Download as pdf or txt
Download as pdf or txt
You are on page 1of 4

CCNP COMMANDS

CH 2 EIGRP
manual
summarization.

R3(config)# interface Serial 0/0/1


R3(config-if)# ip summary-address eigrp 100 192.168.0.0 255.255.224.0

Default Route
Advertisement
Using a Static Route
and Route
Redistribution for
an ISR
Observe equal-cost
load balancing.

R1(config)# router eigrp 100


R1(config)# redistribute static

default network
advertisement.

R1(config)# ip default-network 172.31.0.0

Authentication
link authentication.

R1# conf t
R1(config)# key chain EIGRP-KEYS
R1(config-keychain)# key 1
R1(config-keychain-key)# key-string cisco
R1(config)# interface serial 0/0/0
R1(config-if)# ip authentication key-chain eigrp 1
EIGRP-KEYS
R1(config-if)# ip authentication mode eigrp 1 md5

Manipulate EIGRP
timers.

R1# conf t
R1(config)# interface serial 0/0/0
R1(config-if)# ip hello-interval eigrp 1 2
R1(config-if)# ip hold-time eigrp 1 8

R3(config)# interface S0/0/0


R3(config-if)# no ip route-cache
R3(config-if)# interface S0/0/1
R3(config-if)# no ip route-cache



( ISP

)




2

1
AS
EIGRP

CH 3 OSPF
cost

R1(config)# interface FastEthernet 0/0


R1(config-if)# ip ospf cost 50

bandwidth

R4(config)#int s0/0/0
R4(config-if)#bandwidth 64

authentication

R4(config)#interface Serial0/0/0
R4(config-if)#ip ospf authentication
R4(config-if)#ip ospf authentication-key cisco
R4(config-if)#ip ospf authentication message-digest
R4(config-if)#ip ospf message-digest-key 1 md5 cisco

Eng: Abdullah Hussein Mohammed Thabet


authentication

priority

R1(config)# interface FastEthernet 0/0


R1(config-if)# ip ospf priority 10
R2(config)# interface FastEthernet 0/0
R2(config-if)# ip ospf priority 5
R1(config)# interface loopback 1
R1(config-if)# ip ospf network point-to-point

virtual-link

R2(config)# router ospf 1


R2(config-router)# area 23 virtual-link
192.168.103.1
R3(config)# router ospf 1
R3(config-router)# area 23 virtual-link 10.1.2.1

Stub area

R2(config)# router ospf 1


R2(config-router)# area 23 stub

totally
stubby area.

R2(config)# router ospf 1


R2(config-router)# area 23 stub no-summary

Default routing

R1(config)# router ospf 1


R1(config-router)# default-information originate
always

Hello & dead Time

EAST(config)# interface FastEthernet 0/0


EAST(config-if)# ip ospf hello-interval 5
EAST(config-if)# ip ospf dead-interval 15


DR
BDR
R1 is DR and R2
is BDR





32


192.168.103.1

10.1.2.1 R3
2





23






0.0.0.0


CH 4 Redistrebution
R3(config-router)# router ospf 1
R3(config-router)# redistribute rip subnets metric 30


ospf
ospf
rip

R3(config-router)# router ospf 1


R3(config-router)# redistribute rip subnets
R3(config-router)# default-metric 30

rip
ospf

R1(config)# router ospf 1


R1(config-router)# redistribute eigrp 100 subnets metric-type 1

Eng: Abdullah Hussein Mohammed Thabet

Tow way

R1(config)# router ospf 1


R1(config-router)# default-metric 30
R1(config-router)# redistribute eigrp 100 subnets metric-type 1

R1(config)# router rip


R1(config-router)# redistribute ospf 1 metric 3

R1(config)# router eigrp 100


R1(config-router)# redistribute ospf 1 metric 10000 100 255 1 1500
R1(config-router)#

R1(config)# router eigrp 100


R1(config-router)# default-metric 10000 100 255 1 1500
R1(config-router)# redistribute ospf 1
R1(config)# access-list 1 permit 172.21.16.18 0.0.0.0
R1(config)#
R1(config)# route-map MY-ROUTE-MAP permit 10
R1(config-route-map)# match ip address 1
R1(config-route-map)# set ip next-hop 172.30.3.20
R1(config-route-map)#
R1(config-route-map)# interface S0/0/0
R1(config-if)# ip policy route-map MY-ROUTE-MAP

R1(config)# access-list 23 permit 10.1.0.0 0.0.255.255


R1(config)# access-list 29 permit 172.16.1.0 0.0.0.255
R1(config)# access-list 37 permit 10.0.0.0 0.255.255.255
R1(config)#
R1(config)# route-map REDIS-RIP permit 10
R1(config-route-map)# match ip address 23 29
R1(config-route-map)# set metric 500
R1(config-route-map)# set metric-type type-1
R1(config-route-map)#
R1(config-route-map)# route-map REDIS-RIP deny 20
R1(config-route-map)# match ip address 37
R1(config-route-map)#
R1(config-route-map)# route-map REDIS-RIP permit 30
R1(config-route-map)# set metric 5000
R1(config-route-map)# set metric-type type-2
R1(config-route-map)#
R1(config-route-map)# router ospf 10
R1(config-router)# redistribute rip route-map REDIS-RIP subnets
R1(config-router)#

Eng: Abdullah Hussein Mohammed Thabet


one way

ospf
rip

R1(config-route-map)# router rip


R1(config-router)# redistribute ospf 10 metric 5 route-map OSPFinto-RIP
R2(config)# access-list 7 permit 172.16.0.0 0.0.255.255
R2(config)#
R2(config)# router eigrp 1
R2(config-router)# distribute-list 7 out Serial0/0/0
R2(config-router)#

prefix-list

R1(config)# ip prefix-list TEN-ONLY permit 172.16.10.0/24 ge 17 le


24
R1(config)# router bgp 65000
R1(config-router)# aggregate-address 172.16.0.0 255.255.0.0
R1(config-router)# neighbor 10.1.1.1 remote-as 65001
R1(config-router)# neighbor 10.1.1.1 prefix-list TEN-ONLY out
R1(config-router)# exit

Eng: Abdullah Hussein Mohammed Thabet


ospf
Rip

172.16.0.0
s0/0/0

You might also like