Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 3

You might like to study this example Area 0 ----Area10-----Area-20----Area-30---

--Area 40.

!
hostname R0-10
!
interface Loopback0
ip address 100.100.100.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
duplex auto
speed auto
router ospf 1
log-adjacency-changes
area 10 virtual-link 100.100.100.2
network 10.0.0.1 0.0.0.0 area 10
network 100.100.100.1 0.0.0.0 area 0
R0-10#show ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
100.100.100.2 0 FULL/ - - 10.0.0.2 OSPF_VL1
100.100.100.2 1 FULL/DR 00:00:38 10.0.0.2 FastEthernet0/
0
*
R0-10#show ip route

100.0.0.0/32 is subnetted, 4 subnets


O IA 100.100.100.4 [110/31] via 10.0.0.2, 00:05:26, FastEthernet0/0
C 100.100.100.1 is directly connected, Loopback0
O 100.100.100.2 [110/11] via 10.0.0.2, 00:05:26, FastEthernet0/0
O IA 100.100.100.3 [110/21] via 10.0.0.2, 00:05:26, FastEthernet0/0
10.0.0.0/30 is subnetted, 3 subnets
O IA 10.0.0.8 [110/30] via 10.0.0.2, 00:05:26, FastEthernet0/0
C 10.0.0.0 is directly connected, FastEthernet0/0
O IA 10.0.0.4 [110/20] via 10.0.0.2, 00:05:26, FastEthernet0/0
*
!
hostname R10-20
interface Loopback0
ip address 100.100.100.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.5 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
area 10 virtual-link 100.100.100.1
area 20 virtual-link 100.100.100.3
network 10.0.0.2 0.0.0.0 area 10
network 10.0.0.5 0.0.0.0 area 20
network 100.100.100.2 0.0.0.0 area 10
end
R10-20#show ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
100.100.100.3 0 FULL/ - - 10.0.0.6 OSPF_VL1
100.100.100.1 0 FULL/ - - 10.0.0.1 OSPF_VL0
100.100.100.1 1 FULL/BDR 00:00:35 10.0.0.1 FastEthernet0/
0
100.100.100.3 1 FULL/DR 00:00:34 10.0.0.6 FastEthernet0/
1
R10-20#show ip route
100.0.0.0/32 is subnetted, 4 subnets
O IA 100.100.100.4 [110/21] via 10.0.0.6, 00:08:15, FastEthernet0/1
O 100.100.100.1 [110/11] via 10.0.0.1, 00:08:15, FastEthernet0/0
C 100.100.100.2 is directly connected, Loopback0
O 100.100.100.3 [110/11] via 10.0.0.6, 00:12:01, FastEthernet0/1
10.0.0.0/30 is subnetted, 3 subnets
O IA 10.0.0.8 [110/20] via 10.0.0.6, 00:08:15, FastEthernet0/1
C 10.0.0.0 is directly connected, FastEthernet0/0
C 10.0.0.4 is directly connected, FastEthernet0/1
*
!
hostname R20-30
!
!
interface Loopback0
ip address 100.100.100.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.9 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.6 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
area 20 virtual-link 100.100.100.2
area 30 virtual-link 100.100.100.4
network 10.0.0.6 0.0.0.0 area 20
network 10.0.0.9 0.0.0.0 area 30
network 100.100.100.3 0.0.0.0 area 20
end
R20-30#
R20-30#show ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
100.100.100.4 0 FULL/ - - 10.0.0.10 OSPF_VL1
100.100.100.2 0 FULL/ - - 10.0.0.5 OSPF_VL0
100.100.100.2 1 FULL/BDR 00:00:37 10.0.0.5 FastEthernet0/
1
100.100.100.4 1 FULL/BDR 00:00:31 10.0.0.10 FastEthernet0/
0
R20-30#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
100.0.0.0/32 is subnetted, 4 subnets
O 100.100.100.4 [110/11] via 10.0.0.10, 00:14:24, FastEthernet0/0
O 100.100.100.1 [110/21] via 10.0.0.5, 00:10:52, FastEthernet0/1
O IA 100.100.100.2 [110/11] via 10.0.0.5, 00:10:52, FastEthernet0/1
C 100.100.100.3 is directly connected, Loopback0
10.0.0.0/30 is subnetted, 3 subnets
C 10.0.0.8 is directly connected, FastEthernet0/0
O IA 10.0.0.0 [110/20] via 10.0.0.5, 00:10:52, FastEthernet0/1
C 10.0.0.4 is directly connected, FastEthernet0/1
*
!
hostname R30-40
interface Loopback0
ip address 100.100.100.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.10 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
area 30 virtual-link 100.100.100.3
network 10.0.0.10 0.0.0.0 area 30
network 100.100.100.4 0.0.0.0 area 30
end
R30-40#show ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
100.100.100.3 0 FULL/ - - 10.0.0.9 OSPF_VL0
100.100.100.3 1 FULL/DR 00:00:38 10.0.0.9 FastEthernet0/
0
R30-40#show ip route
100.0.0.0/32 is subnetted, 4 subnets
C 100.100.100.4 is directly connected, Loopback0
O 100.100.100.1 [110/31] via 10.0.0.9, 00:13:32, FastEthernet0/0
O IA 100.100.100.2 [110/21] via 10.0.0.9, 00:13:32, FastEthernet0/0
O IA 100.100.100.3 [110/11] via 10.0.0.9, 00:13:32, FastEthernet0/0
10.0.0.0/30 is subnetted, 3 subnets
C 10.0.0.8 is directly connected, FastEthernet0/0
O IA 10.0.0.0 [110/30] via 10.0.0.9, 00:13:32, FastEthernet0/0
O IA 10.0.0.4 [110/20] via 10.0.0.9, 00:13:32, FastEthernet0/0
R30-40#

You might also like