Download as doc, pdf, or txt
Download as doc, pdf, or txt
You are on page 1of 4

R1

hostname R1
!
!
!
!
interface Loopback0
ip address 200.0.0.1 255.255.255.252
!
interface FastEthernet0
ip address 200.0.1.1 255.255.255.0
speed auto
!
interface Serial0
ip address 100.0.0.1 255.255.255.252
!
interface Serial1
ip address 100.0.0.5 255.255.255.252
!
router bgp 100
bgp log-neighbor-changes
network 200.0.0.0 mask 255.0.0.0
aggregate-address 200.0.0.0 255.0.0.0 summary-only
neighbor 100.0.0.2 remote-as 200
neighbor 100.0.0.6 remote-as 300
neighbor 100.0.0.6 route-map entrada in
neighbor 100.0.0.6 route-map saida out
!
ip classless
ip route 200.0.0.0 255.0.0.0 Null0
no ip http server
ip as-path access-list 1 permit ^300$
!
route-map entrada permit 10
match as-path 1
set local-preference 50
!
route-map entrada permit 20
set local-preference 150
!
route-map saida permit 10
set as-path prepend 100 100 100

R3
hostname R3
!
!
!
!
interface Loopback0
ip address 202.0.1.1 255.255.255.252
!
interface FastEthernet0
ip address 202.0.3.1 255.255.255.0
speed auto
!
interface Serial0
ip address 100.0.0.6 255.255.255.252
!
interface Serial1
ip address 100.0.0.13 255.255.255.252
!
router bgp 300
bgp log-neighbor-changes
network 202.0.0.0 mask 255.255.0.0
aggregate-address 202.0.0.0 255.255.0.0 summary-only
neighbor 100.0.0.5 remote-as 100
neighbor 100.0.0.14 remote-as 400
!
ip classless
ip route 202.0.0.0 255.255.0.0 Null0

R4
hostname R4
!
!
!
!
interface Loopback0
ip address 202.1.1.1 255.255.255.252
!
interface FastEthernet0
ip address 202.1.4.1 255.255.255.0
speed auto
!
interface Serial0
ip address 100.0.0.10 255.255.255.252
!
interface Serial1
ip address 100.0.0.14 255.255.255.252
!
router bgp 400
bgp log-neighbor-changes
network 202.1.0.0 mask 255.255.0.0
aggregate-address 200.0.0.0 254.0.0.0 as-set summary-only
aggregate-address 202.1.0.0 255.255.0.0 summary-only
neighbor 100.0.0.9 remote-as 200
neighbor 100.0.0.13 remote-as 300
!
ip classless
ip route 202.1.0.0 255.255.0.0 Null0

R2
hostname R2
!
!
!
interface Loopback0
ip address 201.0.0.1 255.255.255.252
!
interface FastEthernet0
ip address 201.0.2.1 255.255.255.0
speed auto
!
interface Serial0
ip address 100.0.0.2 255.255.255.252
!
interface Serial1
ip address 100.0.0.9 255.255.255.252
!
router bgp 200
bgp log-neighbor-changes
network 201.0.0.0 mask 255.0.0.0
aggregate-address 201.0.0.0 255.0.0.0 summary-only
neighbor 100.0.0.1 remote-as 100
neighbor 100.0.0.10 remote-as 400
!
ip classless

You might also like