Frame Relay Over Mpls LSP Tunnel Cross Connect Configuration Example

You might also like

Download as pdf or txt
Download as pdf or txt
You are on page 1of 12

Application Note

Frame Relay Over MPLS LSP Tunnel


Cross-connect Configuration Example

Juniper Networks, Inc.


1194 North Mathilda Avenue
Sunnyvale, CA 94089 USA
408 745 2000 or 888 JUNIPER
www.juniper.net
Part Number: 350012-001 04/02

Contents
Purpose . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
Configuring Frame Relay Routers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
Configuring Ingress/Egress Routers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Configuring Circuit Cross-connect . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Configuring MPLS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Configuring Transit Routers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Confirm . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Additional Notes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
References . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Figures
Figure 1: Test Bed Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

Copyright 2002, Juniper Networks, Inc.

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

Purpose
This paper will provide an example of how to configure and troubleshoot Frame Relay via
Circuit Cross-connect (CCC).

Setup
There are three types of routers used in this example: frame relay routers, ingress/egress
routers, and transit routers. Figure 1 shows test bed network with three types of routers.
The following sections will cover configurations for each group using routers listed in Figure 1.
Figure 1: Test Bed Setup
lo0: 3.1.1.1/32

lo0:

lo0: 3.1.1.2/32

49.0001.0301.0101
.0000.00

49.0001.0301.0103
.0000.00

49.0001.0301.0102
.0000.00

Kuku

Paul

Morrey

Slippery

Iggy

M40

M40

M20

M20

M40

So-4/2/1

So-2/0/0

So-2/3/3

So-3/3/2

So-6/0/1

DLCI 514

DLCI 514

192.168.34.5/30

DLCI 513

DLCI 513

So-6/0/1

So-6/0/1

So-6/0/1

192.168.34.1/30

192.168.34.2/30

192.168.34.6/30

68.68.68.2/30

68.68.68.1/30

Configuring Frame Relay Routers


Configuration on Kuku will be used for demonstration in this section. Configuration on Iggy
will be similar.
You will need the following minimum configuration to establish the frame relay connection:

interfaces {
so-4/2/1 {
encapsulation frame-relay;
unit 0 {
point-to-point;
dlci 514;
family inet {
address 68.68.68.1/30;
}
}
}
}
Please note, the DLCIs specified at frame relay routers have to match the DLCIs specified on
the ingress/egress routers. Also, DLCIs selected must be between 512 and 1022, inclusively.
Figure 1 illustrates these two requirements: the DLCIs used at Kuku and Paul are both 514, and
514 is between 512 and 1022.

Copyright 2002, Juniper Networks, Inc.

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

Configuring Ingress/Egress Routers


You need to configure both CCC and MPLS on the Ingress/Egress routers.

Configuring Circuit Cross-connect


You need to configure CCC on the interface to which the frame relay router is connected. For
Paul, the configuration is as follows.

interfaces {
so-2/0/0 {
dce;
encapsulation frame-relay-ccc;
unit 0 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 514;
}
}
}
For Slippery, the configuration follows.

interfaces {
so-3/3/2 {
dce;
encapsulation frame-relay-ccc;
unit 0 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 513;
}
}
}
Note:
Configure encapsulation frame-relay-ccc under both interfaces interface and

unit 0.
dce needs to be specified within interfaces interface.
The DLCI chosen must be between 512 and 1022, inclusively, and must match the DLCI

used on the frame relay routers.


In addition, protocol connections needs to be configured on Paul as follows:

protocols {
connections {
remote-interface-switch ccc2slippery {
interface so-2/0/0.0;
transmit-lsp to-slippery;
receive-lsp to-paul;
}
}
}

Copyright 2002, Juniper Networks, Inc.

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

The configuration is similar on Slippery.

protocols {
connections {
remote-interface-switch ccc2paul {
interface so-3/3/2.0;
transmit-lsp to-paul;
receive-lsp to-slippery;
}
}
}
Note:
interface specified under protocols connections remote-interface-switch is the interface

to which the frame relay connection is made.


The LSPs used under transmit-lsp and receive-lsp are specified in the next section. The

transmit-lsp is configured locally with the local router as an ingress router, while the
receive-lsp is an LSP configured on the router at the other end of this tunnel, with the local
router being the egress router.

Configuring MPLS
For the following example, IS-IS is used as the IGP with level 2 disabled.
On Paul, the following configurations are used.

interfaces {
so-2/0/1 {
unit 0 {
family inet {
address 192.168.34.1/30;
}
family iso;
family mpls;
}
}
lo0 {
unit 0 {
family inet {
address 3.1.1.1/32;
}
family iso {
address 49.0001.0301.0101.0000.00;
}
}
}
}
protocols {
rsvp {
interface all;
}
mpls {
label-switched-path to-slippery {
to 3.1.1.2;
}
interface all;
}

Copyright 2002, Juniper Networks, Inc.

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

isis {
level 2 disable;
interface all;
}
}
On Slippery, the following configuration is used.

interfaces {
so-3/3/1 {
unit 0 {
family inet {
address 192.168.34.6/30;
}
family iso;
family mpls;
}
}
lo0 {
unit 0 {
family inet {
address 3.1.1.2/32;
}
family iso {
address 49.0001.0301.0102.0000.00;
}
}
}
}
protocols {
rsvp {
interface all;
}
mpls {
label-switched-path to-paul {
to 3.1.1.1;
}
interface all;
}
isis {
level 2 disable;
interface all;
}
}
Note:
The LSPs specified under protocols connections remote-interface-switch in the previous
section are defined under protocols mpls on the routers at two ends.

Copyright 2002, Juniper Networks, Inc.

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

Configuring Transit Routers


The transit routers need only to be configured for MPLS support, in addition to IGP (either
IS-IS or OSPF). The configuration on Morrey follows.

interfaces {
so-2/3/2 {
unit 0 {
family inet {
address 192.168.34.2/30;
}
family iso;
family mpls;
}
}
so-2/3/3 {
unit 0 {
family inet {
address 192.168.34.5/30;
}
family iso;
family mpls;
}
}
lo0 {
unit 0 {
family iso {
address 49.0001.0301.0103.0000.00;
}
}
}
}
protocols {
rsvp {
interface all;
}
mpls {
interface all;
}
isis {
level 2 disable;
interface all;
}
}

Copyright 2002, Juniper Networks, Inc.

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

Confirm
After completing the configuration, take the following steps to confirm that everything is
functioning properly.
1. On both ingress/egress routers, check the status of LSPs with the command show mpls
lsp.
A. Check the LSP on Slippery.
lab@slippery> show mpls lsp
Ingress LSP: 1 label-switched paths
To
From
State Rt ActivePath
3.1.1.1
3.1.1.2
Up
0
Total 1 displayed, Up 1, Down 0

P
*

LSPname
to-paul

Egress RSVP: 1 sessions


To
From
State Rt Style Labelin Labelout LSPname
3.1.1.2
3.1.1.1
Up
0 1 FF 100009
to-slippery
Total 1 displayed, Up 1, Down 0
Transit RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0

B. Check the LSP on Paul.


lab@Paul> show mpls lsp
Ingress LSP: 1 label-switched paths
To
From
State Rt ActivePath
3.1.1.2
3.1.1.1
Up
0
to-slippery
Total 1 displayed, Up 1, Down 0

P
*

LSPname

Egress RSVP: 1 sessions


To
From
State Rt Style Labelin Labelout LSPname
3.1.1.1
3.1.1.2
Up
0 1 FF 100027
- to-paul
Total 1 displayed, Up 1, Down 0
Transit RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0

You should see an ingress and an egress LSP on both routers. The state should be UP.
C. In addition, show mpls lsp can be used on the transit routers to confirm LSPs are
traversing through these routers.
Check the LSP on Morrey.
lab@morrey> show mpls lsp
Ingress LSP: 0 label-switched paths
Total 0 displayed, Up 0, Down 0
Egress RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0
Transit RSVP: 2 sessions
To
From
State Rt Style Labelin Labelout LSPname
3.1.1.1
3.1.1.2
Up
1 1 FF 100014
100027 to-paul
3.1.1.2
3.1.1.1
Up
1 1 FF 100012
100009
to-slippery
Total 2 displayed, Up 2, Down 0

Copyright 2002, Juniper Networks, Inc.

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

2. Check RSVP statistics on the ingress/egress and transit routers for clues about any
problems experienced by RSVP. It is a good idea to clear the RSVP counters with clear rsvp
statistics first before issuing the command show rsvp statistics.
The following is sample output of show rsvp statistics.
lab@Paul> show rsvp statistics
PacketType
Total
Sent
Received
Path
125658
124410
PathErr
1178
58
PathTear
5104
2950
Resv FF
0
0
Resv WF
0
0
Resv SE
116684
115990
ResvErr
0
0
ResvTear
443
14
ResvConf
0
0
Hello
1042831
1035766
Errors
Total
Rcv pkt bad length
0
Rcv pkt unknown type
0
Rcv pkt bad version
0
Rcv pkt auth fail
0
Rcv pkt bad checksum
0
Rcv pkt bad format
0
Memory allocation fail
0
No path information
1
Resv style conflict
0
Port conflict
0
Resv no interface
0
PathErr to client
17
ResvErr to client
0
Path timeout
1000
Resv timeout
1

Last 5 seconds
Sent
Received
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
4
4
Last 5 seconds
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

3. In addition, you can use show rsvp session detail to find more information about
the status of different LSPs in a router. The following output is an example of show rsvp
session detail.
NOTE

The output below was not captured from the test bed shown in Figure 1 and is provided as a
reference; the addresses used do not match those used in Figure 1.
user@host> show rsvp session detail
Ingress RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0
Egress RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0
Transit RSVP: 1 sessions
192.168.2.34
From: 101.0.0.1, LSPstate: Up, ActiveRoute: 1, LSPname: sfo1
Resv style: 1 FF, Label in: 1024, Label out: 0
Time left: 123, Since: Sat Feb 13 12:45:42 1999
Tspec: rate 0bps size 0bps peak 320Tbps m 20 M 1500
Port number: sender 1 receiver 18 protocol 255
PATH rcvfrom: 192.168.2.17
(so-2/0/0) 1568 pkts
PATH sentto: 192.168.2.34
(so-0/0/0) 1568 pkts
RESV rcvfrom: 192.168.2.34
(so-0/0/0) 1568 pkts
Record route: 192.168.2.17
<self>
192.168.2.34
Total 1 displayed, Up 1, Down 0

Copyright 2002, Juniper Networks, Inc.

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

4.

On both ingress/egress routers, check the CCC connections with show connections.
A. On Slippery:

lab@slippery> show connections


CCC connections
Legend for status (St)
UN -- uninitialized
NP -- not present
WE -- wrong encapsulation
DS -- disabled
Dn -- down
-> -- only outbound conn is up
<- -- only inbound conn is up
Up -- operational
Connection/Circuit
trans
ccc2paul
so-3/3/2.0
to-paul
to-slippery

Legend for connection types


if-sw: interface switching
rmt-if: remote interface switching
lsp-sw: LSP switching
Legend for circuit types
intf -- interface
tlsp -- transmit LSP
rlsp -- receive LSP
Type

St

Time last up

rmt-if
intf
tlsp
rlsp

Up
Up
Up
Up

Dec 29 02:20:19

# Up
9

B. On Paul:
lab@Paul> show connections
CCC connections
Legend for status (St)
UN -- uninitialized
NP -- not present
switching
WE -- wrong encapsulation
DS -- disabled
Dn -- down
-> -- only outbound conn is up
<- -- only inbound conn is up
Up -- operational
Connection/Circuit
trans
ccc2slippery
so-2/0/0.0
to-slippery
to-paul

Legend for connection types


if-sw: interface switching
rmt-if: remote interface
lsp-sw: LSP switching
Legend for circuit types
intf -- interface
tlsp -- transmit LSP
rlsp -- receive LSP
Type

St

Time last up

rmt-if Up Dec 28 19:18:46


intf Up
tlsp Up
rlsp Up

# Up
7

The states for remote-interface-switch, interface, and LSPs should all be UP. If any one of
these fields is not UP, further troubleshooting of the entry without UP state is required.
5. Check the interface status on frame relay routers with show interface terse. The
status should show up/up.
A. On Iggy:
lab@iggy> show interfaces terse
Interface
Admin Link Proto Local
<snip>
up
up
so-6/0/1
so-6/0/1.0
up
up
inet 68.68.68.2/30
<snip>

Copyright 2002, Juniper Networks, Inc.

Remote

10

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

B. On Kuku:
lab@kuku> show interfaces terse
Interface
Admin Link Proto Local
<snip>
so-4/2/1
up
up
so-4/2/1.0
up
up
inet 68.68.68.1/30
<snip>

Remote

6. Ping the remote routers frame relay or other interfaces. You should be able to ping
without problems.
On Iggy:
lab@iggy> ping 68.68.68.1
PING 68.68.68.1 (68.68.68.1): 56 data bytes
64 bytes from 68.68.68.1: icmp_seq=0 ttl=255 time=1.258 ms
64 bytes from 68.68.68.1: icmp_seq=1 ttl=255 time=1.247 ms
64 bytes from 68.68.68.1: icmp_seq=2 ttl=255 time=1.222 ms
64 bytes from 68.68.68.1: icmp_seq=3 ttl=255 time=1.160 ms
^C
--- 68.68.68.1 ping statistics --4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.160/1.222/1.258/0.038 ms
7. Check the routing updates to confirm that proper routing protocol relationships are
formed.
NOTE

BGP and OSPF were configured on Kuku and IGGY, which were not shown in the
configuration presented thus far.

lab@iggy> show bgp summary


Groups: 1
Peers: 1 Down Peers: 0
Table
Tot Paths Act Paths Suppressed
History Damp State
Pending
inet.0
0
0
0
0
0
0
inet.2
0
0
0
0
0
0
Peer
AS
InPkt
OutPkt
OutQ
Flaps Last Up/Dwn
State|#Active/Received/Damped...
68.68.68.1
134
68
69
0
0
00:33:09 0/0/0
0/0/0
lab@iggy> show ospf neighbor
Address
Interface
State
ID
Pri Dead
68.68.68.1
so-6/0/1.0
Full
172.17.4.81
128
39

Copyright 2002, Juniper Networks, Inc.

11

Frame Relay Over MPLS LSP Tunnel Cross-connect Configuration Example

Additional Notes
IS-IS may not form adjacencies across tunnels if the IS-IS MTU plus overheads is larger than
the MPLS MTU. Use the following formula to calculate the maximum IS-IS MTU size:
IS-IS MTU <= MPLS MTU 4 bytes link-layer overhead
Where link-layer overheads for different encapsulations are:
ATM 8 bytes
Frame Relay 2 bytes
HDLC 4 bytes
PPP 4 bytes
If you have problems or questions, please contact Juniper Customer Service at 1-888-314-JTAC
(North America only).

References
JUNOS Internet Software Configuration Guide

Copyright 2002, Juniper Networks, Inc. All rights reserved. Juniper Networks is registered in the U.S. Patent and Trademark Office and in other countries
as a trademark of Juniper Networks, Inc. Broadband Cable Processor, G10, Internet Processor, JUNOS, JUNOScript, M5, M10, M20, M40, M40e, M160,
M-series, T640, and T-series, are trademarks of Juniper Networks, Inc. All other trademarks, service marks, registered trademarks, or registered service marks
are the property of their respective owners. All specifications are subject to change without notice.
Juniper Networks assumes no responsibility for any inaccuracies in this document. Juniper Networks reserves the right to change, modify, transfer, or otherwise
revise this publication without notice.

Copyright 2002, Juniper Networks, Inc.

12

You might also like