BGP - Part 5 (Packet Tracer BGP Configuration Example)

You might also like

Download as pdf or txt
Download as pdf or txt
You are on page 1of 11

BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.

com/bgp-part-5-packet-tracer-bgp-configuration-example/

www.ipcisco.com
Challenge IP Networking
IPCisco
Bookcase
About
Network Tools
Technology Forecasts
Contact Us

BGP Part 5 (Packet Tracer BGP Configuration Example)


Category: BGP, Cisco, Packet Tracer, Routing
Author: gokhankosem, on 03 Apr 15 - 2 Comments

Packet Tracer BGP Configuration

************************************************************
IF YOU DO NOT KNOW HOW TO USE CISCO PACKET TRACER, YOU CAN START
WITH OUR CISCO PACKET TRACER HOW TO GUIDE COURSE, IN UDEMY.COM.
************************************************************

To understand BGP (Border Gateway Protocol) better, we will make a basic BGP configuration on Cisco IOS. This configuration will be on packet
tracer. Because of the limited numbers of commands available on it, we will have a very basic configuration. Beside this, I will add some additional
cofiguration steps that is needed for IBGP but we can not configure on Packet Tracer.

In the configuratin we will use two AS (Autonomous System) with 3 routers for each. We will use the private AS block (64512 to 65535) for this
configuration, but in internet public AS numbers are used.

The topology that we will use is below:

BGP Configuration Topology

For this configuration, firstly we need to configure the IP addresses of interfaces as other examples. To do this, as a better network engineering rule,

1 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

firstly make your IP plan or, use the existing one. Acording to my basic IP plan, I used the below IPs for my interfaces.

Interfaces IP Addresses
1.1.1.1
2.2.2.2
10.0.0.1
10.0.0.2
20.0.0.1
20.0.0.2
30.0.0.1
30.0.0.2
40.0.0.1
40.0.0.2
50.0.0.1
50.0.0.2

Interface Configurations

RouterA1 Interface Configuration

RouterA1(config)#interface loopback 0
RouterA1(config-if)#ip address 1.1.1.1 255.255.255.255
RouterA1(config-if)#no shutdown
RouterA1(config-if)#exit
RouterA1(config)#interface gigabitEthernet 0/0
RouterA1(config-if)#ip address 10.0.0.1 255.255.255.0
RouterA1(config-if)#no shutdown
RouterA1(config-if)#exit
RouterA1(config)#interface gigabitEthernet 0/1
RouterA1(config-if)#ip address 20.0.0.1 255.255.255.0
RouterA1(config-if)#no shutdown
RouterA1(config)#interface gigabitEthernet 0/2
RouterA1(config-if)#ip address 30.0.0.1 255.255.255.0
RouterA1(config-if)#no shutdown

RouterB1 Interface Configuration

RouterB1(config)#interface loopback 0
RouterB1(config-if)#ip address 2.2.2.2 255.255.255.255
RouterB1(config-if)#no shutdown
RouterB1(config-if)#exit
RouterB1(config)#interface gigabitEthernet 0/0
RouterB1(config-if)#ip address 10.0.0.2 255.255.255.0
RouterB1(config-if)#no shutdown
RouterB1(config-if)#exit
RouterB1(config)#interface gigabitEthernet 0/1
RouterB1(config-if)#ip address 40.0.0.1 255.255.255.0
RouterB1(config-if)#no shutdown
RouterB1(config-if)#exit
RouterB1(config)#interface gigabitEthernet 0/2
RouterB1(config-if)#ip address 50.0.0.1 255.255.255.0
RouterB1(config-if)#no shutdown

RouterA2 Interface Configuration

RouterA2(config)#interface gigabitEthernet 0/1


RouterA2(config-if)#ip address 20.0.0.2 255.255.255.0
RouterA2(config-if)#no shutdown

RouterA3 Interface Configuration

RouterA3(config)#interface gigabitEthernet 0/2


RouterA3(config-if)#ip address 30.0.0.2 255.255.255.0
RouterA3(config-if)#no shutdown

RouterB2 Interface Configuration

RouterB2(config)#interface gigabitEthernet 0/1

2 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

RouterB2(c
RouterB2(c

RouterB3 Interface Configuration

RouterB3(config)#interface gigabitEthernet 0/2


RouterB3(config-if)#ip address 50.0.0.2 255.255.255.0
RouterB3(config-if)#no shutdown

BGP Configurations

The exact important point of this configuration is here. The configuration made in this part, is for the BGP.

As I said before, because of the Packet Tracer s command limit, in the configuration file, th IBGP parts are not configured, but writen here (ibgp
neighbourship and route reflector commands).

RouterA1(config)#router bgp 64600


RouterA1(config-router)#neighbor 10.0.0.2 remote-as 64700
RouterA1(config-router)#neighbor 20.0.0.2 remote-as 64600
RouterA1(config-router)#neighbor 30.0.0.2 remote-as 64600
RouterA1(config-router)#neighbor 20.0.0.2 route-reflector-client
RouterA1(config-router)#neighbor 30.0.0.2 route-reflector-client
RouterA1(config-router)#network 20.0.0.0 mask 255.255.255.0
RouterA1(config-router)#network 30.0.0.0 mask 255.255.255.0

RouterB1(config)#router bgp 64700


RouterB1(config-router)#neighbor 10.0.0.2 remote-as 64600
RouterB1(config-router)#neighbor 40.0.0.2 remote-as 64700
RouterB1(config-router)#neighbor 50.0.0.2 remote-as 64700
RouterB1(config-router)#neighbor 40.0.0.2 route-reflector-client
RouterB1(config-router)#neighbor 50.0.0.2 route-reflector-client
RouterB1(config-router)#network 40.0.0.0 mask 255.255.255.0
RouterB1(config-router)#network 50.0.0.0 mask 255.255.255.0

RouterA2(config)#router bgp 64600


RouterA2(config-router)#neighbor 20.0.0.1 remote-as 64600

RouterA3(config)#router bgp 64600

3 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

RouterA3(config-router)#neighbor 30.0.0.2 remote-as 64600

RouterB2(config)#router bgp 64700


RouterB2(config-router)#neighbor 40.0.0.1 remote-as 64700

RouterB3(config)#router bgp 64700


RouterB3(config-router)#neighbor 50.0.0.2 remote-as 64700

BGP Verification Commands

After the configuration you can verfy your configuration with the below commands:

show ip bgp
show ip bgp summary
show ip bgp neighbours

There is also one show ip bgp rib-failure command which is used to displays routes that were not inserted into the IP routing table. The reason of
this also can be seen with this commands output.

RouterA1#show ip bgp
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


*> 20.0.0.0/24 0.0.0.0 0 0 32768 i
*> 30.0.0.0/24 0.0.0.0 0 0 32768 i
*> 40.0.0.0/24 10.0.0.2 0 0 0 64700 i
*> 50.0.0.0/24 10.0.0.2 0 0 0 64700 i

RouterA1#show ip bgp summary


BGP router identifier 1.1.1.1, local AS number 64600
BGP table version is 5, main routing table version 6
4 network entries using 528 bytes of memory
4 path entries using 208 bytes of memory
2/2 BGP path/bestpath attribute entries using 368 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1184 total bytes of memory
BGP activity 4/0 prefixes, 4/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd10.0.0.2 4 64700 4 2 5 0 0 00:00:36 4

RouterA1#show ip bgp neighbors


BGP neighbor is 10.0.0.2, remote AS 64700, external link
BGP version 4, remote router ID 2.2.2.2
BGP state = Established, up for 00:00:41
Last read 00:00:41, last write 00:00:41, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(new)
Address family IPv4 Unicast: advertised and received
Message statistics:

4 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

InQ depth is 0
OutQ depth is 0

Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 2 2
Keepalives: 1 1
Route Refresh: 0 0
Total: 4 4
Default minimum time between advertisements runs is 30 seconds

For address family: IPv4 Unicast


BGP table version 5, neighbor version 6/0
Output queue size : 0
Index 1, Offset 0, Mask 0x2
1 update-group member
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 2 2 (Consumes 92 bytes)
Prefixes total: 2 2
Implicit Withdraw: 0 0
Explicit Withdraw: 0 0
Used as bestpath: n/a 1
Used as multipath: n/a 0

Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 3, min 1

Address tracking is enabled, the RIB does have a route to 10.0.0.2


Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Minimum incoming TTL 0, Outgoing TTL 1
Local host: 10.0.0.1, Local port: 179
Foreign host: 10.0.0.2, Foreign port: 1025
Connection tableid (VRF): 0

Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)

Event Timers (current time is 0xC69F4):


Timer Starts Wakeups Next
Retrans 0 0 0x0
TimeWait 0 0 0x0
AckHold 3 0 0x0
SendWnd 0 0 0x0
KeepAlive 1 0 0x0
GiveUp 0 0 0x0
PmtuAger 0 0 0x0
DeadWait 0 0 0x0
Linger 0 0 0x0
ProcessQ 0 0 0x0

iss: 2057115318 snduna: 2057115748 sndnxt: 2057115748 sndwnd: 15955


irs: 3480424370 rcvnxt: 3480424751 rcvwnd: 16004 delrcvwnd: 380

SRTT: 259 ms, RTTO: 579 ms, RTV: 320 ms, KRTT: 0 ms
minRTT: 16 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):


Rcvd: 4 (out of order: 0), with data: 0, total data bytes: 0
Sent: 2 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 2, total data bytes: 48
Packets received in fast path: 0, fast processed: 0, slow path: 0
fast lock acquisition failures: 0, slow path: 0

Download the Packet Tracer example with .pkt format here.

************************************************************
IF YOU DO NOT KNOW HOW TO USE CISCO PACKET TRACER, YOU CAN START
WITH OUR CISCO PACKET TRACER HOW TO GUIDE COURSE, IN UDEMY.COM.
************************************************************

5 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

You can download Packet Tracer in Tools section.

In the following articles, we will deeply talk about BGP. Keep on IPcisco.com ;)

BGP Part 1
BGP Part 2 (BGP Peers, BGP Sessions, BGP Messages)
BGP Part 3 (IBGP, IBGP Topologies and EBGP)
BGP Part 4 (BGP Administrative Distance and BGP Path Attributes)
BGP Part 5 (Packet Tracer BGP Configuration Example)

You can check the other Packet Tracer Examples below:

Common Cisco Router Configuration Example on Packet Tracer


Router DHCP Configuration Example on Packet Tracer
VTP Configuration Example on Packet Tracer
VLAN Configuration Example on Packet Tracer
STP Configuration Example on Packet Tracer
BGP Configuration Example on Packet Tracer
Port Security Configuration Example on Packet Tracer
RIP Configuration Example on Packet Tracer
CDP Configuration Example on Packet Tracer
OSPF Area Types Example on Packet Tracer (Standard and Backbone Areas)
OSPF External Routes Example on Packet Tracer
OSPF Area Types Example on Packet Tracer (Stub, NSSA, Totally Stubby, Totally NSSA Areas)

Youn can join OUR Facebook Group with the below links!!!

About the Author


Gokhan Kosem is a telecommunation and network engineer. His ambition to
IP networks and end-to-end system installation made him to prepare this
web-site. By sharing his experiences about various networking protocols
beside different system installation experiences and Cisco, Juniper, Alcatel-
Lucent devices configurations, he is aimed to be helpful for his collegues in
all over the world. He is currently lives in Istanbul, Turkey.

2 comments for BGP Part 5 (Packet Tracer BGP Configuration Example)

1
Adhi

Whats version of packet tracer you use to implement IBGP?

July 31st, 2015 at 05:54


2
TODAN

Hello
BGP works with any version of Packet Tracer.
But in the tutorial it to mentione that the IBGP does not work on packet trace but to insert commands.
So you can try with GNS3 if you want implemanter IBGP
Or you buy real router

October 20th, 2015 at 18:55

6 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

Leave a Reply

Name (required)

E-Mail(required)

Url

Search

7 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

Would you Like to Follow an


Internet of Things (IoT) Product Blog ?

Recent Articles
EIGRP Configuration With Packet Tracer
EIGRP Part 4 (Other EIGRP Properties)
EIGRP Part 3 (EIGRP Packet Types and Neighbourship)
EIGRP Part 2 (EIGRP Tables)

8 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

EIGRP Part 1
RSTP Configuration on Packet Tracer
STP Portfast Configuration with Packet Tracer
Switch Virtual Interface Configuration on Packet Tracer
Inter VLAN Routing Configuration on Packet Tracer (Router on Stick)
Routing With IS-IS Protocol Part 5 (IS-IS versus OSPF)

Categories
2.5G GPRS (1)
2G GSM (1)
4G LTE (2)
Alcatel-Lucent (30)
Alcatel-Lucent (3)
Alcatel-Lucent (6)
Alcatel-Lucent Certification (33)
All IP (2)
Basic (19)
BGP (11)
CCDP (5)
CCIE (39)
CCIE SP (19)
CCNA (50)
CCNP (63)
CCNP SP (18)
CDP (3)
Cisco (57)
Cisco Certification (87)
Cisco IOS XR (1)
DHCP (1)
ECMP (1)
EDGE (1)
EIGRP (5)
EtherChannel (1)
Ethernet (1)
Fast Reroute (9)
Forecasts (1)
Frame Relay (3)
General (1)
GLBP (2)
GNS3 (3)
HSRP (3)
IES (4)
IES (3)
IES (3)
IoT (2)
IPTV (2)
IPv4 (1)
IPv6 (9)
IS-IS (5)
JNCIA (18)
JNCIE (13)
JNCIP (18)
Juniper (20)
Juniper Certification (30)
LACP (5)
LDP (8)
Link Aggregation (5)
LLDP (3)
M2M (2)
Mobile (1)
MPLS (26)
Multicast (2)
NAT (4)
Neighbour Discovery (5)

9 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

Network Certifications (81)


Network Management (5)
Network Monitoring (1)
NRS I (17)
NRS II (20)
OSPF (12)
Packet Tracer (18)
Packet Tracer (1)
Packets (1)
PAgP (2)
Redundancy (5)
RIP (2)
Routing (43)
RSVP-TE (2)
SAM (1)
Secondary Paths (9)
Security (1)
Services (14)
Services (3)
Services (6)
SNMP (5)
SRA (18)
Static Routing (6)
STP (3)
switch security (2)
Switching (19)
TCP/IP (5)
Technology Forecasts (1)
Telecom (5)
Troubleshooting (1)
VLAN (10)
VPLS (9)
VPLS (3)
VPLS (3)
VPRN (6)
VPRN (3)
VPRN (3)
VPWS (7)
VPWS (3)
VPWS (6)
VRRP (2)
VTP (2)
Wireless (5)

10 de 11 18/01/2017 10:43 p.m.


BGP Part 5 (Packet Tracer BGP Configuration Example) | www.ipcisc... http://ipcisco.com/bgp-part-5-packet-tracer-bgp-configuration-example/

Copy Protected by Chetans WP-Copyprotect.

11 de 11 18/01/2017 10:43 p.m.

You might also like