Cisco IOS Cisco XR Difference Guide

You might also like

Download as pdf or txt
Download as pdf or txt
You are on page 1of 40

Converting Cisco IOS Configurations to

Cisco IOS XR Configurations

This module discusses converting a Cisco IOS configuration to a Cisco IOS XR configuration. It is not
a complete guide to converting every command or configuration from Cisco IOS to Cisco IOS XR, but
covers only the features most commonly used. There may be features in Cisco IOS that you are
interested in that do not appear in this document.
The configurations presented here use Cisco IOS XR 3.2 as a reference.
This document is not an introduction to Cisco IOS XR, nor is it an introduction to any of the features
you can configure in Cisco IOS. It assumes that you are familiar with the differences in operating
infrastructure between Cisco IOS and Cisco IOS XR, and that you know how the protocols work.

Contents
General Differences Between Cisco IOS and Cisco IOS XR, page 2
Cisco IOS Configurations That Do Not Exist in Cisco IOS XR, page 2
Cisco IOS Configurations That Are the Same in Cisco IOS XR, page 5
Cisco IOS Configurations That Are Similar in Cisco IOS XR, page 5
Basic Interface Configuration, page 7
IPv4 Unicast Routing and Forwarding, page 8
Multiprotocol Label Switching (MPLS), page 23
Quality of Service (QoS), page 26
IPv6, page 28
Other Cisco IOS XR Issues, page 29
Translating Cisco IOS Route Maps to Cisco IOS XR Routing Policy Language, page 34

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


1
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
General Differences Between Cisco IOS and Cisco IOS XR

General Differences Between Cisco IOS and Cisco IOS XR


In Cisco IOS XR, features are generally disabled by default and must be explicitly enabled. This means
that, for example, you need to explicitly enable the address-family ipv4 unicast command in some
routing protocols (IS-IS, BGP), whereas you did not need to do it in Cisco IOS. This also means that
external services that listen to TCP/UDP ports and IP protocols (telnet, ssh, tcp-small-servers, and so
forth) are off unless you turn them on.
In general, use the following guidelines when initially converting between operating systems:
Do not configure new features without understanding them first.
Do not turn on features in Cisco IOS XR that are turned off in your Cisco IOS configuration.
Do not assume that you need all the same features in Cisco IOS XR that you needed in Cisco IOS.
Think before you add or remove features. Is the feature really something you use, or are you just
carrying it over because it is in your Cisco IOS configuration?
Test changes carefully and ask for help if you are having difficulty.
After you have successfully converted your existing Cisco IOS configuration to a working
Cisco IOS XR configuration, you may want to try some of the additional features in Cisco IOS XR. For
more information on these, consult the standard Cisco IOS XR configuration guides:
Cisco IOS XR IP Addresses and Services Configuration Guide
Cisco IOS XR Interface and Hardware Component Configuration Guide
Cisco IOS XR Multicast Configuration Guide
Cisco IOS XR Multiprotocol Label Switching Configuration Guide
Cisco IOS XR Modular Quality of Service Configuration Guide
Cisco IOS XR Routing Configuration Guide
Cisco IOS XR System Management Configuration Guide
Cisco IOS XR System Security Configuration Guide

Cisco IOS Configurations That Do Not Exist in Cisco IOS XR


The following table lists some of the Cisco IOS configurations that do not exist in Cisco IOS XR. The
Cisco IOS column contains either a configuration string or a partial configuration string. If it is partial
(like ip tftp ), that means that only the top level text has changed and options past the listed text are
the same in Cisco IOS and Cisco IOS XR.
The Cisco IOS XR columncontains the text "No such configuration" or "No such keyword." "No such
configuration" means that the service that is configured in Cisco IOS cannot be configured in
Cisco IOS XR (largely because the feature does not exist, such as the Cisco IOS version command). "No
such keyword" means that, although the configuration exists, the specific keyword listed in the
Cisco IOS configuration does not exist in Cisco IOS XR. Both types of entries may also have a comment
explaining what happened to the Cisco IOS functionality.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


2
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Cisco IOS Configurations That Do Not Exist in Cisco IOS XR

Table 2 List of Cisco IOS Configurations That Do Not Exist in Cisco IOS XR

Cisco IOS Cisco IOS XR


aaa authentication enable No such keyword.
Cisco IOS XR has no concept of changing enable level
when logged in; all permissions are defined in the
usergroup/taskgroup model.
aaa new-model No such configuration.
There is no old model authentication, authorization, and
accounting (AAA) in
Cisco IOS XR.
access-list compiled No such configuration.
Cisco IOS XR does its own access control List (ACL)
management with no configurable input from the user.
access-list number No such configuration.
All ACLs are configured using ipv4 access-list submode;
see the ACL section later on.
boot system ... No such configuration.
The Cisco IOS XR boot model is very different from
Cisco IOS boot model.
enable No such configuration.
You must have a username. The password and enable level
ability are defined within the username and taskgroup
set of commands.
ip bgp-community new-format No such configuration.
Community-lists, which support old-style numbering, are
being phased out. See also the extensive section on
Border Gateway Protocol (BGP) later in this document.
ip bootp server No such configuration.
No BOOTP server exists in Cisco IOS XR.
ip classless No such configuration,
Cisco IOS XR fully supports classless interdomain
routing (CIDR) and variable-length subnet mask (VLSM).
There is no classful routing in
Cisco IOS XR, so so there is no need to enable classless
behavior.
ip finger No such keyword.
There is no finger daemon on Cisco IOS XR.
ip receive No such configuration.
There is no support for Receive ACLs in
Cisco IOS XR.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


3
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Cisco IOS Configurations That Do Not Exist in Cisco IOS XR

Table 2 List of Cisco IOS Configurations That Do Not Exist in Cisco IOS XR (continued)

Cisco IOS Cisco IOS XR


ip spd No such configuration.
There is no Selective Packet Discard (SPD) in
Cisco IOS XR. A feature called Local Packet Transfer
Services (LPTS) somewhat obviates the need for SPD;
LPTS is not configurable and is not discussed in this
document.
ip subnet-zero No such configuration.
This behavior is automatic. Cisco IOS XR is fully
classless and CIDR-capable.
mpls label protocol ldp No such configuration.
There is no Tag Distribution Protocol (TDP) in
Cisco IOS XR, so no need to pick between Label
Distribution Protocol (LDP) and TDP.
mpls traffic-eng auto-bw No such configuration.
There is no support for Traffic Engineering (TE) auto-bw
in Cisco IOS XR.
no service pad No such configuration.
service compress-config No such configuration.
Configuration file management is very different between
Cisco IOS and Cisco IOS XR
service nagle No such configuration.
nagle is on by default, and this cannot be changed by the
user.
service password-encryption No such configuration.
You cannot have unencrypted passwords in
Cisco IOS XR
service tcp-keepalives-in No such configuration.
In Cisco IOS XR, it is up to the application to decide
whether to use keepalives or not, and none of this is
configurable. The telnet server sends keepalives every 5
minutes. Telnet client does not send them. Other
TCP-based protocols (BGP, SSH, and so on) have similar
built-in keepalive values.
service tcp-keepalives-out No such configuration.
service upgrade all No such configuration.
tag-switching No such configuration.
All the tag-switching CLI is gone, replaced with
Multiprotocol Label Switching (MPLS)
version No such configuration.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


4
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Cisco IOS Configurations That Are the Same in Cisco IOS XR

Cisco IOS Configurations That Are the Same in Cisco IOS XR


The following table lists some of the configurations that are identical in Cisco IOS and Cisco IOS XR.
The Cisco IOS column contains either a configuration string or a partial configuration string. If it is
partial, like ip tftp , that means that all options past the listed text are the same in Cisco IOS and
Cisco IOS XR.

Table 3 List of Cisco IOS Configurations That Are the Same in Cisco IOS XR

Cisco IOS Cisco IOS XR


banner Same
hostname hostname Same
service timestamps debug datetime msec Same
service timestamps log datetime msec Same
snmp-server Same

Cisco IOS Configurations That Are Similar in Cisco IOS XR


The following table lists some of the Cisco IOS configurations that differ from their Cisco IOS XR
counterparts in minor ways. The Cisco IOS column contains either a configuration string or a partial
configuration string. If it is partial like ip tftp , only the top level text has changed and options past
the listed text are the same in Cisco IOS and Cisco IOS XR.
The Cisco IOS XR column contains an explanation of the differences between the two configurations.

Table 4 List of Cisco IOS Configurations That Are Similar in Cisco IOS XR

Cisco IOS Cisco IOS XR


aaa authentication login name tacacs+ aaa authentication login name group tacacs+
Note the group before tacacs+; this is common for all
aaatacacs+commands.
aaa authorization commands level aaa authorization commands {default | list-name}
{default | list-name}tacacs+ group tacacs+
Note the lack of a level, because Cisco IOS XR
permissions are different from those of Cisco IOS.
aaa accounting exec {default | list-name} aaa accounting exec {default | list-name} {start-stop |
{start-stop | stop-only} tacacs+ stop-only} group tacacs+
Note the group before tacacs+.
aaa accounting commands level aaa accounting commands {default | list-name}
{default | list-name} {start-stop | {start-stop | stop-only} group tacacs+
stop-only} tacacs+
Note the lack of a level; see also the taskgroup section
below.
ip tcp path-mtu-discovery tcp path-mtu-discovery age-timer minutes
ip telnet source-interface telnet ipv4 client source-interface

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


5
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Cisco IOS Configurations That Are Similar in Cisco IOS XR

Table 4 List of Cisco IOS Configurations That Are Similar in Cisco IOS XR (continued)

Cisco IOS Cisco IOS XR


ip tftp tftp client
ip ftp ... ftp client ...
ip name-server domain name-server
ip route network mask route ipv4 network/masklen ...
Router# ip route 10.0.0.0 255.0.0.0 RP0/0/RP0/CPU0:router# route ipv4 unicast
10.0.0.0/8 ...

All the options available after the network and mask in


Cisco IOS (outgoing interface, next-hop, tag, admin
distance, and so forth) are also available after the
network/masklen with the same CLI, in
Cisco IOS XR.
line {aux | console} 0 line {aux | console}
No line number is necessary. See also the VTY section
later in this document.
logging buffered 1000000 debugging The debug level and the buffer size are now two separate
commands:
logging buffered 150000
logging buffered debugging
redundancy redundancy disable
Redundancy is enabled by default in Cisco IOS XR.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


6
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Basic Interface Configuration

Basic Interface Configuration


A few differences in interface configuration are shown in the examples below:

Table 5 Basic Interface Configuration for Cisco IOS Versus Cisco IOS XR

Cisco IOS Cisco IOS XR


interface POS2/1 interface POS0/2/0/1
ip address 192.168.14.5 255.255.255.0 mtu 4474
no ip directed-broadcast ipv4 address 192.168.14.8 255.255.255.0
crc 32 pos
clock source internal crc 32
pos ais-shut !
pos scramble-atm !
end controller SONET0/2/0/1
ais-shut
path
ais-shut
!
clock source internal
!

The major differences are as follows:


The use of a separate SONET controller configuration mode in Cisco IOS XR.
The use of the ipv4 address command in Cisco IOS XR in place ofthe ip address command in
Cisco IOS.
The Cisco IOS XR configuration has both ais-shut and path ais-shut commands configured. This
does not map exactly to the Cisco IOS pos ais-shut command, which enables only line ais-shut, but
you achieve the same thing with the two configurations.
Only Packet-over-SONET (PoS) specific configurations (configurations having to do with
High-level Data Link Control (HDLC) and Point-to-Point Protocol (PPP) payload and how they are
put into a Synchronous Payload Envelope [SPE]) go on the interface in Cisco IOS XR.
The crc command is issued in the (config-if-pos) submode in Cisco IOS XR.
The ais-shut, clock, path, and other commands in the (config-SONET-path) submode are issued
while in SONET controller submode in Cisco IOS XR.
Payload scrambling (pos scramble-atm in Cisco IOS) is on by default in Cisco IOS XR. It can be
disabled using the path scrambling disable command.
For further information on SONET controller configuration and PoS configurations, including PPP and
HDLC, see the following configuration guide and command reference modules:
The Configuring SONET Controller Interfaces on Cisco IOS XR Software module of the
Cisco IOS XR Interface and Hardware Component Configuration Guide
The Configuring POS Interfaces on Cisco IOS XR Software module of the
Cisco IOS XR Interface and Hardware Component Configuration Guide
The Packet-over-SONET User Interface and SONET Layer-1 Commands on Cisco IOS XR Software
module of the Cisco IOS XR Interface and Hardware Component Command Reference
The SONET APS Commands on Cisco IOS XR Software module of the Cisco IOS XR Interface and
Hardware Component Command Reference

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


7
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

The cHDLC Commands on Cisco IOS XR Software module of the Cisco IOS XR Interface and
Hardware Component Command Reference
The PPP Commands on Cisco IOS XR Software module of the Cisco IOS XR Interface and
Hardware Component Command Reference

Note The other interface type supported in Cisco IOS XR is the Gigabit Ethernet (GigE) interface. The GigE
interface does not have a controller submode and, therefore, configuration of GigE is similar to
configuration of GigE in Cisco IOS.

IPv4 Unicast Routing and Forwarding


This section contains the following parts:
Cisco Express Forwarding (CEF), page 8
General IP Routing, page 9
Intermediate System-to-Intermediate System (IS-IS), page 10
Open Shortest Path First (OSPF), page 12
Border Gateway Protocol (BGP), page 13
Multicast, page 22

Cisco Express Forwarding (CEF)


CEF is the only switching method in Cisco IOS XR, and it cannot be disabled. The implementation of
CEF in Cisco IOS XR is different from the implementation in Cisco IOS, but the end result is the same.
Cisco IOS XR has fewer configurable CEF options thanCisco IOS has. Table 6 shows
Cisco IOS and Cisco IOS XR configurations for options that are available in Cisco IOS XR.

Table 6 Differences in CEF for Cisco IOS and Cisco IOS XR Configurations

Cisco IOS Cisco IOS XR


ip cef accounting non-recursive cef accounting non-recursive
Cisco IOS XR does not use the ip keyword in this
command.
ip cef table consistency-check cef ipv4 unicast check-consistency
Cisco IOS XR does not use the ip keyword in this
command.
Cisco IOS XR uses ipv4 unicast in place of Cisco
IOSs table.
Cisco IOS XR uses check-consistency in place of
Cisco IOSs consistency-check.

The Cisco IOS consistency checker has many more options than the Cisco IOS XR consistency checker,
and the default for both Cisco IOS and Cisco IOS XR is that the consistency checker is disabled.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


8
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

For further information on CEF configuration , see the following configuration guide and command
reference modules:
The Implementing CEF on Cisco IOS XR Software module of the
Cisco IOS XR IP Addresses and Services Configuration Guide
The Cisco Express Forwarding Commands on Cisco IOS XR Software module of the Cisco IOS XR
IP Addresses and Services Command Reference

General IP Routing
A major difference between Cisco IOS and Cisco IOS XR is that in Cisco IOS you enable a protocol on
an interface by some combination of configuration in the Interior Gateway Protocol (IGP)and on the
physical interface. An example of the first method is an Open Shortest Path First (OSPF) network
statement, while an example of the second method is an Intermediate System-to-Intermediate System
(IS-IS) ip router isis command, or any change in the cost of an interface. In Cisco IOS XR, all
protocol-specific configuration goes under the global protocol configuration submode and not on the
physical interface configuration. This means that there are no OSPF or IS-IS commands on a physical
interface; they are all put under the interface submode of the routing protocol configuration. See the
examples in Intermediate System-to-Intermediate System (IS-IS) and Open Shortest Path First
(OSPF) for more detail.
A useful feature for all routing protocols in Cisco IOS XR is the global router-id command. In
Cisco IOS, it is recommended that you hard-code a router-id to a loopback (by convention, Loopback0)
for every protocol. In Cisco IOS XR, you can use the global command router-id interface. Thus, all
the following Cisco IOS commands are replaced by a single Cisco IOS XR command:

Table 7 Examples of Cisco IOS Commands Replaced by the Cisco IOS XR router-id Command

Cisco IOS Cisco IOS XR


Example of the IS-IS router-id command: router-id Loopback0

router isis
mpls traffic-eng router-id Loopback0

Example of the OSPF router-id command:


router ospf
router-id ip_address_of_Loopback0
mpls traffic-eng router-id Loopback0

Example of the BGP router-id command:


router bgp
bgp router-id ip_address_of_Loopback0

You can override the global router-id command in Cisco IOS XR by further configuring a router-id
command within a given protocol. However, configuring different router IDs per protocol makes
management more complicated and provides no gain, so we do not recommend this practice.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


9
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

For more information about the router-id command, see the following configuration guide and
command reference modules:
The Implementing Network Stack IPv4 and IPv6 on Cisco IOS XR Software module of the
Cisco IOS XR IP Addresses and Services Configuration Guide
The Network Stack IPv4 and IPv6 Commands on Cisco IOS XR Software module of the
Cisco IOS XR IP Addresses and Services Command Reference
The Implementing Label Distribution Protocol on Cisco IOS XR Software module of the
Cisco IOS XR Multiprotocol Label Switching Configuration Guide
The Implementing Optical User Network Interface on Cisco IOS XR Software module of the
Cisco IOS XR Multiprotocol Label Switching Configuration Guide
The MPLS Label Distribution Commands on Cisco IOS XR Software module of the Cisco IOS XR
Multiprotocol Label Switching Command Reference
The Implementing Optical User Network Interface on Cisco IOS XR Software module of the
Cisco IOS XR Multiprotocol Label Switching Configuration Guide
The MPLS Optical User Network Interface Commands on Cisco IOS XR Software module of the
Cisco IOS XR Multiprotocol Label Switching Command Reference
The Implementing OSPF on Cisco IOS XR Software module of the Cisco IOS XR Routing
Configuration Guide
The OSPF Commands on Cisco IOS XR Software module of the Cisco IOS XR Routing Command
Reference
The OSPFv3 Commands on Cisco IOS XR Software module of the Cisco IOS XR Routing Command
Reference

Intermediate System-to-Intermediate System (IS-IS)


Some key differences between the Cisco IOS and Cisco IOS XR IS-IS implementation are:
Cisco IOS XR does not support Connectionless Network Services (CLNS) routing.
Cisco IOS XR defaults to multitopology mode for IPv6 (see the IPv6 section later in this
document).
Cisco IOS XR must have a process name, such as router isis lab, whereas Cisco IOS could be
configured with just router isis.
A sample configuration for IPv4 routing only is given in the Table 8. This is for a very simple network
consisting of a router (Router ID: 192.168.1.5) configured with a PoS interface (POS2/1) under
Cisco IOS, and another router (Router ID:192.168.1.8) configured with a PoS interface (POS0/2/0/1)
under Cisco IOS XR.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


10
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

Table 8 Configuration Comparison for IPv4 in Cisco IOS and Cisco IOS XR

IOS (Router ID:192.168.1.5) IOS XR (Router ID:192.168.1.8)


router isis lab router isis lab
net 49.0192.0168.0001.0005.00 is-type level-2-only
is-type level-2-only net 49.0192.0168.0001.0008.00
passive-interface Loopback0 interface Loopback0
! passive
interface POS2/1 address-family ipv4 unicast
... !
ip router isis lab !
isis metric 42 interface POS0/2/0/1
... address-family ipv4 unicast
metric 42
!
!
!

The largest change between Cisco IOS and Cisco IOS XR is that in Cisco IOS XR you need to explicitly
enable the ipv4 address family, whereas in Cisco IOS it is implicitly on. Most or all of the IS-IS options
in Cisco IOS also exist in Cisco IOS XR. Another difference is that there are very few CLNS commands
in Cisco IOS XR; most of the show clns options in Cisco IOS are under the show isis command in
Cisco IOS XR.
Redistribution for IS-IS is very similar; the only difference is that instead of a route-map (as in
Cisco IOS), you specify a policy. Thus, redistribution into Cisco IOS XR is an attach point for an RPL
policy:

Table 9 IS-IS Redistribution Differences Between Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


router isis lab router isis lab
redistribute connected route-map route-map redistribute connected policy policy

All of the standard options are available in both Cisco IOS and Cisco IOS XR.
Table 10 shows the output produced by issuing the help command (?) while in the proper configuration
submode for the redistribute connected command on systems running Cisco IOS and Cisco IOS XR
software:

Table 10 Comparison of the redistribute connected command on Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


Router# redistribute connected RP/0/RP/CPU0:router(config) redistribute connected ?
? level-1
level-1 level-1-2
level-1-2 level-2
level-2 metric
metric metric-type
metric-type policy
route-map <cr>
<cr>

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


11
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

IS-IS configurations for multitopology are slightly different, as well; see the sections on Multiprotocol
Label Switching (MPLS) and IPv6 for details.
For further information on IS-IS configuration , see the following configuration guide and command
reference modules:
The Implementing IS-IS on Cisco IOS XR Software module of the Cisco IOS XR Routing
Configuration Guide
The IS-IS Commands on Cisco IOS XR Software module of the Cisco IOS XR Routing Command
Reference

Open Shortest Path First (OSPF)


An OSPF configuration is very similar to an IS-IS configuration. A sample configuration for OSPF
routing only is given in Table 11 below. This is for a very simple network consisting of a router (Router
ID:192.168.1.5) configured with a PoS interface (POS2/1) under Cisco IOS, and another router (Router
ID:192.168.1.5) configured with a PoS interface (POS0/2/0/1) under Cisco IOS XR.
The mainpiece of information to get from this discussion is that redistribution into OSPF on
Cisco IOS XR is a policy attach point.

Table 11 OSPF Configuration for Cisco IOS and Cisco IOS XR

Cisco IOS (Router ID:192.168.1.5) Cisco IOS XR (Router ID:192.168.1.8)


router ospf 1 router ospf lab
log-adjacency-changes log adjacency changes
passive-interface Loopback0 area 0
network 192.168.1.0 0.0.0.255 area 0 interface Loopback0
network 192.168.7.0 0.0.0.255 area 0 passive enable
network 192.168.12.0 0.0.0.255 area 0 !
network 192.168.13.0 0.0.0.255 area 0 interface POS0/1/0/1
network 192.168.14.0 0.0.0.255 area 0 !
network 192.168.18.0 0.0.0.255 area 0 interface POS0/2/0/0
network 192.168.20.0 0.0.0.255 area 0 !
! interface POS0/2/0/1
interface Loopback0 cost 17
ip address 192.168.1.5 255.255.255.255 !
! interface POS0/2/0/2
interface POS2/1 !
ip address 192.168.14.5 255.255.255.0 !
ip ospf cost 17 mpls traffic-eng area 0
!

Note that the network statement in Cisco IOS has been replaced by enabling the interface under the area
keyword inside OSPF. Also, OSPF does not need an address-family ipv4 unicast command like BGP
or IS-IS. This is because router ospf implies support for unicast IPv4. Cisco does not support MOSPF,
and unicast IPv6 has its own routing protocol, consisting of the router ospfv3 family of commands.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


12
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

Redistribution is a little different as well. Table 12 gives examples of redistribution configurations in


Cisco IOS and Cisco IOS XR.

Table 12 Redistribution Configurations for OSPF in Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


router ospf 1 router ospf lab
redistribute connected subnets redistribute connected
redistribute static subnets route-map map redistribute static policy

You no longer need the subnets keyword in Cisco IOS XR, and you declare an RPL policy rather than
a route map.
If you want to redistribute only classful routes into OSPF in Cisco IOS XR, you can use the redistribute
command with the classful keyword. The use of policies rather than route maps is covered in the
Border Gateway Protocol (BGP) section and also in the existing Cisco IOS XR documentation on
RPL. The mainpiece of information to get from this discussion is that redistribution into OSPF on
Cisco IOS XR is a policy attach point.
For further information on OSPF configuration, see the following configuration guide and command
reference modules:
The Implementing OSPF on Cisco IOS XR Software module of the Cisco IOS XR Routing
Configuration Guide
The OSPF Commands on Cisco IOS XR Software module of the Cisco IOS XR Routing Command
Reference
The OSPFv3 Commands on Cisco IOS XR Software module of the Cisco IOS XR Routing Command
Reference

Border Gateway Protocol (BGP)


This section is divided into the following areas:
Introduction and General Examples, page 13
Address-Family Parameters, page 14
Session Parameters, page 16
BGP Neighbors, page 16
Building a Route Policy, page 19
Neighbor Independent Issues, page 21

Introduction and General Examples


BGP is the largest piece of conversion work to be done when migrating from Cisco IOS to
Cisco IOS XR. BGP is also where Route Policy Language (RPL) is used most heavily, so this is where
RPL is explained. Because this document focuses on configuration conversion, and because it is not an
RPL tutorial, the treatment of RPL is not complete. For more information on RPL, see the following
configuration guide and command reference modules:
The Implementing Routing Policy on Cisco IOS XR Software module of the Cisco IOS XR Routing
Configuration Guide

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


13
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

The Routing Policy Language Commands on Cisco IOS XR Software module of the Cisco IOS XR
Routing Command Reference
BGP configuration is complex enough that it is worth going over several sample configurations.
First, let us start with a simple IBGP peering between a Cisco IOS router and a Cisco IOS XR router.
For these examples, the Cisco IOS router has an IP address of 192.168.1.5, while the Cisco IOS XR
router has an IP address of 192.168.1.8.

Table 13 Basic BGP Configuration Between a Cisco IOS Router and a Cisco IOS XR Router

Cisco IOS (Router ID: 192.168.1.5) Cisco IOS XR (Router ID: 192.168.1.8)
router bgp 3402 router bgp 3402
no synchronization neighbor 192.168.1.5
bgp log-neighbor-changes remote-as 3402
neighbor 192.168.1.8 remote-as 3402 update-source Loopback0
neighbor 192.168.1.8 update-source !
Loopback0 !
no auto-summary

Note the following:


The remote-as and update-source in Cisco IOS XR are configured inside a neighbor submode
(config-bgp-nbr).
bgp log neighbor changes disable (no hyphens)logging of BGP neighbor resets is on by default
and does not show up in the Cisco IOS XR configuration.
Cisco IOS XR does not have the concept of auto-summary, so there is nothing to disable as there
is in Cisco IOS.
The most important thing to learn from the above configuration is that you can configure everything you
need to using the neighbor submode.
Of course, it can get more complicated. Cisco IOS XR lets you break the BGP configuration down into
separate building blocks that can be reused to build a more modular and more readable configuration.

Address-Family Parameters
There are two fundamental building blocks to basic BGP neighbor configuration in Cisco IOS XR:
address-family groups (referred to in a configuration as an af-group) and session groups (referred to in
a configuration as a session-group). For more discussion of session groups see the Session Parameters
section on page 16 of this document.
You configure properties of different address families using the af-group keyword. The following
address-family groups are supported for Cisco IOS XR Release 3.2:
IPv4 unicast
IPv4 multicast
IPv6 unicast
IPv6 multicast

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


14
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

Note A given address family is only supported with a neighbor whose address is from that address family. For
instance, IPv4 neighbors support IPv4 unicast and multicast address families, and IPv6 neighbors
support IPv6 unicast and multicast address families. However, you cannot exchange IPv6 routing
information with an IPv4 neighbor and vice versa.

Inside an af-group, you configure properties specific to the exchange of information for a specific
address family.
Table 14 shows a more complex example of an IBGP peering between a Cisco IOS router (Router ID
192.168.1.5) and a Cisco IOS XR router (Router ID 192.168.1.8):

Table 14 BGP Configuration Using an af-group

Cisco IOS (Router ID:192.168.1.5) Cisco IOS XR (Router ID:192.168.1.8)


router bgp 3402 router bgp 3402
no synchronization af-group test address-family ipv4
bgp log-neighbor-changes unicast
neighbor 192.168.1.8 remote-as 3402 weight 50
neighbor 192.168.1.8 update-source Loopback0 maximum-prefix 75 75
neighbor 192.168.1.8 soft-reconfiguration soft-reconfiguration inbound
inbound !
neighbor 192.168.1.8 weight 50 neighbor 192.168.1.5
neighbor 192.168.1.8 maximum-prefix 75 remote-as 3402
no auto-summary update-source Loopback0
! address-family ipv4 unicast
use af-group test
!
!
!

You can see from the example that Cisco IOS XR allows you to put address-family specific
configuration in an af-group and apply that af-group to a specific neighbor using the af-group
command, thus avoiding the need for a series of lines beginning with neighbor 192.168.1.5.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


15
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

Session Parameters
Session-groups are conceptually very similar to af-groups, except that they allow you to configure
properties of a BGP session itself rather than configure properties of a specific address family.

Table 15 BGP Configuration Using session-group for Cisco IOS XR

Cisco IOS Cisco IOS XR


router bgp 3402 router bgp 3402
no synchronization af-group test address-family ipv4
bgp log-neighbor-changes unicast
neighbor 192.168.1.8 remote-as 3402 weight 50
neighbor 192.168.1.8 password 7 045D0409 maximum-prefix 75 75
neighbor 192.168.1.8 update-source Loopback0 soft-reconfiguration inbound
neighbor 192.168.1.8 soft-reconfiguration !
inbound session-group example
neighbor 192.168.1.8 weight 50 remote-as 3402
neighbor 192.168.1.8 maximum-prefix 75 password encrypted 1303181D
no auto-summary update-source Loopback0
! !
neighbor 192.168.1.5
use session-group example
address-family ipv4 unicast
use af-group test
!
!
!

In this example, a password was added between the neighbors; in Cisco IOS XR, this is in the
session-group, because it is a property of the session rather than a property of the address-family. Also,
rather than using the Cisco IOS keyword syntax password 0 or password 7, Cisco IOS XR uses the
keyword syntax password clear or password encrypted.

BGP Neighbors
The next major configuration task is Cisco IOS XRs equivalent of Cisco IOS peer-groups.
Cisco IOS XR calls them neighbor-groups rather than peer-groups, but the function is the same. In
recent versions of Cisco IOS, the concept of dynamic update-groups was added to separate policy
grouping from neighbor grouping. Cisco IOS XR does this as well, so there is no restriction on what
policies can be shared across which update-groups.
The following configuration examples illustrate the difference in peer-groups under Cisco IOS and
neighbor-groups under Cisco IOS XR.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


16
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

Table 16 BGP Configuration Using Peer Groups in Cisco IOS and Neighbor Groups in Cisco IOS XR

Cisco IOS Cisco IOS XR


router bgp 3402 router bgp 3402
no synchronization af-group test address-family ipv4
bgp log-neighbor-changes unicast
neighbor ibgp-peers peer-group weight 50
neighbor ibgp-peers remote-as 3402 maximum-prefix 75 75
neighbor ibgp-peers password 7 10480616 soft-reconfiguration inbound
neighbor ibgp-peers update-source Loopback0 !
neighbor ibgp-peers soft-reconfiguration session-group example
inbound remote-as 3402
neighbor ibgp-peers weight 50 password 7 1303181D
neighbor ibgp-peers maximum-prefix 75 update-source Loopback0
neighbor 192.168.1.8 peer-group ibgp-peers !
no auto-summary neighbor-group ibgp-peers
! use session-group example
address-family ipv4 unicast
use af-group test
!
!
neighbor 192.168.1.5
use neighbor-group ibgp-peers
!
!

Although the Cisco IOS XR configuration is longer, as the number of peers grows, the abstractions
Cisco IOS XR offers will make configurations shorter and more manageable.
Another issue to look at is routing policy. Routing policy is applied in Cisco IOS XR through Route
Policy Language (RPL) and is a powerful replacement for Cisco IOS route maps. The terminology
translation table for RPL vs. route-maps is:

Table 17 Translation Table Between Cisco IOS Route Maps and Cisco IOS XR RPL

Cisco IOS route-map terminology Cisco IOS XR RPL terminology


route-map route-policy
ip prefix-list prefix-set
ip as-path access-list as-path-set
community-list community-set

As you can see where Cisco IOS uses lists, Cisco IOS XR uses sets. A set, in the mathematical sense,
is an unordered grouping of items, which makes more sense than an ordered list for many applications.
One major change between Cisco IOS and Cisco IOS XR is that in Cisco IOS XR there must be a policy
applied (both inbound and outbound) between EBGP neighbors for routes to be exchanged. Below is a
basic configuration between the same two routers as before, but note that the autonomous system (AS)
numbers are now different:

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


17
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

Table 18 EGBP Configurations in Cisco IOS and Cisco IOS XR with No Policies

Cisco IOS (Router ID: 192.168.1.5) Cisco IOS XR (Router ID: 192.168.1.8)
router bgp 5 router bgp 8
no synchronization neighbor 192.168.1.5
bgp log-neighbor-changes remote-as 5
neighbor 192.168.1.8 remote-as 8 ebgp-multihop 255
neighbor 192.168.1.8 ebgp-multihop 255 update-source Loopback0
neighbor 192.168.1.8 update-source !
Loopback0 !
no auto-summary
!

With the above configuration, no routes are sent from or received by the Cisco IOS XR router; when the
configuration is committed, Cisco IOS XR displays the following messsage
%BGP-4-NBR_NOPOLICY : No inbound IPv4 Unicast policy is configured for eBGP neighbor
192.168.1.5. No IPv4 Unicast prefixes will be accepted from the neighbor until inbound
policy is configured.
%BGP-4-NBR_NOPOLICY : No outbound IPv4 Unicast policy is configured for eBGP neighbor
192.168.1.5. No IPv4 Unicast prefixes will be sent to the neighbor until outbound policy
is configured.

A warning also shows when using the show bgp summary command if you do not have a policy
configured.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


18
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

Building a Route Policy


You need both an inbound policy and outbound policy on Cisco IOS XR. The simplest policy is one that
allows all routes to pass back and forth. Adding this to the configuration, we have:

Table 19 EBGP Configuration in Cisco IOS and Cisco IOS XR with Inbound and Outbound Policies

Cisco IOS Cisco IOS XR


router bgp 5 route-policy permit
no synchronization pass
bgp log-neighbor-changes end-policy
neighbor 192.168.1.8 remote-as 8 !
neighbor 192.168.1.8 ebgp-multihop 255 router bgp 8
neighbor 192.168.1.8 update-source neighbor 192.168.1.5
Loopback0 remote-as 5
no auto-summary ebgp-multihop 255
! update-source Loopback0
address-family ipv4 unicast
policy permit in
policy permit out
!
!
!

With the policy in place, the routes can pass.


A complete explanation of converting route maps to RPL policies is beyond the scope of this document.
However, we include an extended example here to briefly illustrate the process. See Translating Cisco
IOS Route Maps to Cisco IOS XR Routing Policy Language in this document for a more complete
example of the conversion process.
For further information on writing route policies in Cisco IOS XR, see the following documents:
The Implementing Routing Policy on Cisco IOS XR Software module of the Cisco IOS XR Routing
Configuration Guide
The Routing Policy Language Commands on Cisco IOS XR Software module of the Cisco IOS XR
Routing Command Reference
To get the same behavior in Cisco IOS XR as in Cisco IOS, create the permit route policy and apply it
to every address-family (or in the af-group) for all EBGP neighbors.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


19
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

Combining the EBGP policy configuration with the af-group and session-group configuration from the
IBGP example, the final configurations are:

Table 20 Final Configuration for EBGP for Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


router bgp 5 route-policy permit
no synchronization pass
bgp log-neighbor-changes end-policy
neighbor ebgp-peers peer-group !
neighbor ebgp-peers remote-as 8 router bgp 8
neighbor ebgp-peers password 7 15140403 af-group test address-family ipv4
neighbor ebgp-peers ebgp-multihop 255 unicast
neighbor ebgp-peers update-source Loopback0 weight 50
neighbor ebgp-peers soft-reconfiguration maximum-prefix 75 75
inbound soft-reconfiguration inbound
neighbor ebgp-peers weight 50 policy permit in
neighbor ebgp-peers maximum-prefix 75 policy permit out
neighbor 192.168.1.8 peer-group ebgp-peers !
no auto-summary session-group example
! remote-as 5
password 7 00021C09
ebgp-multihop 255
update-source Loopback0
!
neighbor-group ebgp-peers
use session-group example
address-family ipv4 unicast
use af-group test
!
!
neighbor 192.168.1.5
use neighbor-group ebgp-peers
!
!

If you look closely at the Cisco IOS XR configuration, you see that the EBGP AS (remote-as 5) is
embedded in the session group. Although you can do this if you want, it is not necessary. If you do this,
you end up having to create a session group per external AS, or not use session groups.
Policies can be cascaded, so that session groups and address family groups can inherit from each other,
and settings in session groups can be overridden. Following are two other ways to accomplish the same
configuration on Cisco IOS XR while making the configuration more flexible.
Alternate examples for creating BGP policies on Cisco IOS XR:
Remove the remote-as command from the neighbor group and put it in the neighbor directly:
session-group example
password 7 00021C09
ebgp-multihop 255
update-source Loopback0
!
neighbor-group ebgp-peers
use session-group example
address-family ipv4 unicast
use af-group test
!
!

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


20
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

neighbor 192.168.1.5
remote-as 5
use neighbor-group ebgp-peers
!
!

Create a second neighbor group and use inheritance


router bgp 8
af-group test address-family ipv4 unicast
weight 50
maximum-prefix 75 75
soft-reconfiguration inbound
policy permit in
policy permit out
!
session-group example
password 7 00021C09
ebgp-multihop 255
update-source Loopback0
!
neighbor-group ASFive
remote-as 5
use neighbor-group ebgp-peers
!
neighbor-group ebgp-peers
use session-group example
address-family ipv4 unicast
use af-group test
!
!
neighbor 192.168.1.5
use neighbor-group ASFive
!
!

The second example hints at the real power you can get with inheritance.

Neighbor Independent Issues


Another important issue to look at in BGP are keywords that are independent of any neighbors or policy.
The three major keywords in Cisco IOS XR for BGP are bgp, socket, and timers. The keywords you
can configure under BGP are not explored in depth in this document. The bgp command keywords are
listed below:
as-path-loopcheck
auto-policy-soft-reset
bestpath
bgp
cluster-id
confederation
default
enforce-first-as
fast-external-fallover
graceful-restart

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


21
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv4 Unicast Routing and Forwarding

log
receive-buffer-size
redistribute-internal
router-id
scan-time
send-buffer-size
socket
timers bgp keepalive holdtime
update-delay
write-limit
For further information on BGP configuration, see the following configuration guide and command
reference modules:
The Implementing BGP on Cisco IOS XR Software module of the Cisco IOS XR Routing
Configuration Guide
The Implementing Routing Policy on Cisco IOS XR Software module of the Cisco IOS XR Routing
Configuration Guide
The BGP Commands on Cisco IOS XR Software module of the Cisco IOS XR Routing Command
Reference
The Routing Policy Language Commands on Cisco IOS XR Software module of the Cisco IOS XR
Routing Command Reference

Multicast
There are two things to configure for multicast: multicast forwarding, and multicast routing.
It is difficult to seperate out exactly where Cisco IOS configures multicast forwarding versus routing,
since multicast forwarding is not enabled on a Cisco IOS interface until you enable a multicast routing
protocol. Also, enabling multicast-routing on a specific interface in Cisco IOS XR enables Protocol
Independent Multicast (PIM) on that interface, despite the fact that there is a separate PIM configuration
submode.
IOS XR does not support PIM dense mode, although enough of dense mode is supported to enable
auto-RP; forwarding of multicast groups not related to auto-RP is not supported.
Multicast is consistent with the IOS XR model of configuring everything under a protocol submode
rather than on an interface. The following examples illustrate enabling basic multicast (multicast
forwarding and PIM with AutoRP):

Table 21 Basic Multicast Configuration on Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


ip multicast-routing multicast-routing address-family ipv4
interface POS6/0 interface POS0/6/0/2
ip pim sparse-dense-mode enable
!
!

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


22
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Multiprotocol Label Switching (MPLS)

If you want to change any PIM parameters in IOS XR, you change them under the (config-mcast-ipv4)
submode, not under router pim. For example, if you want to explicitly specify an RP address rather than
letting AutoRP discover it, the configuration is:

Table 22 Changing PIM Parameters in Multicast Configurations on Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


ip pim rp-address 1.2.3.4 router pim address-family ipv4
rp-address 1.2.3.4
!

The basic idea in IOS XR is this: enabling multicast-routing turns on AutoRP (so by definition PIM
sparse-dense) and also multicast forwarding on any interface you specify. Additionally, the all keyword
allows you to turn on multicast on all interfaces in the router and then selectively disable some of them.
If you want to modify your PIM configuration, most of the changes you make are under router pim;
configurations such as administratively scoped boundaries, which have nothing to do with PIM but are
instead forwarding-related, are configured under the (config-mcast-ipv4)submode.

Multiprotocol Label Switching (MPLS)


There are three major parts to MPLS configuration on Cisco IOS XR:
Minor Differences and Adjustments, page 23
Label Distribution Protocol (LDP), page 24
Traffic Engineering (TE), page 25
There is no support in Cisco IOS XR for static labels, VPNv4 prefixes in BGP, or AToM.

Minor Differences and Adjustments


Table 23 lists some minor differences in MPLS usage between the Cisco IOS and Cisco IOS XR
configurations.

Table 23 Minor DIfferences in MPLS usage for Cisco IOS and Cisco IOS XR Configurations

Cisco IOS Cisco IOS XR


no mpls ip propagate-ttl mpls ip-ttl-propagate disable
mpls label range min max {static } mpls label range {table table-id} min max

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


23
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Multiprotocol Label Switching (MPLS)

Label Distribution Protocol (LDP)


The difference in configuration between LDP in Cisco IOS and Cisco IOS XR is similar to the difference
between OSPF configurations. There is a global mpls ldp submode under which all LDP commands
exist, including those relevant to an interface. Sample LDP configurations are presented in the
configurations below:

Table 24 LDP Configurations in Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


mpls label protocol ldp mpls ldp
interface POS2/1 interface POS0/1/0/1
... !
tag-switching ip interface POS0/2/0/0
!
interface POS0/2/0/1
!
interface POS0/2/0/2
!
!

Most of the Cisco IOS LDP capabilities are in Cisco IOS XR as well. One notable exception is the ability
to configure an LDP targeted session. You can accept targeted hellos in Cisco IOS XR using the
command sequence:
mpls ldp
discovery targeted-hello accept

but there is no equivalent to the Cisco IOS command mpls ldp neighbor neighbor targeted.
Other configurations, such as authentication, timer tuning, and graceful restart are similar in both
systems. Note that Cisco IOS XR only supports DU mode, so there are no DoD commands.
For further information on LDP configuration, see the following configuration guide and command
reference modules:
The Implementing MPLS Label Distribution Protocol on Cisco IOS XR Software module of the
Cisco IOS XR Multiprotocol Label Switching Configuration Guide
The MPLS Label Distribution Protocol Commands on Cisco IOS XR Software module of the
Cisco IOS XR Multiprotocol Label Switching Command Reference

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


24
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Multiprotocol Label Switching (MPLS)

Traffic Engineering (TE)


TE configuration in Cisco IOS XR is slightly different from Cisco IOS. In either Cisco IOS or
Cisco IOS XR, there are four things you configure: Interior Gateway Protocol (IGP), TE infrastructure,
Resource Reservation Protocol (RSVP), and TE tunnels. IGP configuration is very similar between
Cisco IOS and Cisco IOS XR. In Cisco IOS XR, both TE and RSVP have their own submodes, whereas
in Cisco IOS neither one has a submode and most of the configuration is done on a physical interface.
TE tunnel headend configuration is similar, except that in Cisco IOS XR the name of the tunnel denotes
its type, which removes the need to preface every TE tunnel command with tunnel mpls traffic-eng.
A sample configuration for two routers which are tunnel head/tail pairs follows.
Table 25 Configuration of Tunnel head/tail Pairs in Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


interface Tunnel1 interface tunnel-te1
ip unnumbered Loopback0 ipv4 unnumbered Loopback0
tunnel destination 192.168.1.1 tunnel destination 192.168.1.11
tunnel mode mpls traffic-eng autoroute announce
tunnel mpls traffic-eng autoroute path-option 10 dynamic
announce !
tunnel mpls traffic-eng path-option 10
dynamic mpls traffic-eng
interface POS0/6/0/0
interface POS6/0 !
... interface POS0/7/0/0
mpls traffic-eng tunnels !
ip rsvp bandwidth !

interface POS7/0 router ospf lab


... mpls traffic-eng area 0
mpls traffic-eng tunnels !
ip rsvp bandwidth
rsvp
router ospf 1 interface POS0/6/0/0
mpls traffic-eng router-id Loopback0 bandwidth
mpls traffic-eng area 0 !
interface POS0/7/0/0
bandwidth
!
!

Note that in Cisco IOS XR there are four submodes below the global configuration modetunnel
interface, mpls traffic-eng, IGP, and rsvpwhile in Cisco IOS there are threetunnel interface, physical
interface, and IGP.
An IS-IS configuration for TE in Cisco IOS XR is similar to one in Cisco IOS; Cisco IOS XR supports
the full range of narrow, transition, and wide metrics that Cisco IOS supports, and the TE configuration
is under the IPv4 address family:
router isis lab
address-family ipv4 unicast
mpls traffic-eng level 2
!
!

In Cisco IOS XR the default metric-style is narrow, just as it is in Cisco IOS.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


25
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Quality of Service (QoS)

For further information on TE configuration, see the following configuration guide and command
reference modules:
The Implementing MPLS Traffic Engineering on Cisco IOS XR Software module of the
Cisco IOS XR Multiprotocol Label Switching Configuration Guide
The MPLS Traffic Engineering Commands on Cisco IOS XR Software module of the Cisco IOS XR
Multiprotocol Label Switching Command Reference

Quality of Service (QoS)


The most commonly used QoS element on a Cisco 12000 Series router is the Modular QoS CLI (MQC).
Converting Cisco IOS MQC to Cisco IOS XR MQC is very simple, because the syntax is exactly the
same; the only difference is the available set of capabilities. The table below shows the matching options
you have for Cisco IOS XR 3.2 and Cisco IOS 12.0(28)S on a Cisco 12000 Series router.

Table 26 Matching Options for QoS in Cisco IOS and Cisco IOS XR Configurations

Cisco IOS Cisco IOS XR


access-group access-group
any any
atm discard-class
cos dscp
dscp mpls
fr-dlci precedence
ip protocol
mpls qos-group
not
precedence
protocol
qos-group
vlan

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


26
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Quality of Service (QoS)

Table 27 Available Class-map Actions in Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


bandwidth bandwidth
police police
priority priority
queue-limit queue-limit
random-detect random-detect
service-policy service-policy
set set
dscp cos
ip discard-class
mpls dscp
precedence mpls
atm-clp precedence
cos qos-group
discard-class srp-priority
fr-de shape
qos-group
shape

You have a few more class-map options in Cisco IOS than Cisco IOS XR, but the core matching
optionsdscp, mpls, qos-group,and discard-classare there. Cisco IOS XR has no support for
atm-clp or fr-de, but that is because there is no support for ATM or FR encapsulation in Cisco IOS XR.
The actions you can take in a policy map are almost identical as well.
One issue to note in MQC is that in Cisco IOS some measures of bandwidth are in bits per second, some
are in bytes per second, and some are in kilobits per second. The three keywords in a policy-map that
refer to bandwidth on a Cisco 12000 Series router in 12.0(28)S are:
bandwidth rate_in_kilobits_per_second
police rate_in_bits_per_second bc_bytes be_bytes
shape average cir_bits_per_second bc_bits be_bits
In Cisco IOS XR, everything is in kilobits per second:
bandwidth kilobits_per_second
police cir kilobits_per_second bc_kilobits be_kilobits
shape average cir_kilobits_per_second burst_in_kilobits
To convert from bytes to kilobits, multiply by .008. Thus, 64,000 bytes is 512 kilobits.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


27
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
IPv6

Other parts of QoS that exist in Cisco IOS are Selective Packet Discard (SPD) and receive ACLs.
Cisco IOS XR also has Local Packet Transport Service( LPTS) that has a lot of built-in Denial of Service
(DoS)-mitigation components which makes SPD and receive ACLs somewhat unnecessary. At this time,
LPTS is not configurable (although it is monitorable), so it is not covered here.
For further information on QoS configuration, see the following configuration guide and command
reference:
Cisco IOS XR Modular Quality of Service Configuration Guide
Cisco IOS XR Modular Quality of Service Command Reference

IPv6
IPv6 configuration is very similar to IPv4.

Table 28 IPv6 IS-IS Configuration in Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


interface POS2/1 interface POS0/2/0/1
ipv6 address FEC0:0:0:14::5/104 ipv6 address fec0:0:0:14::8/104
ipv6 router isis labv6
router isis labv6
router isis labv6 is-type level-2-only
net 49.0192.0168.0001.0005.00 net 49.0192.0168.0001.000.8.00
is-type level-2-only interface Loopback0
metric-style wide passive
redistribute connected address-family ipv6 unicast
passive-interface Loopback0 !
! !
address-family ipv6 interface POS0/2/0/1
multi-topology address-family ipv6 unicast
exit-address-family !
! !

One thing to note is that Cisco IOS XR uses multi-topology routing rather than a single topology with
all prefixes as leaf nodes, so you need to enable multi-topology under the address family in Cisco IOS.
In general, IPv6 show commands are the same as IPv4 show commands; many of the show ip
commands in Cisco IOS are now show ipv4 commands in Cisco IOS XR, and most of those
commands have a show ipv6 equivalent.
There are three routing protocols in Cisco IOS XR that support IPv6:
BGP using IPv6 unicast or multicast address-family
OSPFv3
IS-IS using IPv6 unicast address-family
The IS-IS configuration was show in the above. A BGP configuration looks just like previously
demonstrated BGP configurations, except using the IPv6 address-family. And OSPF, rather than having
separate address families in a single routing protocol, has its own new routing protocol, OSPFv3. An
OSPFv3 configuration looks just like an IPv4 OSPF (also known as OSPFv2) configuration.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


28
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Other Cisco IOS XR Issues

Table 29 IPv4 OSPFv2 and IPv6 OSPFv3 Configurations in Cisco IOS XR

Cisco IOS XR OSPFv2 (IPv4) Cisco IOS XR OSPFv3 (IPv6)


router ospf lab router ospfv3 labv6
log adjacency changes log adjacency changes
area 0 area 0
interface Loopback0 interface Loopback0
passive enable passive
! !
interface POS0/1/0/1 interface POS0/1/0/1
! !
interface POS0/2/0/0 interface POS0/2/0/0
! !
interface POS0/2/0/1 interface POS0/2/0/1
cost 17 cost 17
! !
interface POS0/2/0/2 interface POS0/2/0/2
! !
! !
! !

There is no implementation of MPLS-TE for IPv6 in IS-IS or OSPF, so any traffic-engineering


commands under the IGP will not be accepted.
IPv6 in both Cisco IOS and Cisco IOS XR has capabilities that are not covered in this document
For further information on IPv6 configuration, see the following configuration guide and command
reference:
Cisco IOS XR IP Addresses and Services Configuration Guide
Cisco IOS XR IP Addrsses and Services Command Reference

Other Cisco IOS XR Issues


This section covers a few miscellaneous issues. They are:
Access Lists, page 29
Username Configuration and Permission Levels, page 30
Network Time Protocol (NTP), page 31
Hot Standby Router Protocol (HSRP) and Virtual Router Redundancy Protocol (VRRP), page 32
Line Configurations, page 32

Access Lists
Cisco IOS has standard and extended, as well as named and numbered ACLs. Cisco IOS XR does away
with named versus numbered ACLs, although you can use a set of numbers as an ASCII name string.
Standard and extended ACL configurations are shown below in Table 30 . For Cisco IOS, named and
numbered ACLs are shown; for Cisco IOS XR, the corresponding configuration is shown. Note that

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


29
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Other Cisco IOS XR Issues

Cisco IOS XR does not have a concept of named or numbered ACLs, and also note that there is no such
thing as a standard or extended ACL; for the equivalent of the standard Cisco IOS ACL, configure a
Cisco IOS XR ACL with only the source IP address specified.
Cisco IOS XR supports the full set of keyword equivalents that Cisco IOS does, like host and the port
range syntax.

Table 30 Comparison of Access-lists between Cisco IOS and Cisco IOS XR Configurations

Cisco IOS Cisco IOS XR


access-list 10 permit 1.1.1.1 ipv4 access-list ten
access-list 10 permit 10.0.0.0 0.255.255.255 10 permit ip host 1.1.1.1 any
20 permit ip 10.0.0.0 0.255.255.255 any
access-list 100 permit ip 20.0.0.0 0.0.255.0 any ipv4 access-list 100
access-list 100 permit icmp any host 1.2.3.4 10 permit ip 20.0.0.0 0.0.255.0 any
20 permit icmp any host 1.2.3.4
ip access-list standard test ipv4 access-list test
permit 9.9.9.9 10 permit ip host 9.9.9.9 any
ip access-list extended moreTest ipv4 access-list moreTest
permit eigrp 1.0.2.0 0.255.0.255 host 7.7.7.6 10 permit eigrp 1.0.2.0 0.255.0.255 host 7.7.7.6

Cisco IOS XR also allows you to resequence an ACL, so that if you have left yourself no space to add
new lines, you can create that space. The first example shows the results of using the show ipv4
access-lists command:
RP/0/RP/CPU0:router# show ipv4 access-lists test
ipv4 access-list test
10 permit ip 11.0.0.0 0.0.0.255 any
11 permit ip 12.0.0.0 0.0.0.255 any

Using the resequence command followed by the same show command results in the following output:
RP/0/RP/CPU0:router(config)# resequence ipv4 access-list test
RP/0/RP/CPU0:router# show ipv4 access-lists test

ipv4 access-list test


10 permit ip 11.0.0.0 0.0.0.255 any
20 permit ip 12.0.0.0 0.0.0.255 any

There are options to the resequence command that let you control the starting number and the step value
as well.

Username Configuration and Permission Levels


This section briefly describes a very powerful and therefore complex set of Cisco IOS XR tools for
allowing multiple levels of permissions to a CLI user. Cisco IOS has privilege levels; an unauthenticated
user is privilege level 1, a user with the enable password is privilege level 15, and some networks use the
levels in between for partial access.
Cisco IOS XR has a concept of taskgroups and usergroups that allow you much more flexibility in a more
logical manner; you define a group of users that has access to a certain set of capabilities. Some of these
capabilities are debugs, some are show commands, some are configurations. Different usergroups have
configuration access to different parts of the router, so it is difficult to come up with an exact translation
of an unprivilege Cisco IOS user (most show commands, no debugs, no configuration). However, at a

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


30
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Other Cisco IOS XR Issues

minimum, you want to configure a root-system user; this is the most powerful user in Cisco IOS XR
terminology, and is essentially the same as a fully enabled user in Cisco IOS. The configuration for a
root-system user in Cisco IOS XR is:
username lab
password 7 1042081B
group root-system
!

This creates a user called lab with a password of lab, and this user has the power to do anything on the
router. Configuring a user with less than complete privileges is easy, as there are a few taskgroups you
can use instead of root-system:
cisco-support
netadmin
operator
root-lr
root-system
sysadmin
In addition, you can define your own taskgroups (sets of things a user is allowed to do) and usergroups
(collections of taskgroups) and attach them to a username. Doing this is beyond the scope of this
document, although investigation of taskgroups and the Cisco IOS XR authentication model is highly
recommended.

Network Time Protocol (NTP)


The NTP configuration in Cisco IOS XR is similar to that in Cisco IOS:

Table 31 NTP Configuration in Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


ntp server 10.86.202.56 ntp
server 161.44.71.59
!

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


31
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Other Cisco IOS XR Issues

Hot Standby Router Protocol (HSRP) and Virtual Router Redundancy Protocol
(VRRP)
HSRP andVRRP configurations are similar in Cisco IOS and in Cisco IOS XR.

Table 32 HSRP and VRRP Configurations in Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


interface GigabitEthernet4/0 router hsrp
interface GigabitEthernet0/6/0/0
standby 1 ip 1.2.3.4 hsrp 1 ipv4 1.2.3.4
end !
!
interface GigabitEthernet4/0 router vrrp
interface GigabitEthernet0/6/0/0
vrrp 1 ip 1.2.3.4 vrrp 1 ipv4 1.2.3.4
end !
!

The primary difference here is, of course, that you configure interface properties not on the interface
directly, but under the interface submode of the protocol either router hsrp or router vrrp.

Line Configurations
The line {console|aux|vty} configurations are very similar between Cisco IOS and Cisco IOS XR.
Most networks have the console and vtys configured; the aux port is not very useful in either Cisco IOS
or Cisco IOS-XR. A simple translation of Cisco IOS to Cisco IOS XR is

Table 33 Line Configurations in Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


aaa authentication login default local username lab
username lab password 7 09404F0B password 7 1042081B
line con 0 group root-system
exec-timeout 0 0 !
line vty 0 4 line console
password lab exec-timeout 0 0
login !
! telnet ipv4 server enable

Note that in Cisco IOS XR you must configure the global command telnet ipv4 server enable for the
router to allow telnet.
Secure Shell (SSH) support is very similar. The crypto key zerioze and crypto key generate commands
are in EXEC mode in Cisco IOS XR, whereas in Cisco IOS they were in config mode.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


32
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Other Cisco IOS XR Issues

Table 34 Secure Shell (with no telnet) Configurations in Cisco IOS and Cisco IOS XR

Cisco IOS Cisco IOS XR


aaa authentication login default local username lab
username lab password 7 09404F0B password 7 1042081B
line vty 0 4 group root-system
transport input ssh !
! line console
exec-timeout 0 0
!
ssh server enable

For SSH support, you need to have crypto support, just as in Cisco IOS. This is generally accomplished
by installing the k9sec package.
In Cisco IOS XR, no matter whether you have enabled the telnet server, the ssh server, or both, show
line vty vty will show both transports allowed:
RP/0/0/CPU0:router# show line vty 0

Tty Speed Modem Uses Noise Overruns Acc I/O


vty0 0 - - - 0/0 -/-

Line vty0, Location "Unknown", Type "Unknown"


Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 0, 0 parity, 0 stopbits, 0 databits
Template: default
Config:
Allowed transports are telnet ssh.

This is a little confusing, as the notion of a transport being allowed in Cisco IOS means that you can use
that transport to connect to the router; in Cisco IOS XR, you need to enable both the server and the
transport, and the transport is enabled by default. To be certain of control access into the router, enable
and disable the server.

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


33
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Translating Cisco IOS Route Maps to Cisco IOS XR Routing Policy Language

Translating Cisco IOS Route Maps to Cisco IOS XR Routing


Policy Language
This section contains the following topics:
Introduction and Overview, page 34
Original Route Map Configuration, page 34
A Simple Translation, page 36
Using Nested Conditionals to Reduce Repetitive Comparisons, page 37
Using Inline Sets to Remove Small Indirect Set References, page 38
Taking Advantage of Parameterization to Reuse Common Structures, page 39

Introduction and Overview


Consider the following route maps, prefix lists, and community lists. We show four different translations
into the routing policy language, continually using more capabilities of the language to reduce the
amount of configuration needed. This example steps you through using several of the features of the
language to modularize the configuration. Decide what you should modularize and whether you should
modularize specific portions in the context of how that particular piece of policy will be used.
You cannot use both RPL and old policy (including route maps and access control lists) at the same
attach point.
For example, the following configuration would be invalid:
router bgp 2
neighbor 10.0.101.2
address-family ipv4 unicast
policy rpl0 in
route-map rm0 in

However, this configuration would be valid:


router bgp 2
neighbor 10.0.101.2
address-family ipv4 unicast
policy rpl0 in
route-map rm0 out
neighbor 10.0.101.3
address-family ipv4 unicast
policy rpl1 out

In the following example, a route map is translated to the policy language while retaining the redundant
operations:

Original Route Map Configuration


ip prefix-list 101
10 permit 10.48.0.0/16 le 32
20 permit 172.48.0.0/19 le 32
30 permit 172.10.10.0/24
40 permit 172.11.1.0/24
50 permit 192.168.3.0/24

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


34
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Translating Cisco IOS Route Maps to Cisco IOS XR Routing Policy Language

60 permit 192.168.8.0/21
70 permit 192.168.32.0/21

ip prefix-list 102
10 permit 10.48.0.0/16 le 32
20 permit 10.48.0.5/19 le 32
30 permit 172.16.10.0/24
40 permit 172.16.1.0/24
50 permit 172.16.3.0/24
60 permit 192.168.8.0/21
70 permit 192.168.32.0/21

ip community-list 1
10 permit 10:11

ip community-list 2
10 permit 10:12

ip community-list 3
10 permit 10:13

ip community-list 4
10 permit 10:14

route-map sample1-translation-1 permit 10


match ip address prefix-list 101
match community 1
set community 12:34 additive
set metric 11
route-map sample1-translation-1 permit 20
match ip address prefix-list 101
match community 2
set metric 12
set community 12:34 additive
route-map sample1-translation-1 permit 30
match ip address prefix-list 101
match community 3
set metric 13
set community 12:34 additive
route-map sample1-translation-1 permit 40
match ip address prefix-list 101
match community 4
set metric 14
set community 12:34 additive
route-map sample1-translation-1 permit 50
match ip address prefix-list 101
set metric 100
set community 12:34 additive

route-map sample2-translation-1 permit 10


match ip address prefix-list 102
match community 1
set community 12:35 additive
set metric 11
route-map sample2-translation-1 permit 20
match ip address prefix-list 102
match community 2
set metric 12
set community 12:35 additive
route-map sample2-translation-1 permit 30
match ip address prefix-list 102
match community 3
set metric 13

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


35
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Translating Cisco IOS Route Maps to Cisco IOS XR Routing Policy Language

set community 12:35 additive


route-map sample2-translation-1 permit 40
match ip address prefix-list 102
match community 4
set metric 14
set community 12:35 additive
route-map sample2-translation-1 permit 50
match ip address prefix-list 102
set metric 100
set community 12:35 additive

A Simple Translation
A simple translation of this route map configuration to the policy language would retain the redundant
operations, as shown in the following example:
prefix-set ps101
10.48.0.0/16 le 32
172.48.0.0/19 le 32
172.10.10.0/24
172.11.1.0/24
192.168.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set

prefix-set ps102
10.48.0.0/16 le 32
10.48.0.5/19 le 32
172.16.10.0/24
172.16.1.0/24
172.16.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set

community-set cs1
10:11
end-set

community-set cs2
10:12
end-set

community-set cs3
10:13
end-set

community-set cs4
10:14
end-set

route-policy sample1-translation-1a
if destination in ps101 and community matches-any cs1 then
set med 11
set community 12:34 additive
elseif destination in ps101 and community matches-any cs2 then
set med 12
set community 12:34 additive
elseif destination in ps101 and community matches-any cs3 then
set med 13

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


36
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Translating Cisco IOS Route Maps to Cisco IOS XR Routing Policy Language

set community 12:34 additive


elseif destination in ps101 and community matches-any cs4 then
set med 14
set community 12:34 additive
elseif destination in ps101
set med 100
set community 12:34 additive
endif
end-policy

route-policy sample2-translation-1a
if destination in ps102 and community matches-any cs1 then
set med 11
set community (12:35) additive
elseif destination in ps102 and community matches-any cs2 then
set med 12
set community (12:35) additive
elseif destination in ps102 and community matches-any cs3 then
set med 13
set community (12:35) additive
elseif destination in ps102 and community matches-any cs4 then
set med 14
set community (12:35) additive
elseif destination in ps102
set med 100
set community (12:35) additive
endif
end-policy

Using Nested Conditionals to Reduce Repetitive Comparisons


Common operations can be coalesced by nesting the conditionals, testing the destination address only
once, and setting the community only once, as shown in the following example:
prefix-set ps101
10.48.0.0/16 le 32
172.48.0.0/19 le 32
172.10.10.0/24
172.11.1.0/24
192.168.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set

prefix-set ps102
10.48.0.0/16 le 32
10.48.0.5/19 le 32
172.16.10.0/24
172.16.1.0/24
172.16.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set

community-set cs1
10:11
end-set

community-set cs2
10:12
end-set

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


37
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Translating Cisco IOS Route Maps to Cisco IOS XR Routing Policy Language

community-set cs3
10:13
end-set

community-set cs4
10:14
end-set

route-policy sample1-translation-1b
if destination in ps101 then
set community (12:34) additive
if community matches-any cs1 then
set med 11
elseif community matches-any cs2 then
set med 12
elseif community matches-any cs3 then
set med 13
elseif community matches-any cs4 then
set med 14
else
set med 100
endif
endif
end-policy

route-policy sample2-translation-1b
if destination in ps102 then
set community (12:35) additive
if community matches-any cs1 then
set med 11
elseif community matches-any cs2 then
set med 12
elseif community matches-any cs3 then
set med 13
elseif community matches-any cs4 then
set med 14
else
set med 100
endif
endif
end-policy

Using Inline Sets to Remove Small Indirect Set References


Because the community comparisons are quite simple, we can replace the named community set
references with direct inline references, thus eliminating the need to define four community sets, each
of which contains only one community value. These replacements leave two prefix sets and two policies,
as follows:
prefix-set ps101
10.48.0.0/16 le 32
172.48.0.0/19 le 32
172.10.10.0/24
172.11.1.0/24
192.168.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set

prefix-set ps102
10.48.0.0/16 le 32

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


38
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Translating Cisco IOS Route Maps to Cisco IOS XR Routing Policy Language

10.48.0.5/19 le 32
172.16.10.0/24
172.16.1.0/24
172.16.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set

route-policy sample1-translation-1c
if destination in ps101 then
set community (12:34) additive
if community matches-any (10:11) then
set med 11
elseif community matches-any (10:12) then
set med 12
elseif community matches-any (10:13) then
set med 13
elseif community matches-any (10:14) then
set med 14
else
set med 100
endif
end-policy

route-policy sample2-translation-1c
if destination in ps102 then
set community (12:35) additive
if community matches-any (10:11) then
set med 11
elseif community matches-any (10:12) then
set med 12
elseif community matches-any (10:13) then
set med 13
elseif community matches-any (10:14) then
set med 14
else
set med 100
endif
end-policy

Taking Advantage of Parameterization to Reuse Common Structures


The following example takes advantage of the ability to parameterize common structures and create a
common parameterized policy (sample-translation-common) that is reused:
prefix-set ps101
10.48.0.0/16 le 32
172.48.0.0/19 le 32
172.10.10.0/24
172.11.1.0/24
192.168.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set

prefix-set ps102
10.48.0.0/16 le 32
10.48.0.5/19 le 32
172.16.10.0/24
172.16.1.0/24
172.16.3.0/24
192.168.8.0/21

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


39
Converting Cisco IOS Configurations to Cisco IOS XR Configurations
Translating Cisco IOS Route Maps to Cisco IOS XR Routing Policy Language

192.168.32.0/21
end-set

route-policy sample-translation-common(tag)
set community (12:$tag) additive
if community matches-any (10:11) then
set med 11
elseif community matches-any (10:12) then
set med 12
elseif community matches-any (10:13) then
set med 13
elseif community matches-any (10:14) then
set med 14
else
set med 100
endif
end-policy

route-policy sample1-translation-1d
if destination in ps101 then
apply sample-translation-common (34)
pass
endif
end-policy

route-policy sample2-translation-1d
if destination in ps102 then
apply sample-translation-common (35)
pass
endif
end-policy

Converting Cisco IOS Configurations to Cisco IOS XR Configurations


40

You might also like