Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 1

333247772:AAFKWAe5moPhrs79UqJMfzSdxoPN8aW9fbk

https://api.telegram.org/bot333247772:AAFKWAe5moPhrs79UqJMfzSdxoPN8aW9fbk/sendmessa
ge?chat_id=208001517&text=test test test

208001517

:local ping
:local maxping 10
:local packet
:local percentage
:local loss
:local min 4
:set ping [/ping 8.8.8.8 count=$maxping interval=0.1];

:if ($ping > $min ) do={


:log info ("Host replied OK");
/tool fetch
url="https://api.telegram.org/bot333247772:AAFKWAe5moPhrs79UqJMfzSdxoPN8aW9fbk/send
message?chat_id=208001517&text=Host OK. Ping to 8.8.8.8 resulted $ping / $maxping
packets."

} \
else={
($ping < $min )
:set packet ($maxping - $ping);
:set percentage (($ping * 100) / $maxping)
:set loss (($packet *100) / $maxping)
:log info "recieved $percentage% of packets"
/tool fetch url="Host is down Warning !! Ping to 8.8.8.8 resulted #ping /
$maxping packets recieved $loss% packet loss !"
}

You might also like