Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 10

P3 __________________________________

_____________________________________

!
ip vrf cliente_1
rd 100:10
route-target export 100:10
route-target import 100:10
!
ip vrf cliente_2
rd 200:20
route-target export 200:20
route-target import 200:20

!
interface Loopback0
ip address 21.1.1.2 255.255.255.255
!
interface FastEthernet0/0
ip address 172.30.11.5 255.255.255.252
duplex half
mpls ip
!
interface FastEthernet1/0
ip vrf forwarding cliente_1
ip address 172.16.1.19 255.255.255.0
duplex half
!
interface FastEthernet2/0
ip vrf forwarding cliente_2
ip address 172.16.2.19 255.255.255.0
duplex half
!
router ospf 1
router-id 21.1.1.3
log-adjacency-changes
network 21.1.1.2 0.0.0.0 area 0
network 172.30.11.4 0.0.0.3 area 0
!
router bgp 749
no synchronization
bgp router-id 21.1.1.1
bgp log-neighbor-changes
neighbor 22.1.1.2 remote-as 749
neighbor 22.1.1.2 update-source Loopback0
neighbor 23.1.1.2 remote-as 749
neighbor 23.1.1.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 22.1.1.2 activate
neighbor 22.1.1.2 send-community both
neighbor 22.1.1.2 next-hop-self
neighbor 23.1.1.2 activate
neighbor 23.1.1.2 send-community both
neighbor 23.1.1.2 next-hop-self
exit-address-family
!
address-family ipv4 vrf cliente_2
neighbor 172.16.2.1 remote-as 123
neighbor 172.16.2.1 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf cliente_1
neighbor 172.16.1.1 remote-as 123
neighbor 172.16.1.1 activate
no auto-summary
no synchronization
exit-address-family

P __________________________________
_____________________________________

!
interface Loopback0
ip address 20.1.1.2 255.255.255.255
!
interface FastEthernet0/0
ip address 172.30.11.6 255.255.255.252
duplex half
mpls ip
!
interface FastEthernet1/0
ip address 172.30.11.9 255.255.255.252
duplex half
mpls ip
!
interface FastEthernet2/0
ip address 172.30.11.13 255.255.255.252
duplex half
mpls ip
!
router ospf 1
router-id 10.10.0.5
log-adjacency-changes
network 20.1.1.2 0.0.0.0 area 0
network 172.30.11.4 0.0.0.3 area 0
network 172.30.11.8 0.0.0.3 area 0
network 172.30.11.12 0.0.0.3 area 0
!

P1 __________________________________
_____________________________________

!
ip vrf cliente_1
rd 100:10
route-target export 100:10
route-target import 100:10
!
ip vrf cliente_2
rd 200:20
route-target export 200:20
route-target import 200:20

!
!
interface Loopback0
ip address 22.1.1.2 255.255.255.255
!
interface FastEthernet0/0
ip address 172.30.11.14 255.255.255.252
duplex half
mpls ip
!
interface FastEthernet1/0
ip vrf forwarding cliente_2
ip address 200.3.9.1 255.255.255.252
duplex half
!
interface FastEthernet2/0
ip vrf forwarding cliente_1
ip address 200.1.9.1 255.255.255.252
duplex half
!
router ospf 1
router-id 22.1.1.2
log-adjacency-changes
network 22.1.1.2 0.0.0.0 area 0
network 172.30.11.12 0.0.0.3 area 0
!
router bgp 749
bgp router-id 22.1.1.2
bgp log-neighbor-changes
neighbor 21.1.1.2 remote-as 749
neighbor 21.1.1.2 update-source Loopback0
neighbor 23.1.1.2 remote-as 749
neighbor 23.1.1.2 update-source Loopback0
neighbor 200.1.9.2 remote-as 19
neighbor 200.3.9.2 remote-as 29
!
address-family ipv4
neighbor 21.1.1.2 activate
neighbor 23.1.1.2 activate
neighbor 200.1.9.2 activate
neighbor 200.3.9.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 21.1.1.2 activate
neighbor 21.1.1.2 send-community both
neighbor 21.1.1.2 next-hop-self
neighbor 23.1.1.2 activate
neighbor 23.1.1.2 send-community both
neighbor 23.1.1.2 next-hop-self
exit-address-family
!
address-family ipv4 vrf cliente_2
neighbor 200.3.9.2 remote-as 29
neighbor 200.3.9.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf cliente_1
neighbor 200.1.9.2 remote-as 19
neighbor 200.1.9.2 activate
no auto-summary
no synchronization
exit-address-family

P2 __________________________________
_____________________________________

!
ip vrf cliente_1
rd 100:10
route-target export 100:10
route-target import 100:10
!
ip vrf cliente_2
rd 200:20
route-target export 200:20
route-target import 200:20

!
!
interface Loopback0
ip address 23.1.1.2 255.255.255.255
!
interface FastEthernet0/0
ip address 172.30.11.10 255.255.255.252
duplex half
mpls ip
!
interface FastEthernet1/0
ip vrf forwarding cliente_1
ip address 200.2.9.1 255.255.255.252
duplex half
!
interface FastEthernet2/0
ip vrf forwarding cliente_2
ip address 200.4.9.1 255.255.255.252
duplex half
!
router ospf 1
router-id 23.1.1.2
log-adjacency-changes
network 23.1.1.2 0.0.0.0 area 0
network 172.30.11.8 0.0.0.3 area 0
!
router bgp 749
no synchronization
bgp router-id 23.1.1.2
bgp log-neighbor-changes
network 22.1.1.2 mask 255.255.255.255
neighbor 21.1.1.2 remote-as 749
neighbor 21.1.1.2 update-source Loopback0
neighbor 22.1.1.2 remote-as 749
neighbor 22.1.1.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 21.1.1.2 activate
neighbor 21.1.1.2 send-community both
neighbor 21.1.1.2 next-hop-self
neighbor 22.1.1.2 activate
neighbor 22.1.1.2 send-community both
neighbor 22.1.1.2 next-hop-self
exit-address-family
!
address-family ipv4 vrf cliente_2
neighbor 200.4.9.2 remote-as 29
neighbor 200.4.9.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf cliente_1
neighbor 200.2.9.2 remote-as 19
neighbor 200.2.9.2 activate
no auto-summary
no synchronization
exit-address-family
!
ip classless
no ip http server

CPE_1 HSRP __________________________________


_____________________________________

VLAN DATABASE
vlan 10 name AA
exit

interface Port-channel1
switchport mode trunk
!
interface FastEthernet0/0
switchport mode trunk
channel-group 1 mode on

interface FastEthernet0/3
switchport mode trunk
channel-group 1 mode on

interface Vlan1
description VLAN_LAN
no ip address
standby 1 priority 120
standby 1 preempt
!
interface Vlan10
description VLANLAN
ip address 192.168.19.2 255.255.255.0
ip nat inside
ip virtual-reassembly
standby 1 ip 192.168.19.1
standby 1 priority 120
standby 1 preempt
!
router bgp 19
bgp router-id 19.9.9.9
bgp log-neighbor-changes
neighbor 200.1.9.1 remote-as 749
!
address-family ipv4
neighbor 200.1.9.1 activate
no auto-summary
no synchronization
network 192.168.19.0
network 200.1.9.0 mask 255.255.255.252
exit-address-family
!
no ip http server
!
ip route 0.0.0.0 0.0.0.0 200.1.9.1
!
ip nat inside source list 1 interface FastEthernet1/0 overload
!
access-list 1 permit 192.168.19.0 0.0.0.255
no cdp log mismatch duplex
!
!
!

CPE_2 HSRP __________________________________


_____________________________________
VLAN DATABASE
vlan 10 name AA
exit

interface FastEthernet0/0
switchport mode trunk
channel-group 1 mode on

!
interface FastEthernet0/3
switchport mode trunk
channel-group 1 mode on

!
interface FastEthernet1/0
ip address 200.2.9.2 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.19.3 255.255.255.0
ip nat inside
ip virtual-reassembly
standby 1 ip 192.168.19.1
standby 1 preempt
!
router bgp 19
bgp router-id 19.1.91.91
bgp log-neighbor-changes
neighbor 200.2.9.1 remote-as 749
!
address-family ipv4
neighbor 200.2.9.1 activate
no auto-summary
no synchronization
network 192.168.19.0
network 200.2.9.0 mask 255.255.255.252
exit-address-family
!
no ip http server
!
ip route 0.0.0.0 0.0.0.0 200.2.9.1
!
ip nat inside source list 1 interface FastEthernet1/0 overload
!
access-list 1 permit 192.168.19.0 0.0.0.255

____________________________________________
SW1 HSRP
____________________________________________
VLAN DATABASE
vlan 10 name AA
exit

no spanning-tree vlan 10
!
!
ip tcp synwait-time 5
!
!
!
interface Port-channel1
description CPE1
switchport mode trunk
!
interface Port-channel2
description CP2
switchport mode trunk
!
interface FastEthernet0/0
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/1
switchport mode trunk
channel-group 2 mode on

interface FastEthernet0/3
switchport mode trunk
channel-group 1 mode on

interface FastEthernet0/4
switchport mode trunk
channel-group 2 mode on

____________________________________________
SW2 HSRP
____________________________________________
VLAN DATABASE
vlan 10 name AA
exit

no spanning-tree vlan 10

interface Port-channel1
description CPE1
switchport mode trunk
!
interface Port-channel2
description CP2
switchport mode trunk
!
interface FastEthernet0/0
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/1
switchport mode trunk
channel-group 2 mode on

!
interface FastEthernet0/3
switchport mode trunk
channel-group 1 mode on

interface FastEthernet0/4
switchport mode trunk
channel-group 2 mode on

_____________________________________________

CPE_1 UNO __________________________________


_____________________________________

!
track 10 rtr 1
!
!
!
interface FastEthernet0/0
ip address 192.168.19.2 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
vrrp 1 ip 192.168.19.1
vrrp 1 priority 120
vrrp 1 track 10 decrement 50
!
interface FastEthernet1/0
ip address 200.3.9.2 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
vrrp 1 track 10
!
router bgp 29
bgp router-id 29.0.9.9
bgp log-neighbor-changes
neighbor 200.3.9.1 remote-as 749
!
address-family ipv4
neighbor 200.3.9.1 activate
no auto-summary
no synchronization
network 200.3.9.0 mask 255.255.255.252
exit-address-family
!
no ip http server
!
ip route 0.0.0.0 0.0.0.0 200.3.9.1
!
ip nat inside source list 1 interface FastEthernet1/0 overload
!
access-list 1 permit 192.168.19.0 0.0.0.255
no cdp log mismatch duplex
!

CPE_DOS VRRP __________________________________


_____________________________________

!
!
interface FastEthernet0/0
ip address 200.4.9.2 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.19.3 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
vrrp 1 ip 192.168.19.1
!
router bgp 29
bgp router-id 29.0.9.9
bgp log-neighbor-changes
neighbor 200.4.9.1 remote-as 749
!
address-family ipv4
neighbor 200.4.9.1 activate
no auto-summary
no synchronization
network 200.4.9.0 mask 255.255.255.252
exit-address-family
!
no ip http server
!
ip route 0.0.0.0 0.0.0.0 200.4.9.1
!
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 192.168.19.0 0.0.0.255
no cdp log mismatch duplex
!

You might also like