Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 14

ospf

conf t
no ip domain-lookup
line con 0
logging synchronous
exec-timeout 0 0
exit

R1
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:CAFE:1::1/64
no shutdown
exit
interface Serial0/0/0
ip address 192.168.2.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:CAFE:2::1/64
clock rate 64000
no shutdown
exit

R2

interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:3::1/64
no shutdown
exit
interface Serial0/0/0
ip address 192.168.2.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:2::2/64
no shutdown
exit
interface Serial0/0/1
ip address 192.168.4.1 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:4::1/64
clock rate 64000
no shutdown
exit

r3

interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:CAFE:5::1/64
no shutdown
exit
interface Serial0/0/1
ip address 192.168.4.2 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:CAFE:4::2/64
no shutdown
exit
interface Serial0/1/0
ip address 192.168.77.2 255.255.255.0
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:FEED:77::2/64
clock rate 64000
no shutdown
exit
r4

interface Serial0/0/0
ip address 192.168.77.1 255.255.255.0
ipv6 address FE80::4 link-local
ipv6 address 2001:DB8:FEED:77::1/64
no shutdown
exit
interface gigabitethernet 0/0
ip address 192.168.99.1 255.255.255.0
ipv6 address 2001:db8:99:1::1/64
no shutdown
exit
ipv6 unicast-routing
ipv6 route 2001:DB8:CAFE::/48 2001:DB8:FEED:77::2
ip route 0.0.0.0 0.0.0.0 192.168.77.2
exit

GNS·
R1
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:CAFE:1::1/64
no shutdown
exit
interface Serial1/0
ip address 192.168.2.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:CAFE:2::1/64
clock rate 64000
no shutdown
exit

R2

interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:3::1/64
no shutdown
exit
interface Serial1/0
ip address 192.168.2.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:2::2/64
no shutdown
exit
interface Serial1/1
ip address 192.168.4.1 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:4::1/64
clock rate 64000
no shutdown
exit

r3

interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:CAFE:5::1/64
no shutdown
exit
interface Serial1/1
ip address 192.168.4.2 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:CAFE:4::2/64
no shutdown
exit
interface Serial1/2
ip address 192.168.77.2 255.255.255.0
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:FEED:77::2/64
clock rate 64000
no shutdown
exit

r4

interface Serial1/0
ip address 192.168.77.1 255.255.255.0
ipv6 address FE80::4 link-local
ipv6 address 2001:DB8:FEED:77::1/64
no shutdown
exit
interface gigabitethernet 0/0
ip address 192.168.99.1 255.255.255.0
ipv6 address 2001:db8:99:1::1/64
no shutdown
exit
ipv6 unicast-routing
ipv6 route 2001:DB8:CAFE::/48 2001:DB8:FEED:77::2
ip route 0.0.0.0 0.0.0.0 192.168.77.2
exit

r1

ipv6 unicast-routing
router ospfv3 1
address-family ipv4 unicast
router-id 3.3.3.3
passive-interface gigabitethernet 0/0
exit-address-family
address-family ipv6 unicast
router-id 3.3.3.6
passive-interface gigabitethernet 0/0
exit-address-family
exit

interface gigabitethernet 0/0


ospfv3 1 ipv4 area 0
ospfv3 1 ipv6 area 0
exit
interface serial 1/1
ospfv3 1 ipv4 area 0
ospfv3 1 ipv6 area 0
r2

ipv6 unicast-routing
router ospfv3 1
address-family ipv4 unicast
router-id 2.2.2.2
passive-interface gigabitethernet 0/0
exit-address-family
address-family ipv6 unicast
router-id 2.2.2.6
passive-interface gigabitethernet 0/0
exit-address-family

interface serial 1/1


ospfv3 1 ipv4 area 0
ospfv3 1 ipv6 area 0
exit
interface gigabitethernet 0/0
ospfv3 1 ipv4 area 0
ospfv3 1 ipv6 area 0
exit
interface serial 1/0
ospfv3 1 ipv4 area 51
ospfv3 1 ipv6 area 51
exi

R1

ipv6 unicast-routing
router ospfv3 1
address-family ipv4 unicast
router-id 1.1.1.1
passive-interface gigabitethernet 0/0
exit-address-family
address-family ipv6 unicast
router-id 1.1.1.6
passive-interface gigabitethernet 0/0
exit-address-family
exit
interface gigabitethernet 0/0
ospfv3 1 ipv4 area 51
ospfv3 1 ipv6 area 51
exit

interface serial 1/0


ospfv3 1 ipv4 area 51
ospfv3 1 ipv6 area 51
exi
R3 a r4

ip route 0.0.0.0 0.0.0.0 192.168.77.1


ipv6 route ::/0 2001:db8:feed:77::1
router ospfv3 1
address-family ipv4 unicast
default-information originate
exit-address-family
address-family ipv6 unicast
default-information originate
exit-address-family
end

ip route 192.168.99.0 255.255.255.0 192.168.77.1


ipv6 route 2001:db8:99:1::/64 2001:db8:feed:77::1
router ospfv3 1
address-family ipv4 unicast
redistribute static
exit-address-family
address-family ipv6 unicast
redistribute static
end

Otros

R1
router ospfv3 1
address-family ipv4 unicast
area 51 stub
exit-address-family
address-family ipv6 unicast
area 51 stub

R2

router ospfv3 1
address-family ipv4 unicast
area 51 stub
exit-address-family
address-family ipv6 unicast
area 51 stub

Lab 2-4
conf t
no ip domain-lookup
line con 0
logging synchronous
exec-timeout 0 0
exit

R1

interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:CAFE:1::1/64
no shutdown
exit
interface Serial1/0
ip address 192.168.2.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:CAFE:2::1/64
clock rate 64000
no shutdown

R2
interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:3::1/64
no shutdown
exit
interface Serial1/0
ip address 192.168.2.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:2::2/64
no shutdown
exit
interface Serial1/1
ip address 192.168.4.1 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:4::1/64
clock rate 64000
no shutdown

R3
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:CAFE:5::1/64
no shutdown
exit
interface Serial1/1
ip address 192.168.4.2 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:CAFE:4::2/64
no shutdown
exit
interface Serial1/2
ip address 192.168.77.2 255.255.255.0
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:FEED:77::2/64
clock rate 64000
no shutdown
exi

R4

interface Serial1/0
ip address 192.168.77.1 255.255.255.0
ipv6 address FE80::4 link-local
ipv6 address 2001:DB8:FEED:77::1/64
no shutdown
exit
ipv6 route 2001:DB8:CAFE::/48 2001:DB8:FEED:77::2
ip route 0.0.0.0 0.0.0.0 192.168.77.2
exit

Step 2

R1
ipv6 unicast-routing
router eigrp DUAL-STACK

address-family ipv4 unicast autonomous-system 4


eigrp router-id 1.1.1.1
network 192.168.1.0
network 192.168.2.0 0.0.0.3
exit-address-family

Step 3:

address-family ipv6 unicast autonomous-system 6


eigrp router-id 1.1.1.1

Step 4:

R2

ipv6 unicast-routing
router eigrp DUAL-STACK
address-family ipv4 unicast autonomous-system 4
eigrp router-id 2.2.2.2
network 192.168.2.0 0.0.0.3

network 192.168.3.0
network 192.168.4.0 0.0.0.3
exit-address-family

address-family ipv6 unicast autonomous-system 6


eigrp router-id 2.2.2.2

R2(config-router-af)#

R3

ipv6 unicast-routing
router eigrp DUAL-STACK
address-family ipv4 unicast autonomous-system 4
eigrp router-id 3.3.3.3
network 192.168.4.0 0.0.0.3

network 192.168.5.0
exit-address-family
address-family ipv6 unicast autonomous-system 6
eigrp router-id 3.3.3.3

R3(config-router-af)#

Step 5:

R1

router eigrp DUAL-STACK


address-family ipv4 unicast autonomous-system 4
af-interface gigabitethernet 0/0

R1

passive-interface
exit-af-interface
exit-address-family
address-family ipv6 unicast autonomous-system 6
af-interface gigabitethernet 0/0
passive-interface
exit-af-interface
exit-address-family

R1(config-router)#

R2

router eigrp DUAL-STACK


address-family ipv4 unicast autonomous-system 4
af-interface gigabitethernet 0/0
passive-interface
exit-af-interface
exit-address-family
address-family ipv6 unicast autonomous-system 6
af-interface gigabitethernet 0/0
passive-interface
exit
exit

R2(config-router)#

R3

router eigrp DUAL-STACK


address-family ipv4 unicast autonomous-system 4
af-interface gigabitethernet 0/0
passive-interface
exit-af-interface
exit-address-family
address-family ipv6 unicast autonomous-system 6
af-interface gigabitethernet 0/0
passive-interface
exit
exit

R3(config-router)#

Step 6:

R3

router eigrp DUAL-STACK


address-family ipv6 unicast autonomous-system 6
af-interface serial 1/2
shutdown
end

Step 7:
R3

ip route 0.0.0.0 0.0.0.0 192.168.77.1


ipv6 route ::/0 serial0/1/0 2001:db8:feed:77::1

router eigrp DUAL-STACK


address-family ipv4 unicast autonomous-system 4
topology base

redistribute static
exit-af-topology
exit-address-family
address-family ipv6 unicast autonomous-system 6
topology base
redistribute static
exit-af-topology
exit-address-family

__________________________________
Lab 4-2
R1

interface Loopback0
ip address 172.16.1.1 255.255.255.0
exit

interface Loopback48
ip address 192.168.48.1 255.255.255.0
exit

interface Loopback49
ip address 192.168.49.1 255.255.255.0
exit

interface Loopback50
ip address 192.168.50.1 255.255.255.0
exit

interface Loopback51
ip address 192.168.51.1 255.255.255.0
exit

interface Loopback70
ip address 192.168.70.1 255.255.255.0
exit

interface Serial1/0
ip address 172.16.12.1 255.255.255.0
clock rate 64000
bandwidth 64
no shutdown
exit

R2

interface Loopback0
ip address 172.16.2.1 255.255.255.0
exit
interface Loopback100
ip address 172.16.100.1 255.255.255.0
ip ospf network point-to-point
exit

interface Serial1/0
bandwidth 64
ip address 172.16.12.2 255.255.255.0
no shutdown
exit

interface Serial1/1
bandwidth 64
ip address 172.16.23.2 255.255.255.0
clock rate 64000
no shutdown
exit

R3

interface Loopback0
ip address 172.16.3.1 255.255.255.0
ip ospf network point-to-point
exit
interface loopback 8
ip address 192.168.8.1 255.255.255.0
ip ospf network point-to-point
exit
interface loopback 9
ip address 192.168.9.1 255.255.255.0
ip ospf network point-to-point
exit

interface loopback 10
ip address 192.168.10.1 255.255.255.0
ip ospf network point-to-point
exit

interface loopback 11
ip address 192.168.11.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback20
ip address 192.168.20.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback25
ip address 192.168.25.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback30
ip address 192.168.30.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback35
ip address 192.168.35.1 255.255.255.0
ip ospf network point-to-point
exit

interface Loopback40
ip address 192.168.40.1 255.255.255.0
ip ospf network point-to-point
exit

interface Serial1/1
ip address 172.16.23.3 255.255.255.0
bandwidth 64
no shutdown

Step 2: Configure Routing

R1

interface Serial1/0
ip summary-address eigrp 1 192.168.48.0 255.255.254.0
exit

router eigrp 1
no auto-summary
network 172.16.0.0
network 192.168.0.0 0.0.255.255
exit

R3
router ospf 1
area 20 range 192.168.8.0 255.255.252.0
network 172.16.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
network 192.168.8.0 0.0.3.255 area 20
exit

R2

router eigrp 1
no auto-summary
network 172.16.0.0
redistribute ospf 1 metric 10000 100 255 1 1500
exit

router ospf 1
network 172.16.23.0 0.0.0.255 area 0
network 172.16.100.0 0.0.0.255 area 10
redistribute eigrp 1 subnets
summary-address 192.168.48.0 255.255.252.0
exit

Step 3

R2
ip access-list standard OSPF20-FILTER
remark Used with DList to filter OSPF 20 routes
deny 192.168.8.0 0.0.3.255
permit any
exit

router eigrp 1
distribute-list OSPF20-FILTER out ospf 1

ip prefix-list EIGRP-FILTER description Used with DList to filter EIGRP


routes
ip prefix-list EIGRP-FILTER permit 172.16.0.0/16 le 24

router ospf 1
distribute-list prefix EIGRP-FILTER out eigrp 1
Step 5: Filter redistributed routes using a route map.

R2

ip access-list standard R3-ACL


remark ACL used with the R3-FILTER route map
permit 192.168.25.0 0.0.0.255
permit 192.168.30.0 0.0.0.255
exit

route-map R3-FILTER deny 10


description RM filters R3 OSPF routes
match ip address R3-ACL
exit

route-map R3-FILTER permit 20


description RM permits all other R3 OSPF routes
exit

router eigrp 1
redistribute ospf 1 route-map R3-FILTER metric 64 100 255 1 1500

c.6

route-map R1-FILTER permit 10


description RM filters 172.16.12.0/24
match ip address prefix-list R1-PL
set metric 25
set metric-type type-1
exit
route-map R1-FILTER permit 20
description RM permits all other R1 OSPF routes
exit

router ospf 1
redistribute eigrp 1 subnets route-map R1-FILTER
exit

________________________________________________________________________

Chapter 4 Lab 4-3,

R1

interface Loopback0
ipv6 address 2001:db8:A:0::1/64
exit
interface Loopback1
ipv6 address 2001:db8:A:1::1/64

exit
interface Loopback2
ipv6 address 2001:db8:A:2::1/64
exit
interface Loopback3
ipv6 address 2001:db8:A:3::1/64
exit
interface serial 1/0
ipv6 address 2001:db8:cafe:1::1/64
ipv6 address fe80::1 link-local
clock rate 64000
no shutdown
exit
R2

interface Loopback0
ipv6 address 2001:db8:B:0::1/64
exit

interface serial1/0
ipv6 address 2001:db8:cafe:1::2/64
ipv6 address fe80::2 link-local
no shutdown
exit

interface serial 1/1


ipv6 address 2001:db8:cafe:2::1/64
ipv6 address fe80::2 link-local
clock rate 64000
no shutdown

R3

interface Loopback0
ipv6 address 2001:db8:C:0::1/64
exit
interface Loopback1
ipv6 address 2001:db8:C:1::1/64
exit
interface Loopback2
ipv6 address 2001:db8:C:2::1/64
exit
interface Loopback3
ipv6 address 2001:db8:C:3::1/64
exit
interface Loopback4
ipv6 address 2001:db8:D:0::1/64
ipv6 address fe80::3 link-local
exit
interface Loopback5
ipv6 address 2001:db8:D:1::1/64
ipv6 address fe80::3 link-local
exit
interface Loopback6
ipv6 address 2001:db8:D:2::1/64
ipv6 address fe80::3 link-local
exit
interface Loopback7
ipv6 address 2001:db8:D:3::1/64
ipv6 address fe80::3 link-local
interface serial 1/1
ipv6 address 2001:db8:cafe:2::2/64
ipv6 address fe80::3 link-local
clock rate 64000
no shutdown
exit

************* Step 2: Configure EIGRP for IPv6.

R1

ipv6 unicast-routing
ipv6 router eigrp 1
eigrp router-id 1.1.1.1
no shutdown
exit
interface range lo 0 - 3
ipv6 eigrp 1
exit
interface s1/0
ipv6 eigrp 1
exit

R2
ipv6 unicast-routing
ipv6 router eigrp 1
eigrp router-id 2.2.2.2
no shutdown
exit

interface lo 0
ipv6 eigrp 1
exit
interface s1/0
ipv6 eigrp 1
exit

Step 4: Configure OSPFv3 Address Family.

R2

ipv6 unicast-routing
router ospfv3 1
address-family ipv6 unicast

router-id 2.2.2.2
exit-address-family
exit

interface Loopback0
ospfv3 1 ipv6 area 10
exit
interface serial 1/1
ospfv3 1 ipv6 area 0
exit

r3

router ospfv3 1
address-family ipv6 unicast
router-id 3.3.3.3
exit-address-family
exit

interface range lo 0 - 3
ospfv3 1 ipv6 area 0
exit

interface range lo 4 - 7
ospfv3 1 ipv6 area 20
exit

interface serial 1/1


ospfv3 1 ipv6 area 0
exit

Step 5: Configure mutual redistribution between OSPFv3 and EIGRP for


IPv6.

R2

router ospfv3 1
address-family ipv6 unicast
redistribute eigrp 1 include-connected
exit

ipv6 router eigrp 1


redistribute ospf 1 metric 1500 100 255 1 1500 include-connected
exit

You might also like