EIGRP

You might also like

Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 5

R1# no ip router domain-lookup

R1# hostname R1
R1# enable secret class
R1# line con 0
R1# password cisco
R1# login
R1# service password-encryption
R1# banner motd
R1# int g0/1
R1# des connection to S1
R1# ip address 172.27.0.1 25.255.255.0
R1# no shutdown
R1# int s0/0/0
R1# des connection to R2
R1# ip add 172.27.123.1 255.255.255.252
R1# clock rate 128000
R1# no shut
R1# int loopback 1
R1# ip address 172.27.1.1 255.255.255.0
R1# int loopback 2
R1# ip add 172.27.2.1 255.255.255.0
R1# int loopback 3
R1# ip add 172.27.3.1 255.255.255.0

BASIC CONFIG---------
R2# int S0/0/0
R2# des connection to R2
R2# ip add 172.27.123.2 255.255.255.252
R2# no shut
R2# int s0/0/1
R2# description connection to R3
R2# ip add 172.27.123.5 255.255.255.252
R2# clock rate 128000
R2# No shut
R2# int loopback 0
R2# des connection to internet
R2# ip add 209.165.200.225 255.255.255.248
R2# ip route 0.0.0.0 0.0.0.0 loopback 0

R3# BASIC CONFIG--------------

R3# int g0/1


R3# desc connection to S3
R3# ip address 172.27.0.3 255.255.255.0
R3# no shut
R3# int s0/0/1
R3# des Connection to R2
R3# ip add 172.27.123.6 255.255.255.252
R3# no shut
R3# int loopback 4
R3# ip ad 172.27.4.1 255.255.255.0
R3# int loopback 5
R3# ip add 172.27.5.1 255.255.255.0
R3# int loopback 6
R3# ip add 172.27.6.1 255.255.255.0

S W I T C H

S1# no ip domain-lookup
S1# hostname S1
s1# enable secret class
s1# line con 0
s1# password cisco
S1# login
s1# line vty 0 4
s1# password cisco
s1# login
s1# service password-encryption
s1# Banner motd
s1# int vlan 1
s1# ip ad 172.27.0.11 255.255.255.0
s1# no shut
s1# ip default-gateway 172.27.0.2

s1# int range f0/1-4


s1# switchport mode trunk
s1# switchport trunk native vlan 1

s1# int range f0/5-24, g0/1-2


s1# switchport mode access
s1# switchport nonegotiate
s1# int range f0/7-24, g0/1-2
s1# shutdown

S2# no ip domain-lookup
s2# hostname
s2# enable sercret class
s2# line con 0
sw# password cisco
s2# login
s2# line vty 0 4
s2# password cisco
s2# login
s2# service password-encryption
s2# int vlan 1
s2# ip add 172.27.0.12 255.255.255.0
s2# no shut
s2# ip default-gateway 172.27.0.2
s2# int range f0/1-4
s2# switchport mode trunk
s2# switchport trunk native vlan 1
s2# int range f0/5-24, g0/1-2
s2# switchport mode access
s2# switchport nonegotiate
s2# int range f0/5-17, f0/19-24, g0/1-2
s2# shutdown

s3# BASIC cONFIGURATION


s3# int vlan 1
s3# ip ad 172.27.0.13 255.255.255.0
s3# no shut
s3# ip default gateway 172.27.0.2
s3# int range f0/1-4
s3# switchport mode trunk
s3# switchport trunk native vlan 1
s3# int range f0/5-24, g0/1-2
s3# switchport mode acccess
s3# switchport mode nonegotiate
s3# int range f0/6-17, f0/19-24, g0/1-2
s3# shutdown

PCA 172.27.0.21 255.255.255.0 172.27.0.2


PCB 172.27.0.22
PC-C 172.27.0.23

SPANNING------------------------TREE

S1# spanning-tree mode rapit-pvst


s1# spanning-tree vlan 1 root primary
s1# int f0/6
s1# spanning-tree portfast
s1# spanning-tree bpduguard enable

s2# spanning-tree mode rapid-pvst


s2# int f0/18
s2# spanning-tree portfast
s2# spanning-tree bpduguard enable

S3# spanning-tree mode rapid-pvst


s3# spanning-tree vlan 1 root primary
s3# int f0/18
s3# spanning-tree portfast
s3# spanning-tree bpduguard enable

R1# int g0/1


r1# standby 1 ip 172.27.0.2
r1# standby 1 priority 150
R1# standyby 1 preempt

R3# int g0/1


R3# standby 1 ip 172.27.0.2

S1# int range f0/3-4


s1# channgel-group 1 mode active

s3# int range f0/3-4


s3# channel group 1 mode passive

R1# router eigrp 1


r!# eigrp router-id 1.1.1.1
R1# do show ip route concted
R1# network 172.27.0.0 0.0.0.255
r1# network 172.27.1.0 0.0.0.255
r1# network 172.27.2.0 0.0.0.255
r1# network 172.27.3.0 0.0.0.255
r1# network 172.26.123.0 0.0.0.3
r1# passive-interface g0/1
r1# passive-interface loopback 1
r1# passive-interface loopback 2
r1# passive-interface loopback 3
r1# no auto-summary

r1# int s0/0/0


r1# ip summary-address eigrp 1 172.26.0.0 255.255.252.0
r1# int s0/0/0
r1# bandwidth 128
r1# ip hello-interval eigrp 1 30
r1# ip hold-time eigrip 1 90 (remarks Invalid)
r1# exit

r!# key chain EIGRP-KEY


R1# key 1
R1# key-string cisco
r1# end

R1# int s0/0/0


r1# ip authintication mode eigrp 1 md5
r1# ip authentication key-chain eigrp 1 EIGRP-KEY

R2# router eigrp 1


r2# eigrp router-id 2.2.2.2
r2# network 172.27.123.4 0.0.0.3
R2# no auto-summary
R2# redistribute static
R2# Exit

R2# int s0/0/0


R2# bandwidth 128
R2# int s0/0/1
R2# bandwidth 128
R2# int s0/0/0
R2# ip hello-interval eigrp 1 30
R2# ip hold-time eigrp 1 90 (remarks invalid)
R2# int s0/0/1
r2# ip hellow interval eigrp 1 30
R2# no ip hellow-interval eigrp 1
R2# exit

R2# key chain EIGRP-KEY


R2# key 1
R2# key-string cisco
R2# end

R2# int s0/0/0


R2# ip authentication mode eigrp 1 md5
r2# ip authetication key-chain eigrp 1 EIRGRP-KEY

R3# router eigrp 1


R3# eigrp router-id 3.3.3.3
R3# do show ip route concted
R3# network . . . .
R3# passive-interface g0/1
R3# passive-inerface loopback 4
R3# passive-interface loopback 5 / loopback 6
R3# no auto-summary
R3# exit

R3# int s0/0/0/1


R3# bandwidth 128
R3# int s0/0/1
R3# ip summary-address eigrp 1 172.27.4.0 255.255.252.0
R3# int s0/0/1
R3# ip hello-interval eigrp 1 30
R3# ip hold-time eigrp 1 30
R3# no ip hello-interval eigrp 1
R3# ip bandwidth-percent eigrp 1 70
R3# exit

R3# key chain EIGRP-KEY


R3# key 1
R3# key-string cisco
R3# end

R3# int s0/0/1


R3# ip authentication mode eigrp 1 md5
R3# ip authentication key-chain eigrp 1 EIGRP-KEY

verefy network Commands _______

#show ip eigrp neighbor


#show ip eigrp detail
#show ip protocols

#show ip route eigrp

#show version
#show flash
#show license detail
##show license all

#conf t
#license accept end user agreeement

You might also like