SM Implementation Assignment PDF

You might also like

Download as pdf or txt
Download as pdf or txt
You are on page 1of 8

Lab Report 01

Lab Report: 01
Title: VLSM with Packet Tracer Implementation and Static Routing Configuration
Objective:
⇰ Use variable-length subnet mask (VLSM) to support more efficient use of the assigned IP
addresses for various requirement of the organizations in real life senior.
⇰ Configure a LAN and Test the connectivity of the LAN devices.
⇰ Static routing configuration of Wide Area Network (WAN).

Tools: CISCO Packet Tracer 6.3.


Simulation:
An IP Address 192.168.10.0/22 has been allocated in a university and hosts requirement of the
departments:
CSE Department = 60 hosts
EEE Department = 40 hosts
ETE Department = 30 hosts
These departments also have point to point link between them (CSE-EEE, CSE-ETE, ETE-EEE).
According the requirements and IP, the Subnetting Table will be,

Subnet Needed Allocated Address Mask Assignable Broadcast


Name Size Size Range Address
192.168.8.1
CSE 60 64 192.168.8.0 /26 - 192.168.8.63
192.168.8.62
192.168.8.65
EEE 40 64 192.168.8.64 /26 - 192.168.8.127
192.168.8.126
192.168.8.129
ETE 30 32 192.168.8.128 /27 - 192.168.8.159
192.168.8.158
192.168.8.161
CSE-EEE 2 4 192.168.8.160 /30 - 192.168.8.163
192.168.8.162
192.168.8.165
CSE-ETE 2 4 192.168.8.164 /30 - 192.168.8.167
192.168.8.166
192.168.8.169 1
ETE-EEE 2 4 192.168.8.168 /30 - 192.168.8.171
192.168.8.170

Md. Saidur Rahman Kohinoor || ID: 142-15-3669


Lab Report 01

That means we can define,


LAN 1 (CSE):
Network Address 192.168.8.0, Subnet Mask 255.255.255.192 and hosts range from 192.168.8.1
to 192.168.8.62 . Here we use first host IP 192.168.8.1 as our LAN 1’s default gateway.
LAN 2 (EEE):
Network Address 192.168.8.64, Subnet Mask 255.255.255.192 and hosts range from
192.168.8.65 to 192.168.8.126 . Here we use 192.168.8.65 as our LAN 2’s default gateway.
LAN 3 (ETE):
Network Address 192.168.8.128, Subnet Mask 255.255.255.224 and hosts range from
192.168.8.129 to 192.168.8.158 . Here we use 192.168.8.129 as our LAN 3’s default gateway.
WAN 1 (CSE-EEE):
Network Address 192.168.8.160, Subnet Mask 255.255.255.252 and hosts are 192.168.8.161 and
192.168.8.162
WAN 2 (CSE-ETE):
Network Address 192.168.8.164, Subnet Mask 255.255.255.252 and hosts are 192.168.8.165 and
192.168.8.166
WAN 3 (ETE-EEE):
Network Address 192.168.8.168, Subnet Mask 255.255.255.252 and hosts are 192.168.8.169 and
192.168.8.170

Now, draw a topology, assign IP addresses to the hosts, setting default gateway, configuring
routers for WAN and then showing their path as static routing protocol, like that-

Md. Saidur Rahman Kohinoor || ID: 142-15-3669


Lab Report 01

Hosts IP Configuration: Click on the PC and go to the IP configuration mode and then fill up,
PC1:
CSE

PC2:
CSE

PC3:
EEE

PC4:
EEE

PC5:
ETE

PC6: 3
ETE

Md. Saidur Rahman Kohinoor || ID: 142-15-3669


Lab Report 01

Command:
Router Configuration:
At first Assign IP addresses to the interfaces for both Serial interface and Fast Ethernet interface
and Define gateway to the host PCs. So, going to the Router 1 CLI mode and writing-
Router 1 (R1)
Router> en [enable]
Router# conf t [configure terminal]
Router(config)# interface f0/0
Router(config-if)# ip address 192.168.8.1 255.255.255.192 [gateway of host PCs]
Router(config-if)# no shut [no shutdown]
Router(config-if)# exit
Router(config)# interface s2/0
Router(config-if)# ip address 192.168.8.161 255.255.255.252
Router(config-if)# clock rate 64000
Router(config-if)# no shut
Router(config-if)# exit
Router(config)# interface s3/0
Router(config-if)# ip address 192.168.8.169 255.255.255.252
Router(config-if)# clock rate 64000
Router(config-if)# no shut
Router(config-if)# exit
Router(config)# exit
Router# copy run start [copy running-config startup-config]

Actually, copy run start is just copying the running configuration in RAM to the startup
configuration. So, for this configuration it is not mandatory.
However, Router1 configuration is done. Now, same as configure another Routers (R2 & R3).

Router 2 (R2)
Router> en
Router# conf t
Router(config)# interface f0/0
Router(config-if)# ip address 192.168.8.65 255.255.255.192
Router(config-if)# no shut
Router(config-if)# exit
Router(config)# interface s2/0
Router(config-if)# ip address 192.168.8.162 255.255.255.252 4
Router(config-if)# no shut
Router(config-if)# exit
Router(config)# interface s3/0

Md. Saidur Rahman Kohinoor || ID: 142-15-3669


Lab Report 01

Router(config-if)# ip address 192.168.8.165 255.255.255.252


Router(config-if)# clock rate 64000
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#exit
Router#copy run start

Router 3 (R3)
Router> en
Router# conf t
Router(config)# interface f0/0
Router(config-if)# ip address 192.168.8.129 255.255.255.224
Router(config-if)# no shut
Router(config-if)# exit
Router(config)# interface s2/0
Router(config-if)# ip address 192.168.8.170 255.255.255.252
Router(config-if)# no shut
Router(config-if)# exit
Router(config)# interface s3/0
Router(config-if)# ip address 192.168.8.166 255.255.255.252
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#exit
Router#copy run start

Ok, all routers configurations are done! Now, we define static routing to the routers as a final
step to introduce the path of the transferring packets.
R1
Router#config t
Router(config)#ip route 192.168.8.128 255.255.255.224 192.168.8.170
Router(config)#ip route 192.168.8.64 255.255.255.192 192.168.8.162
Router(config)#exit
Router#copy run start

R2
Router#config t
Router(config)#ip route 192.168.8.0 255.255.255.192 192.168.8.161 5
Router(config)#ip route 192.168.8.128 255.255.255.224 192.168.8.166
Router(config)#exit
Router#copy run start

Md. Saidur Rahman Kohinoor || ID: 142-15-3669


Lab Report 01

R3
Router#config t
Router(config)#ip route 192.168.8.0 255.255.255.192 192.168.8.169
Router(config)#ip route 192.168.8.64 255.255.255.192 192.168.8.165
Router(config)#exit
Router#copy run start

Results:
All works is done and it’s time for checking the outputs. So now testing the network with ping
and trace route (tracert) commands.

Ping from PC1 to PC6

We looking at here that four packets are sent and successfully all packets are received.
Same as Ping from PC3 to PC5

Md. Saidur Rahman Kohinoor || ID: 142-15-3669


Lab Report 01

That means all connections are well.


Now, Traceroute from PC2 to PC4

Md. Saidur Rahman Kohinoor || ID: 142-15-3669


Lab Report 01

Traceroute from PC5 to PC2

Comments:
Variable-Length Subnet Masking is configured on the router by enabling routing protocols (such
as EIGRP or OSPF) that support this (here I configured static routing), and by configuring the
subnet masks of the various Cisco interfaces in the ip address interface sub-command.

Download link: The full configured topology is available in that link-


https://www.dropbox.com/s/prlj3dyaw0im2lf/VLSM%20with%20packet%20Tracer.pkt?dl=0

8
----- The END -----

Md. Saidur Rahman Kohinoor || ID: 142-15-3669

You might also like