Download as doc, pdf, or txt
Download as doc, pdf, or txt
You are on page 1of 10

Packet Tracer – Troubleshooting GRE

Topology

Addressing Table
Device Interface IP Address Subnet Mask Default Gateway

G0/0 172.31.0.1 255.255.255.0 N/A


RA S0/0/0 209.165.122.2 255.255.255.252 N/A
Tunnel 0 192.168.1.1 255.255.255.252 N/A
G0/0 172.31.1.1 255.255.255.0 N/A
RB S0/0/0 64.103.211.2 255.255.255.252 N/A
Tunnel 0 192.168.1.2 255.255.255.252 N/A
PC-A NIC 172.31.0.2 255.255.255.0 172.31.0.1
PC-C NIC 172.31.1.2 255.255.255.0 172.31.1.1

Objectives
Find and Correct All Network Errors
Verify Connectivity

Scenario
A junior network administrator was hired to set up a GRE tunnel between two sites and was unable to
complete the task. You have been asked to correct configuration errors in the company network.

© 2017 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 1 of 4
Packet Tracer – Troubleshooting GRE

Part 1: Find and Correct All Network Errors.


Device Error Correction

RA G0/0 IP interface and subnet mask is not interface Tunnel 0


correct. Tunnel address must be removed no ip address
to prevent overlap error.
interface g0/0
ip address 172.31.0.1 255.255.255.0
RA T0 IP address is not correct. interface Tunnel 0
ip address 192.168.1.1 255.255.255.252

RA Static route is not correct. no ip route 172.31.1.0 255.255.255.0 64.103.211.2


ip route 172.31.1.0 255.255.255.0 192.168.1.2

RB Tunnel destination address is not correct. tunnel destination 209.165.122.2

RB Tunnel source port is not correct. tunnel source Serial0/0/0

Part 2: Verify Connectivity


Step 1: Ping PCA from PCB.
Attempt to ping the IP address of PCA from PCB. The ping should be successful.

No se tiene respuesta de ping desde PCB hacia PCA:


Step 2: Trace the path from PCA to PCB.
Attempt to trace the path from PCA to PCB. Note the lack of public IP addresses in the output.

Se detiene traza en el salto debido a que no llega ni a la puerta de enlace.

Device Configs

Router RA
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
hostname RA
interface Tunnel0
ip address 192.168.1.1 255.255.255.252
tunnel source Serial0/0/0
tunnel destination 64.103.211.2

© 2017 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 2 of 4
Packet Tracer – Troubleshooting GRE

tunnel mode gre ip


interface GigabitEthernet0/0
ip address 172.31.0.1 255.255.255.0
duplex auto
speed auto
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
interface Serial0/0/0
ip address 209.165.122.2 255.255.255.252
interface Serial0/0/1
no ip address
shutdown
interface Vlan1
no ip address
shutdown
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
ip route 172.31.1.0 255.255.255.0 192.168.1.2
line con 0
line aux 0
line vty 0 4
login
end

Router RB
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
hostname RB
interface Tunnel0
ip address 192.168.1.2 255.255.255.252
tunnel source Serial0/0/0
tunnel destination 209.165.122.2
tunnel mode gre ip
interface GigabitEthernet0/0
ip address 172.31.1.1 255.255.255.0
duplex auto
speed auto
interface GigabitEthernet0/1
no ip address
duplex auto

© 2017 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 3 of 4
Packet Tracer – Troubleshooting GRE

speed auto
shutdown
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
interface Serial0/0/0
ip address 64.103.211.2 255.255.255.252
interface Serial0/0/1
no ip address
shutdown
interface Vlan1
no ip address
shutdown
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
ip route 172.31.0.0 255.255.255.0 192.168.1.1
line con 0
line aux 0
line vty 0 4
login
end

Se aplica la configuración relacionada anteriormente.

Plantilla Router RA:


RA#sh run
Building configuration...

Current configuration : 1098 bytes


!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RA
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX15242579
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Tunnel0
ip address 172.31.0.1 255.255.255.0
mtu 1476
tunnel source Serial0/0/0
tunnel destination 64.103.211.2
!
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 209.165.122.2 255.255.255.252
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
ip route 172.31.1.0 255.255.255.0 64.103.211.2
ip route 172.31.1.0 255.255.255.0 192.168.1.2
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Plantilla Router RB:
RB#sh run
Building configuration...

Current configuration : 1050 bytes


!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RB
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX152497Z4
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Tunnel0
ip address 192.168.1.2 255.255.255.252
mtu 1476
tunnel source Serial0/0/0
tunnel destination 209.165.122.2
!
!
interface GigabitEthernet0/0
ip address 172.31.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 64.103.211.2 255.255.255.252
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
ip route 172.31.0.0 255.255.255.0 192.168.1.1
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Aun no se tiene respuesta de ping entre los PC´s la traza del PCA no llega al GW y la del PCB se queda en este:
Al identificar los errores se aplican las correcciones correspondientes y se logra respuesta entre PCA y PCB:

You might also like