Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 2

!

R10
!---------------
int f0/0
ip add 172.16.0.1 255.255.255.252
no sh

!********Loop back address*************!


int lo0
ip add 10.10.10.10 255.255.255.255

!*******Local Network*******************!
int lo1
ip add 20.0.0.1 255.255.255.255

!****Making 11.11.11.11 reachable from R10****!


ip route 11.11.11.11 255.255.255.255 172.16.0.2

!****Configuring eBGP************************!
router bgp 100
neighbor 11.11.11.11 remote-as 200

!*****Asking the R11 to use its loopback0 IP for TCP session and updates**!
neighbor 11.11.11.11 update-source loopback 0

!****By default the TTL value of a packet over a eBGP link is 1, hence
!it cannot go to loopback interface, as the TTL will expire, we asking R10
!to make TTL value, 2*****!
neighbor 11.11.11.11 ebgp-multihop 2

end
wr
!
***********************************************************************************
*********!
!R11
!---------------
int f0/0
ip add 172.16.0.2 255.255.255.252
no sh

!********Loop back address*************!


int lo0
ip add 11.11.11.11 255.255.255.255

!*******Local Network*******************!
int lo1
ip add 30.0.0.1 255.255.255.255

!****Making 10.10.10.10 reachable from R10****!


ip route 10.10.10.10 255.255.255.255 172.16.0.1

!****Configuring eBGP************************!
router bgp 200
neighbor 10.10.10.10 remote-as 100

!*****Asking the R11 to use its loopback0 IP for TCP session and updates**!
neighbor 10.10.10.10 update-source loopback 0

!****By default the TTL value of a packet over a eBGP link is 1, hence
!it cannot go to loopback interface, as the TTL will expire, we asking R10
!to make TTL value, 2*****!
neighbor 10.10.10.10 ebgp-multihop 2

end
wr
-------------------------
Now the networks would be reachable

You might also like