Eth Trunk Configuration

You might also like

Download as pdf or txt
Download as pdf or txt
You are on page 1of 12

Eth-Trunk technical principle and configuration

Preface
As the volume of services deployed in the network continues to grow, for full-duplex point-
to-point links, the bandwidth of a single physical link can no longer meet the needs of normal
business traffic. If the current interface board is replaced with an interface board with higher
bandwidth, existing equipment resources will be wasted, and the upgrade cost will be relatively
high. If you increase the number of links between devices, you need to configure an IP address
on each interface when used as a Layer 3 interface, which will result in a waste of IP address
resources.
Eth-Trunk (link aggregation technology), as a bundling technology, can bind multiple
independent physical interfaces together as a large-bandwidth logical interface, so that neither
interface boards need to be replaced nor IP address resources are wasted. In this course, we will
introduce Eth-Trunk technology in detail.

Basic principles of Eth-Trunk


Eth-Trunk concept

Eth-Trunk is a bundling technology that bundles multiple Ethernet interfaces into one
logical interface.
Eth-Trunk link aggregation mode:
Manual load sharing mode;
LACP mode.

According to different link aggregation modes, the Eth-Trunk interface can increase
bandwidth, load sharing, etc., helping to improve network reliability.
Eth-Trunk can be used for Layer 2 link aggregation or Layer 3 link aggregation. By default,
the Ethernet interface works in Layer 2 mode. If you need to configure a Layer 2 Eth-Trunk
interface, you can switch the interface to a Layer 2 interface through the portswitch command; if
you need to configure a Layer 3 Eth-Trunk interface, you can switch the interface to a Layer 3
interface through the undo port switch command.
Advantages:
1) Increase the bandwidth;
2) Improve link reliability;
3) Able to achieve load sharing;

Manual load sharing mode

When at least one of the two devices does not support the LACP protocol, you can use the
Eth-Trunk in manual load sharing mode to increase the bandwidth and reliability between the
devices.
In manual load sharing mode, all links that join the Eth-Trunk perform data forwarding.
Huawei's default Eth-Trunk is this mode.

LACP mode

LACP mode is also called M:N mode. Data is forwarded when the M link is in an active
state, and the N link is a backup link when the N link is in an inactive state.
Conditions: The switch must be able to support this LACP protocol, and the devices at both
ends can communicate in LACP mode.
work process
1) Two switches select an active segment and a passive end to compare by LACP priority
2) Determine the respective numbers of active links and inactive links on the active end
3) When one of the active links has a problem, the device will substitute on the inactive
link. Parameter data forwarding
4) When the active link is restored, the replacement link becomes an inactive link and does
not participate in data forwarding
As shown in the figure: There are M+N (2+1) links between the two devices. Data is forwarded
on the M (2) link on the aggregate link, and data is not forwarded on the N (1) link. Now The
actual bandwidth is the sum of M(2), but the bandwidth provided is the sum of M(2)+N(1).
When a faulty link occurs in the M(2) link, a link with the highest priority will be selected from
the N(1) backup links to replace the faulty link. The actual bandwidth on the link is still M(2),
the maximum bandwidth provided is M(2)+N(1)-M (faulty link).

Selection of active link in LACP mode

As shown in the figure, the number of links between devices is 3, and the maximum number
of active links is set to 2, that is, 2 links are in the forwarding state and 1 link is in the backup
state.
If there are links to join, the devices will exchange information (system priority, MAC
address, interface priority, interface number and other information), compare the priority to reach
a consensus, those are active links, those backup links.
Active end election: system LACP priority (the smaller the priority) >> MAC address (the
smaller the priority);
Active interface election: interface LACP priority (the smaller the priority) >> the interface
ID (the smaller the priority);

Preemption mechanism of LACP mode

When LACP preemption occurs, the link in the standby state will wait for a period of time
before switching to the forwarding state. This is the preemption delay. The preemption delay is
configured to avoid unstable Eth-Trunk data transmission due to frequent changes in some link
status.
As shown in the figure, Port1 was switched to an inactive interface due to a link failure, and
then the link returned to normal. If the system enables LACP preemption and configures the
preemption delay, Port1 needs to pass the preemption delay time to switch back to the active
state.
Enable preemption scenario:
Port1 interface failed and then returned to normal. When the interface Port1 fails, it is
replaced by Port3. If preemption is not enabled under the Eth-Trunk interface, Port1 will be in
the backup state when the fault is restored; if LACP preemption is enabled, when Port1 fails to
recover, due to the interface priority Higher than Port3, it will become the active interface again,
and Port3 will become the backup interface again.
If you want the Port3 interface to replace one of Port1 and Port2 as the active interface, you
can increase the LACP priority of the Port3 interface, but the prerequisite is that the LACP
preemption function has been enabled. If the LACP preemption function is not enabled, even if
the priority of the backup interface is adjusted to be higher than the priority of the current active
interface, the system will not proceed to the process of reselecting the active interface or switch
the active interface.

Eth-Trunk interface load sharing

When the Eth-Trunk interface performs load sharing, you can select IP addresses or
packets as the hash basis for load sharing; at the same time, you can also set the load sharing
weight of member interfaces.
In the Eth-Trunk interface, the greater the weight of a member interface accounts for the
total load sharing weight of all member interfaces, the greater the load that the member interface
bears.

Interface load
Features
sharing
Per-flow load
IP-based hashing algorithm can guarantee the order of packets, but cannot
sharing
guarantee bandwidth utilization
(default mode)
The packet-based hash algorithm can guarantee bandwidth utilization, but
cannot guarantee the order of packets. Packet-by-packet forwarding may lead to
Per-packet inconsistent packets back and forth, which will affect the features that depend on
load sharing state detection or the normal use of scenarios (such as NAT). ), when you need
to ensure the same return path of the message, please do not choose the packet-
by-packet load sharing method

Eth-Trunk configuration
Manual load sharing mode (default mode)

interface Eth-Trunk trunk-id //Create an Eth-Trunk interface and enter Eth-


Trunk interface view
portswitch //Switch the Eth-Trunk interface to Layer 2 mode
mode manual load-balance //Configure the current Eth-Trunk working
mode to manual load balancing mode
trunkport interface-type {interface-number1 [to interface-number2]}
&<1-16> // Add member interfaces in batches
 1
 2
 3
 4

LACP mode

interface Eth-Trunk12
mode lacp-static //Modify our mode
lacp preempt enable //Enable the preemption function of our interface
lacp preempt delay 10 //The delay time of device preemption
max active-linknumber 2 //Number of active links
interface GigabitEthernet0/0/2
lacp priority 4096 //Set priority (default 32768)

 1
 2
 3
 4
 5
 6
 7
R1/R2

[R1] interface Eth-Trunk 1 //Enter Eth-Trunk interface view


[R1--Eth-Trunk1] undo portswitch //Convert the interface to a Layer 3
interface
[R1--Eth-Trunk1] description "Core-R1 to Aggregate-SW3" //Description
information, which is convenient for the administrator to understand the
device connected to the opposite end of the interface
[R1--Eth-Trunk1] ip address 192.168.1.254 24
[R1--Eth-Trunk2] trunkport GigabitEthernet 0/0/0 to 0/0/1 //Join the
interface member

[R1] interface Eth-Trunk 2 //Enter Eth-Trunk interface view


[R1--Eth-Trunk2] undo portswitch //Convert the interface to a Layer 3
interface
[R1--Eth-Trunk2] description "Core-R1 to Core-R2" //Description information,
so that the administrator can understand the device connected to the opposite
end
[R1--Eth-Trunk2] ip address 192.168.1.1 24
[R1--Eth-Trunk2] trunkport GigabitEthernet 1/0/0 to 1/0/1 //Join the
interface member
 1
 2
 3
 4
 5
 6
 7
 8
 9
 10
 11

SW3/SW4: Because the convergence layer devices use Layer 2 interconnection, there is no need
to configure the address

[SW3] interface Eth-Trunk 1


[SW3--Eth-Trunk1] description "Aggregate-SW3 to Core-R1"
[SW3--Eth-Trunk1] trunkport GigabitEthernet 0/0/1 to 0/0/2

[SW3] interface Eth-Trunk 2


[SW3--Eth-Trunk2] description "Aggregate-SW3 to Aggregate-SW4"
[SW3--Eth-Trunk2] trunkport GigabitEthernet 0/0/3 to 0/0/4

[SW3] interface Eth-Trunk 3


[SW3--Eth-Trunk3] description "Aggregate-SW3 to Aggregate-SW5"
[SW3--Eth-Trunk3] trunkport GigabitEthernet 0/0/5 to 0/0/6

[SW3] interface Eth-Trunk 4


[SW3--Eth-Trunk4] description "Aggregate-SW3 toAggregate-SW6"
[SW3--Eth-Trunk4] trunkport GigabitEthernet 0/0/7 to 0/0/8

 1
 2
 3
 4
 5
 6
 7
 8
 9
 10
 11
 12
 13
 14
 15

SW5/6/7/8: The command is similar

[SW3] interface Eth-Trunk 1


[SW3--Eth-Trunk1] description "Aggregate-SW3 toAggregate-SW3"
[SW3--Eth-Trunk1] trunkport GigabitEthernet 0/0/1 to 0/0/2

 1
 2
 3

Eth-Trunk notes
The number, duplex mode, and flow control configuration of the physical interfaces connected at
both ends of the Eth-Trunk must be consistent.
1) When two devices are connected, it is necessary to ensure that the link aggregation mode
on both devices is the same.
2) When deleting an aggregation group, you need to delete the member interfaces in the
aggregation group first.
3) Some command lines (such as port link-type access) and static MAC addresses cannot be

configured under member interfaces, and an error will be reported if the device is configure

Eth-Trunk bundled technology

In the network, if there is a problem with a bandwidth, the upgrade link is usually selected,
which is the specific selection, which is determined according to the cost performance. In the
actual engi...

Eth-Trunk (link aggregation)


Eth-Trunk Basic Principle Ethernet link aggregation Eth-Trunk is referred to as link aggregation,
which enables the purpose of increasing link bandwidth by bundling multiple Ethernet physical
links to...

Eth-Trunk (link aggregation)

Eth-Trunk (link aggregation) Ethernet link aggregation Eth-Trunk is referred to as link


aggregation, which enables the purpose of increasing link bandwidth by bundling multiple
Ethernet physical links...

HCIE (Huawei Eth-trunk and E-trunk)

Eth-trunk Fundamentals · Eth-trunk (Link Aggregation), referred to as link aggregation; It


together into a logical link by bundling a plurality of physical Ethernet links, so as to achieve the
...

Introduction to IP-TRUNK (compared to ETH-TRUNK learning)

Introduction to IP-Trunk Introduce the definition and purpose of IP-Trunk. definition IP-Trunk
binds multiple POS interfaces or Serial ports with HDLC as the link layer protocol to form a
logical data...
More Recommendation

HC110110022 VLAN principle and configuration (Trunk and Access)

VLAN principle and configuration Network topology map Configure Unicom test Catch analysis
Network topology map Configure Configuration on SW1: vlan batch 2 to 3 interface
Ethernet0/0/1 port link-type...

Understand eth-trunk link aggregation and configure Eth-Trunk link


aggregation

Configure eth-trunk link aggregation Principle concept: Advantages: 1. Load sharing. 2. Improve
reliability. 3. Increase bandwidth. Purpose: 1. Understand the application scenarios of using eth-
trunk....

Huawei eth-trunk, dhcp experiment

S1 vlan batch 2 to 3 dhcp enable ip pool vlan2 gateway-list 10.0.10.1 network 10.0.10.0 mask
255.255.255.0 ip pool vlan3 gateway-list 10.0.20.1 network 10.0.20.0 mask 255.255.255.0
interface Vlanif2 i...
Link aggregation Eth-Trunk technology

Link aggregation Eth-Trunk 1. Basic principles of Eth-Trunk 1. Basic principles of Eth-Trunk 1.


The link aggregation technology can bind multiple independent physical interfaces together as a
large-ba...

Ethernet link aggregation Eth-Trunk

Ethernet link aggregation Eth-Trunk is abbreviated as link aggregation. By bundling multiple


physical interfaces into one logical interface, it can achieve the purpose of increasing link
bandwidth wit...

You might also like