Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 9

System and Network Admin Lab 3

Configuring Static Routing and Dynamic routing protocol


Learning Objectives

Upon completion of this lab, you will be able to:

 Cable a network according to the topology diagram

 Erase the startup configuration and reload router to the default state
 Perform basic configuration tasks on a router
 Assign IP address to the routers ports

 Statically routing indirectly connected LAN to each router


 Configuring dynamic routing on routers

 Verify configuration by using show IP route command


 Verify the configured networks by using ping command and massaging methods

Task 1: Prepare the Network


Step 1: Cable a network that is similar to the one in the topology diagram.
Step 2: Clear any existing configurations on the Router, and initialize all ports in the
shutdown state.
In router devices the ports (Fast Ethernet and serial ports) are shut down by default, so the following
activity/task is an optional for a router, but if the device is switch it is mandatory.

Router>
Router >enable
Router #
Router #config t
Router (config)#interface range fa0/0 - 1
Router (config-if-range)#shutdown
Router (config-if-range)#exit
NOTE: DO THIS FOR ALL OETHER ROUTERS

Task 2: Perform Basic Router Configurations


Step 1: Configure the router according to the following guidelines.

 Configure the router hostname (R1, R2, R3, and R4)

 Configure an EXEC mode password or enable password of lab3.


Step 2: Assign IP address, Description and Re-enable the user ports on the Routers.
On router one
Router> enable
Router#config t
Router(config)#hostname R1
R1(config)#enable password 123
R1(config)#int fa0/0
R1(config-if)#ip address 172.16.3.1 255.255.255.0
R1(config-if)#description connect to LAN2
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int serial2/0
R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#show ip route
DO THE SAME TASKS FOR OTHER ROUTERS
NOTE: - you should have to take care about the IP address you assigned for each port of the router.
Devic Port IP address Subnet mask Description
e
R1 Fa0/0 172.16.3.1 255.255.255.0 Connect to LAN2
Serial2/0 172.16.2.1 255.255.255.0 Connect to R2
R2 Fa0/0 172.16.1.1 255.255.255.0 Connect to LAN1
Sr2/0 172.16.2.2 255.255.255.0 Connect to R1
Sr3/0 192.168.1.1 255.255.255.0 Connect to R3
R3 Sr2/0 192.168.1.2 255.255.255.0 Connect to R2
Fa0/0 192.168.3.1 255.255.255.0 Connect to LAN3
Fa1/0 192.168.2.1 255.255.255.0 Connect to R4
R4 Fa0/0 192.168.2.2 255.255.255.0 Connect to R3
Fa1/0 192.168.4.1 255.255.255.0 Connect to LAN4

Task 3: Configure All routes to know about LAN indirectly connected


Step 1: Starting from R1 to all other configure the following
R1#config t
R1(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.2
R1(config)#ip route 192.168.3.0 255.255.255.0 172.16.2.2
R1(config)#ip route 192.168.4.0 255.255.255.0 172.16.2.2
R1(config)#exit
R1#show ip route

DO THE SAME TASK FOR OTHER ROUTER?


Step 2: configure IP address for the pc based on their LAN network given

Configure the IP addresses for those PCs by referring to the following tables.
Alternatively, you can configure all PCs with the IP addresses and default gateways.

Network End devices IP address Subnet mask Getaways


LAN1(172.16.1.0) PC3 172.16.1.2 255.255.255.0 172.16.1.1
PC4 172.16.1.3 255.255.255.0 172.16.1.1
PC5 172.16.1.4 255.255.255.0 172.16.1.1
PC6 172.16.1.5 255.255.255.0 172.16.1.1
LAN2(172.16.3.0) PC 172.16.3.2 255.255.255.0 172.16.3.1
PC 172.16.3.3 255.255.255.0 172.16.3.1
PC 172.16.3.4 255.255.255.0 172.16.3.1
PC 172.16.3.5 255.255.255.0 172.16.3.1
LAN3(192.168.3.0) PC 192.168.3.2 255.255.255.0 192.168.3.1
PC 192.168.3.3 255.255.255.0 192.168.3.1
PC 192.168.3.4 255.255.255.0 192.168.3.1
PC 192.168.3.5 255.255.255.0 192.168.3.1
LAN4(192.168.4.0) PC 192.168.4.2 255.255.255.0 192.168.4.1
PC 192.168.4.3 255.255.255.0 192.168.4.1
PC 192.168.4.4 255.255.255.0 192.168.4.1
PC 192.168.4.5 255.255.255.0 192.168.4.1

Task 4: Verify the designed network


Step 1: Verify the network using messaging method.

To verify the network using message method try to select one pc from LAN1 as a source and then select
the one pc from LAN4 as a destination point.

Q1. Is the massage successfully worked or not? if not try to see the configuration of routers that connects
the selected LAN.

Step 2: verify the network using ping methods.


To do this go to CMD of one pc in LAN1 and ping the destination IP of other LAN.
Q. is the ping successfully working or not? if not try to see the configuration of routers that connects the
selected LAN.

Task 5: Configuring Dynamic routing protocol


Step 1: design the following network topology
Step 2 : Based on the IP address on the diagram configure all routers
Router name Port Ip Address

Router 1 Fa 0/0 192.168.1.1/24

Ser 2/0 192.168.2.1/24

Router 2 Fa 0/0 192.168.3.1/24

Ser 2/0 192.168.2.2/24

Ser3/0 192.168.4.1/24

Router 3 Ser2/0 192.168.4.2/24

Fa 0/0 192.168.5.1/24

Configuration on router 1.
Router > en
Router# config t
Router (config)# int fa0/0
Router (config-if) ip address 192.168.1.1 255.255.255.0
Router (config-if) no shutdown
Router (config-if) exit.

Router (config)# int serial2/0


Router (config-if) ip address 192.168.2.1 255.255.255.0
Router (config-if) no shutdown
Router (config-if) exit.
DO THE SAME THINK ON ROUTER TWO AND THREE BASED ON THE ABOVE TABLE

Step 3 : configure dynamic routing on all three using RIP protocol


Configuration on router one using RIP protocol
Router > en
Router# config t
Router (config)# router rip
Router(config-router)# network 192.168.1.0
Router(config-router)# network 192.168.2.0
Router(config-router)# exit
DO THE SAME THINK ON ROUTER TWO AND THREE BASED ON THE ABOVE TABLE

Step 3 : try to verify routers the network.

Task 6: remote login using Telnet and DHCP configuration


Use the above designed network for remote login
Step 1: create line VTY password and enable password for the PEM access.
On Roter-1 do the following: -
Router(config)#line vty 0 4
Router(config-line)#password 123
Router(config-line)#login
Router(config-line)#exit
Router(config)#enable password abc
Then go to PC1 on CMD and write the following commands:
telnet 192.168.1.1

Step 2: configure router for the dhcp protocols –


Router(config)#
Router(config)#ip dhcp pool MY_LAN
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#dns-server 192.168.1.20
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.20
Task 7: Servers (DHCP, HTTP, and DNS), and Wireless AP configuration (default and authentication)

Step 1: design the above network (if you have the pervious lab designed network it is possible to use it) –
1.1. Assign proper IP for the routers port and try to use route protocol either statically or dynamic
1.2. Assign the last IP address statically for each server with respect to their LAN
1.3. Do configuration using GUI for the servers start from DHCP, HTTP, and then DNS
1.3.1. After configuring DHCP go to each router which not directly connected to
DHCP LAN and select router port which relative to LAN then enter the
following command: -
1.3.2. #ip helper-address 192.168.4.254(DHCP IP address)
1.3.3. Then try to check end devices IP DHCP
1.4. Then try to check all severs.
Step 2: connect wireless switch for each LAN (one is default and the other two should have SSID and
WEP key for a security purpose)

You might also like