Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 3

! device: leaf2 (vEOS, EOS-4.22.

0F)
!
! boot system flash:/vEOS-lab.swi
!
errdisable recovery cause uplink-failure-detection
!
transceiver qsfp default-mode 4x10G
!
service routing protocols model multi-agent
!
hostname leaf2
!
spanning-tree mode mstp
no spanning-tree vlan 4090-4091
!
no aaa root
!
vlan 40
name test-l2-vxlan
!
vlan 4090
name mlag-peer
trunk group mlag-peer
!
vlan 4091
name mlag-ibgp
trunk group mlag-peer
!
vrf definition mgmt
!
interface Port-Channel121
switchport trunk allowed vlan 40
switchport mode trunk
mlag 121
!
interface Port-Channel999
description MLAG Peer
switchport mode trunk
switchport trunk group mlag-peer
spanning-tree link-type point-to-point
!
interface Ethernet1
!
interface Ethernet2
description spine1
mtu 9214
no switchport
ip address 10.0.1.3/31
!
interface Ethernet3
description spine2
mtu 9214
no switchport
ip address 10.0.2.3/31
!
interface Ethernet4
!
interface Ethernet5
!
interface Ethernet6
!
interface Ethernet7
!
interface Ethernet8
!
interface Ethernet9
!
interface Ethernet10
description mlag peer link
channel-group 999 mode active
!
interface Ethernet11
!
interface Ethernet12
channel-group 121 mode active
!
interface Loopback0
ip address 10.0.250.12/32
!
interface Loopback1
ip address 10.0.255.11/32
!
interface Management1
vrf forwarding mgmt
ip address 172.16.0.50/24
!
interface Vlan40
ip address 10.40.40.1/24
!
interface Vlan4090
no autostate
ip address 10.0.199.255/31
!
interface Vlan4091
mtu 9214
ip address 10.0.3.1/31
!
interface Vxlan1
vxlan source-interface Loopback1
vxlan udp-port 4789
vxlan vlan 40 vni 110040
vxlan vlan 40 flood vtep 10.0.255.12
vxlan learn-restrict any
!
ip virtual-router mac-address c0:01:ca:fe:ba:be
!
ip routing
no ip routing vrf mgmt
!
mlag configuration
domain-id leafs
local-interface Vlan4090
peer-address 10.0.199.254
peer-address heartbeat 172.16.0.25 vrf mgmt
peer-link Port-Channel999
dual-primary detection delay 10 action errdisable all-interfaces
!
router bgp 65001
router-id 10.0.250.12
no bgp default ipv4-unicast
distance bgp 20 200 200
maximum-paths 4 ecmp 64
neighbor evpn peer-group
neighbor evpn remote-as 65000
neighbor evpn update-source Loopback0
neighbor evpn ebgp-multihop 3
neighbor evpn send-community extended
neighbor evpn maximum-routes 12000 warning-only
neighbor underlay peer-group
neighbor underlay remote-as 65000
neighbor underlay maximum-routes 12000 warning-only
neighbor underlay_ibgp peer-group
neighbor underlay_ibgp remote-as 65001
neighbor underlay_ibgp next-hop-self
neighbor underlay_ibgp maximum-routes 12000 warning-only
neighbor 10.0.1.2 peer-group underlay
neighbor 10.0.2.2 peer-group underlay
neighbor 10.0.3.0 peer-group underlay_ibgp
neighbor 10.0.250.1 peer-group evpn
neighbor 10.0.250.2 peer-group evpn
!
vlan 40
rd 65001:110040
route-target both 40:100040
redistribute learned
!
address-family evpn
neighbor evpn activate
!
address-family ipv4
neighbor underlay activate
neighbor underlay_ibgp activate
network 10.0.250.12/32
network 10.0.255.11/32
!
end

You might also like