Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 3

••• MPLS :

•• Introduction :
• MPLS = WAN Technology
• MPLS = Multi Protocol Label Switching
• Extend to multiple protocols : Layer 2 protocols (HDLC, PPP, ...) and Layer 3
protocols (IPv4, IPv6, ...)
• Based on the label switching
• Label is a tag or integer associated with the packets in the MPLS network. The
MPLS use it to make a routing decisions.

•• MPLS Objectives :
• Increase the transfer speed
• Combine the layer 2 protocols and layer 3 protocols
• Traffic engineering
• Flexibility

•• MPLS Packet : L2 Header + MPLS Header + L3 Header + DATA

•• MPLS Header : Label + EXP + S + TTL


• Label = 20 bits : Integer to be used for the routing decisions
• EXP = 3 bits : For the QOS
• S = 1 bit : To support the hierarchical label
• TTL = 8 bits : To avoid the loops

•• MPLS Operations : See the Picture 1

•• MPLS Configuration : See the Picture 2


• Basic Configuration :
- Hostname
- Addressing (Backbone interfaces)
- Routing (Backbone zone) : OSPF 1 area 0

• Test :
- PING from PE1 to PE2/PE3
# ping 20.20.20.20
# ping 30.30.30.30

- Routing Table :
# show ip route ospf | begin Gateway

• LDP Configuration :
- LDP = Label Distributed Protocol
- LDP = MPLS
#router ospf 1
#mpls ldp autoconfig
#exit

• Test :
#do show mpls interfaces
#do show mpls ldp neighbor
#do traceroute 20.20.20.20

• MP-BGP :
- PE1 :
router bgp 1
neighbor 20.20.20.20 remote-as 1
neighbor 30.30.30.30 remote-as 1
neighbor 20.20.20.20 update-source lo 0
neighbor 30.30.30.30 update-source lo 0
no auto-summary
address-family vpnv4 unicast
neighbor 20.20.20.20 activate
neighbor 30.30.30.30 activate
exit
exit

- PE2 :
router bgp 1
neighbor 10.10.10.10 remote-as 1
neighbor 30.30.30.30 remote-as 1
neighbor 10.10.10.10 update-source lo 0
neighbor 30.30.30.30 update-source lo 0
no auto-summary
address-family vpnv4 unicast
neighbor 10.10.10.10 activate
neighbor 30.30.30.30 activate
exit
exit

- PE1 :
router bgp 1
neighbor 20.20.20.20 remote-as 1
neighbor 10.10.10.10 remote-as 1
neighbor 20.20.20.20 update-source lo 0
neighbor 10.10.10.10 update-source lo 0
no auto-summary
address-family vpnv4 unicast
neighbor 20.20.20.20 activate
neighbor 10.10.10.10 activate
exit
exit

• Test :
do show bgp vpnv4 unicast all summary

• VRF Configuration :
- VRF = Virtual Routing Forwarder
- VRF = Allows to create a multiple instances of a Routing table on the same router
- PE1 :
ip vrf UITS
rd 1:1
route-target both 1:1
exit
interface GigabitEthernet0/1
no sh
ip vrf forwarding UITS
ip address 11.0.0.1 255.255.255.0
exit
router ospf 1000 vrf UITS
network 11.0.0.0 0.0.0.255 area 1
exit

- PE2 :
ip vrf UITS
rd 1:1
route-target both 1:1
exit
interface GigabitEthernet0/1
no sh
ip vrf forwarding UITS
ip address 18.0.0.1 255.255.255.0
exit
router ospf 1000 vrf UITS
network 18.0.0.0 0.0.0.255 area 1
exit

- PE3 :
ip vrf UITS
rd 1:1
route-target both 1:1
exit
interface GigabitEthernet0/1
no sh
ip vrf forwarding UITS
ip address 19.0.0.1 255.255.255.0
exit
router ospf 1000 vrf UITS
network 19.0.0.0 0.0.0.255 area 1
exit

• RD & RT :
- RD = Route Distniguisher = VPN Route Distniguisher = Keep all the prefixes of the
BGP Table
- RT = Route Target = Transfer the routes between VRF and VPN

• Test :
#do show run interface gigabitEthernet 0/1

• CE Configuration :
- Hostname
- Addressing
- Routing : OSPF 1000 area 1

• Redistribution between OSPF 1000 and BGP 1 :


- PE1 & PE2 & PE3 :
router bgp 1
address-family ipv4 vrf UITS
redistribute ospf 1000 vrf UITS
exit
exit
router ospf 1000 vrf UITS
redistribute bgp 1 subnets
exit
do copy run start

• Test :
# do show ip route
# ping CE_B@ / CE_C@
# do show mpls forwarding-table
https://karneliuk.com/2016/11/bgpmpls-ip-vpn-for-ipv4ipv6-in-nokia-alcatel-lucent-
sr-os-and-cisco-ios-xr/fe

You might also like