Distance Vector Routing

You might also like

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 6

1

Aim: Configure a Network using Distance Vector Routing


protocol(STATIC)

Apparatus (Software):packet tracer software


Theory:In computer communication theory relating to packet-
switched networks,a distance-vector routing protocol is one of the
two major classes of routing protocols, theother major class being
the link-state protocol. Distance-vector routing protocols
usethe Bellman–Ford algorithm, Ford–Fulkerson algorithm, or DUAL
FSM (in the case of CiscoSystems’s protocols) to calculate paths. A
distance-vector routing protocol requires that arouter informs its
neighbors of topology changes periodically. Compared to link-
stateprotocols, which require a router to inform all the nodes in a
network of topology changes,distance-vector routing protocols have
less computational complexity andmessage overhead.The Routing
Information Protocol (RIP) is one of the oldest distance-
vector routing protocols, which employs the hop count as a routing
metric. RIP prevents routing loops byimplementing a limit on
the number of hops allowed in a path from the source to
adestination. The maximum number of hops allowed for RIP is 15.
This hop limit, however,also limits the size of networks that RIP
can support. A hop count of 16 is considered aninfinite distance, in
other words the route is considered unreachable.
2

Procedure:
1.Develop a Topology shown in figure given below.
2.Configure all Routers
3.Implement RIP protocols in Router to configure Network

STEPS FOR EXPERIMENT:


3

ROUTER 0 CONFIG:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


ip address 10.10.10.2 255.0.0.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down


Router(config-if)#ip address 60.60.60.1 255.0.0.0
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
4

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#ip route 20.0.0.0 255.0.0.0 60.60.60.2
Router(config)#
Router(config)#interface Serial2/0
Router(config-if)#

ROUTER 1 CONFIG:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


ip address 20.20.20.2 255.0.0.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#ip address 60.60.60.2 255.0.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
clock rate 64000
This command applies only to DCE interfaces
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
5

Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial3/0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up
clock rate 64000
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
ip address 70.70.70.2 255.0.0.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial3/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#
Router(config-if)#exit
Router(config)#ip route 10.0.0.0 255.0.0.0 60.60.60.1
Router(config)#

ROUTER 2 CONFIG:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 30.30.30.2 255.0.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


6

Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#ip address 60.60.60.3 255.0.0.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down


Router(config-if)#clock rate 64000
This command applies only to DCE interfaces
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

OUTPUT:

You might also like