Resumen Cisco Vs Juniper Commands

You might also like

Download as pdf or txt
Download as pdf or txt
You are on page 1of 5

Cisco Commands Juniper Commands

Show Commands & Genernal


ping ping
traceroute traceroute
show clock show system uptime
show environment show chassis environment
show history show cli history
show ip traffic show system statistics
show logging show log
show processes show system processes
show running config show configuration
show tech-support request support information
show users show system users
show version show version
show arp show arp
show interface show interfaces
show ip interface brief show interfaces detail
show ip route show interfaces extensive
show ip route summary show interfaces terse
show route-map show route
show tcp show route summary
show running-configuration show policy
show policy-map interface show system connections
show log show configuration
show ip interfaces show configuration | display set
show ip int brief show class-of-service interface
show policy-map interface show log messages
show ip route summary show interfaces
show ip route show interfaces terse
show tech show interfaces queue
clear counters show route forwarding-table
clear counters Serial0 show route 172.16.0.0/16 detail
clear ip route * clear interface statistics
clear counters clear arp
clear arp-cache clear interfaces statistics all
clear line clear interfaces statistics se-1/0/0
clear ip route request support information
System Administration & General Commands
router> enable user@host% cli
config terminal user@host>
exit exit
show version show version
show process cpu show system processes
dir extensive
show version show system storage
show version, show diag show system uptime
show environment show chassis forwarding
show memory sum show chassis environment
reload show chassis hardware
show ntp associations show chassis
show ntp status routing-engine
show users request system reboot
show protocols show ntp associations
clear line <line nubmer> show ntp status
term length 0 show system alarms
terminal monitor show system users
terminal no monitor show system connetions
terminal length 0 <command>| no-more
# show ip interface brief monitor start messages
# write erase, # reload monitor stop
# copy run start set cli screen-length 0
# show licence > show interface terse
> request system zeroize
# show | compare, #commit
> show system licence
Configuration Commands
enable cli
config terminal configure OR edit
<command> set
no <command> delete
exit up OR exit
shutdown top
no shutdown edit
copy running-configuration OR wr disable
Cntrl + Z OR end activate
do <command> deactivate
load override teminal
commit
rollback
exit OR exit-configuration-mode
run <operational
command>
BGP Commands
show ip bgp show route protocol bgp
show ip bgp community show route community
show ip bgp dampened paths show route damping decayed
show ip bgp neighbors show bgp neighbor
show ip bgp neighbors address show route advertising-protocol bgp address
advertised-routes show route receive-protocol bgp address
show ip bgp neighbors address show bgp group
received-routes show route aspath-regex
show ip bgp peer-group show bgp summary
show ip bgp regexp –
show ip bgp summary clear bgp neighbor
clear ip bgp clear bgp damping
clear ip bgp dampening clear ip bgp neighbor x.x.x.x
clear ip bgp *
OSPF Commands
show ip ospf database show ospf database
show ip ospf interface show ospf interface
show ip ospf neighbor show ospf neighbor
show ip route ospf show route protocol ospf
MPLS Commands
sh mpls ldp bindings(detail) show mpls interface
sh ip rsvp interface show mpls lsp
show mpls lsp ingress(extensive)
show mpls lsp transit(extensive)
show mpls lsp egress(extensive)
show rsvp interface
show route table inet.3
Multicast Commands
show ip mroute show multicast route
show ip pim bsr-router show route table inet.1
show ip igmp groups show pim bootstrap
show ip pim rp show pim join extensive
show ip pim neighbor show pim rps
show pim neighbors
Firewall Filters Commands
sh access-lists show firewall
sh ip interfaces show interfaces filters
clear ip access-list counters clear firewall
Practice Commands
1. Configure Hostname 1. User account
Router>enable [edit]
Router#conf ter edit system login user [user name]
Router(config)#hostname askitmen set uid xxx
askitmen(config)#end2. Configure set class super-user
Secret Password edit authentication
askitmen(config)#enable secret ? set plain-text-password
0 Specifies an UNENCRYPTED password New password; xxxxx
will follow Retype new password; xxxxx
5 Specifies a MD5 HASHED secret will 2. Shutdown interface
follow [edit]
8 Specifies a PBKDF2 HASHED secret set interface ge-0/0/1 disable
will follow delete interface ge-0/0/1 disable
9 Specifies a SCRYPT HASHED secret 3. Aggregated Ethernet
will follow [edit]
LINE The UNENCRYPTED (cleartext) edit chassis aggregated-devices
‘enable’ secret [edit chassis aggregated-devices]
level Set exec level password set ethernet device-count 3
askitmen(config)#enable secret [edit]
itmenpass set interfaces ge-0/0/0 ether-options 802.3ad ae0
askitmen(config)#end3. Configure set interfaces ge-0/0/2 ether-options 802.3ad ae0
Secure Privileges set interfaces ae0 aggregated-ether-options
/* EXAMPLE FOLLOWS */ minimum-links 1
askitmen#config t set interfaces ae0 aggregated-ether-options lacp
askitmen(config)#line vty 0 4 active
askitmen(config-line)#password set interfaces ae0 unit 0 family ethernet-
******** switching port-mode accessset interfaces ge-0/0/0
askitmen(config-line)#login ether-options 802.3ad ae0
askitmen(config-line)#line tty 1 16 set interfaces ge-0/0/2 ether-options 802.3ad ae0
askitmen(config-line)#password set interfaces ae0 aggregated-ether-options
******** minimum-links 1
askitmen(config-line)#login set interfaces ae0 aggregated-ether-options lacp
askitmen(config-line)#line con 0 active
askitmen(config-line)#password set interfaces ae0 unit 0 family ethernet-
******** switching port-mode trunk
askitmen(config-line)#line aux 0 set interfaces ae0 unit 0 family ethernet-
askitmen(config-line)#password switching vlan members [ xx xx xx ]et interfaces
******** ge-0/0/0 ether-options 802.3ad ae0
askitmen(config-line)#login set interfaces ge-0/0/2 ether-options 802.3ad ae0
askitmen(config-line)#enable password set interfaces ae0 aggregated-ether-options
######## minimum-links 1
askitmen(config)#^Z4. Create User and set interfaces ae0 aggregated-ether-options lacp
Assign Privileges active
askitmen#conf ter set interfaces ae0 unit 0 family inet address
askitmen(config)#username askitmen 10.0.0.2/30
privilege ? 4. Trunk port
<0-15> User privilege level [edit interface]
askitmen(config)#username askitmen set ge-0/0/1 unit 0 family ethernet-switching
privilege 7 password itmenpass port-mode trunk
askitmen(config)#username admin set ge-0/0/1 unit 0 family ethernet-switching
privilege ? vlan member [ 2 3 4 ]
<0-15> User privilege leves set ge-0/0/1 unit 0 family ethernet-switching
askitmen(config)#username admin native-vlan-id default
privilege 15 password Admin@123 [edit interface]
run show vlans 2
5. Enable Encryption password 5. Routed VLAN
askitmen#conf ter [edit vlan]
askitmen(config)#service password- set [vlan name] l3-interface vlan.100
encryption [edit interface vlan]
askitmen(config)#end set unit 100 description Example
set unit 100 family inet address 172.16.x.x/16
6. Log commands
6. Configure IP interface on
GigabitEhernet port show log chassid | no-more
show log messages | no-more
askitmen#conf ter
show log messages | last 100
askitmen(config)#interface
show log security | match so-2/0/0
gigabitEthernet ?
show log isis
<0-9> GigabitEthernet interface
number show log bgp.ibgp
askitmen(config)#interface show log user
gigabitEthernet 0/0 7. System commands
askitmen(config-if)#ip address show system uptime
192.168.1.1 255.255.255 show system users
askitmen(config-if)#no shutdown show cli authorization
askitmen(config-if)#end show system storage
show system processes
7. Configure IP interface on Serial show chassis hardware
port show chassis environment
askitmen#conf ter show chassis routing-engine
askitmen(config)#interface serial show chassis craft-interface
0/0/0 show chassis fpc
askitmen(config-if)#ip address show chassis scb
192.168.2.1 255.255.255 show chassis alarms
askitmen(config-if)# clock rate 64000 8. Interface commands
askitmen(config-if)#no shutdown show configuration
askitmen(config-if)#end show configuration | display set
show interface terse | detail
8. Save show interface description
show interface interface-name
askitmen#copy running-configuration
show interface ge-1/0/0 extensive
show interface ge-1/0/0 brief
show interface so-1/0/0 detail
show ehternet-switching interface ge-1/0/0
show vlans [name of vlan] detail
show vlans [name of vlan] extensive
show interface terse | match “ge-0/0/[67]”
clear interfaces statistics so-2/0/0
9. MAC table and ARP
show ethernet-switching table
show ethernet-switching mac-learning-log
10. Spanning Tree
[edit]
set protocols rstp
set protocols rstp bridge-priority 20k
set protocols rstp interface ge-0/0/1.0 disable
set protocols rstp interface ge-0/0/1.0 cost 1000
set protocols rstp interface ge-0/0/1.0 edge
set protocols rstp interface ge-0/0/1.0 mode
point-to-point
[edit]
show protocols stp | display set
show spanning-tree bridge
show spanning-tree interface
show ehternet-switching interface
11. Routing commands
show route x.x.x.x/24
show route terse
show route detail
show route 117.55.254.0 extensive
12. BGP commands
show bgp summary
show bgp group
show bgp neighbor x.x.x.x
show route receive-protocol bgp ‘x.x.x.x’
show route protocol bgp x.x.x.x/24
show route protocol bgp receive-protocol bgp
neighIP
show policy static-bgp
clear bgp neighbor x.x.x.x
clear bgp neighbor as
13. ISIS commands
show isis adjacency
show isis interface
show isis database
14. MPLS commands
show mpls lsp terse
show mpls lsp name DCA-POR detail
15. Security & Policy commands
show firewall | match “ICMP”
show policy static-bgp or ‘policy name’
clear firewall ICMP
16. Ping & Traceroute
ping rapid count 1000 size 1400 x.x.x.x
ping rapid count 1000 size 1400 pattern 0000
198.6.1.1
ping x.x.x.x bypass-routing interface so-1/0/2
count 1000 size 1400 rapid
17. Rename & Replace
Rename : Useful for renaming single elements.
Replace : Useful for changing all references from
one interface to a new interface.=
* If target interface is already configured,
those command won’t work.rename interfaces ge-
0/0/5 to ge-0/0/6
[edit interface ge-0/0/1]
rename unit 0 family inet address 10.10.10.1/24
to address 20.20.20.1/24
replace pattern ge-0/0/3 with ge-0/0/6
18. Copy configuration
* If target interface is already configured,
those command won’t work.
copy interfaces ge-3/0/5 to ge-3/0/6
19. Commit
commit check
commit at “2012-12-22 00:00”
commit confirmed 1
commit and-quit
20. Rollback
[Edit]
rollback or rollback 0
show | compare rollback 4
show | compare

You might also like