Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 5

To assign I P to a Switch

switch(config)# Interface
Vlan 1 switch(config-it)# ip
address <ip> <mask>
switch(config-it)# no
shutdown

To assign Default Gateway to a Switch


Switch (config) #ip default-gateway 192.168.1.100

To change Speed

Switch(config)#int fa0/1
Switch(config-it)#speed ?

To change Duplex
Switch(config-it)#duplex ?

Vlan Creation

Switch(config)# vlan <no>


Switch(config-VIan)# name <name>

Switch(config-VIan)# Exit

Assigning ports in Vlan

Switch(config)# interface <interface type> <interface no.>

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access Vlan <no>

Verification
Switch#sh vlan

Trunking Configuration

Switch(config)# interface <interface type> <interface no.>

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk encapsulation dot1q/ISL


Adding Removing vlan on trunk link
SW-x(config-if)#switchport trunk allowed vlan add 50,60,70,80
SW-1 (config-if)#switchport trunk allowed vlan remove 70,80

Verification

Switch#sh interfaces trunk

To Change Native Vlan


SW1(config-if)#switchport trunk native vlan 999

Troubleshooting Vlan and Trunks


• Same network
• Same vlan
• Trunking ( mode)
• Allowed vlan on the trunk link
• Native vIan must match

lnter-VIan Routing
Methods
A. Separate Physical Gateway on Router
B. Using Sub-interfaces
C. Using Layer 3 Switch

Router on a Stick

R-1(config)#int fa0/0.10
R-1 (config-sub-if)# encapsulation dotlQ 10

R-1 (config-sub-if)# ip add 192.168.1.100 255.255.255.0

Configuring Voice VLAN


Switch(config)# in!f0/3
Switch(config-if)# switchport mode access
Switch(config-if)#switchport voice vlan 50
Switch(config-if)#exit

Configuring VTP

Switch(Config)# VTP domain CCIE


Switch(Config)# Vtp password cisco123
Switch(Config)# Vtp version 2
Switch(Config)# Vtp mode <server/Client/Transparent>
Switch(Config)# Vtp pruning

SW1#sh vtp status


SW1#sh vtp password

server(Config)# Vtp pruning

Verify VTP pruning

switch1 show interface trunk


RacklSWl#show interface fa0/16 pruning

switchport trunk pruning vlan {add vlan-/ist I all I except vlan-list I remove vlan-/ist}

Switch(config-if)#switchport trunk pruning vlan remove 3,10-15

Etherchannel

Switch(config)#interface range f0/21 - 24


Switch(config-if-range)#channel-group 12 mode ?

Configuring EtherChannel Load


Balancing
Switch(config)#port-channel load-balance ?

dst-ip-Load distribution is based on the destination-host IP address.


dst-mac-Load distribution is based on the destination-host MAC address
of the incoming packet. src-dst-ip-Load distribution is based on the
source-and-destination host-IP address.
src-dst-mac-Load distribution is based on the source-and-
destination host-MAC address. src-ip-Load distribution is based on
the source-host IP address.
src-mac-Load distribution is based on the source-MAC address of the incoming packet.

Etherchannel Configuration

SWl(config)#int range f0/20- 23


SW1(config-if-range)#channel-protocol pagp
SWl(config-if-range)#channel-group 10 mode desirable

Verification

SW2#sh etherchannel summary

Configure the PortchannellO interface as Trunk link.


SW1(config)# int port-channellO
SW1(config-if)# switchport trunk encapsulation dotlq
SW1(config-if)# switchport mode trunk

PAP Configuration
-2(config)# username R- I password ciscoI 23

R-2(config)# int sOlO


R-2(config-if) # encapsulation ppp
R-2(config-if) # ppp authentication pap
R-2(config-if) # ppp pap sent-username R-2 password cisco 123
R-2(config-if) # end

CHAP configuration on R1/R2


R!/R2
R-x( config)# int s0/0
R- x(config-if) # encapsulation ppp
R-x(config-if)# ppp authentication chap
R-x(config-if)# exit
R-l{config)# username R-2 password cisco123
R-2(config)# username R-1 password cisco123

LAB: PPP Multilink

R x(c on fig)# int s 0 /0


R x (c o nfig -if)# no ip a d d
R x(c on fig -if)# e nc a p s ula tio n p p p
R x (c o nfig -if)# ppp m u ltilin k
R x (c o nfig -if)# ppp m u ltilin k group 1
R x (c o nfig -if)# no shutd o w n
R x (c o n fig -if)# ex it

Rl(config)# int multilink 1


Rl(config-if)# ppp multilink
R1(config-if)# ppp multilink group 1
R1(config-if)# ip address 10.0.0.2 255.0.0.0

You might also like