Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 16

Project

Computer Communication and Networks


Name of student:E.C

Name of instructor: Ibrahim Cekiri

Task 1: Using the Packet Tracer design the following network topology:
Task 2:Assign to each of the devices(computers, routers etc) an IP address using as default Network IP
address: 192.168.10.0 /24 (Use VLSM for subnetting)

Complete the following table:

Netw Host Bloc Subnet/CIDR Mask Range of IP Broadcast


ork s k addresses
A 3(5) 8 192.168.10.8/29 255.255.255.248 192.168.10.9-.14 192.168.10.1
5
B 3(5) 8 192.168.10.16/29 255.255.255.248 192.168.10.17-.22 192.168.10.2
3
C 3(5) 8 192.168.10.24/29 255.255.255.248 192.168.10.25-.30 192.168.10.3
1
D 2(4) 4 192.168.10.40/30 255.255.255.252 192.168.10.41-.42 192.168.10.4
3
E 2(4) 4 192.168.10.44/30 255.255.255.252 192.168.10.45-.46 192.168.10.4
7
F 5(7) 8 192.168.10.0/29 255.255.255.248 192.168.10.1-.6 192.168.10.7
G 3(5) 8 192.168.10.32/29 255.255.255.248 192.168.10.33-.38 192.168.10.3
9

Place here a screenshot showing the ping test between PC 0 and PC 5

It is saying Destination host unreachable because PC5 and PC0 are not in the same network.

Task 3– Basic configuration of switches and routers

Configure switches and routers per the following requirements:

a. Hostname of the device as shown in the diagram


b. Restrict the access to the privileged mode of switch with hashed password ‘ GoodDay’

c. Restrict the access to the privileged mode of routers with hashed password ‘Life’
d. Protect console connection with a shared password(use your city name as a password)

e. Protect the console and vty terminal lines (for switches and routers)using a local username and
password (set as username your name and as password your surname)

Write down in the Appendix A the commands you’ve used for configuring one of the switches

Task 4- VLAN and trunk configuration

a. Based on the information shown in the figure create VLANs.

Place here a screenshot showing the ping test between PC 0 and PC 5


PC0 and Pc5 still don’t have a connection with each other to communicate.

Place here in the document the screenshots of the output command which briefly shows the VLANs for both
switches.
b. Configure the Routing to VLANs using 802.1Q protocol on routers to make possible the connection
between computers of different VLANs.

Place here a screenshot showing the ping test between PC 0 and PC 5


The still cannot communicate with eachother because they are not in the same physical network, but also their
routers do not know other networks except the local ones.

Write down in the Appendix C the commands you’ve used for configuring one of the routers
Task 5– Configure the routers in order for PCs to have connectivity with each other

Place here a screenshot showing the ping test between PC 0 and PC 5

Write down in the Appendix B the commands you’ve used for configuring the routers

Task6–Configuration of Administrator laptop

Configure the administrator laptop (IP, VLAN etc.) in order that it can access the switchusing telnet and SSH
(configure also the VLAN in the switch).

Configure port security for the interface where the laptop is connected,use restrict violation mode.

Place a screenshot of the show port-security command for the interface you configured
Place a screenshot of the Command Prompt Window showing the laptop accessing the configuration mode of the
switch through telnet and ssh.

telnet
SSH
Write down in the Appendix D the commands you’ve used for configuring switch and router

Note:Save all the configurations of the network as a .pkt file and send it in a zip file.

Appendix A

a.
Router>en
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router1

Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Switch0
b.

Switch0(config)#enable secret GoodDay


Switch0(config)#do copy run start

c.

Router1(config)#enable secret Life


Router1(config)#do copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
Router1(config)#

d.

Router1(config)#line console 0
Router1(config-line)#password Tirana
Router1(config-line)#login
Router1(config-line)#exit
Router1(config)#do copy run start

Switch0(config)#line console 0
Switch0(config-line)#password Tirana
Switch0(config-line)#login
Switch0(config-line)#exit
Switch0(config)#do copy run start
e.

Switch0(config)#line vty 0 4
Switch0(config-line)#login local
Switch0(config-line)#username ervis password ciku

Router1(config)#line vty 0 4
Router1(config-line)#login local
Router1(config-line)#username ervis password ciku

Appendix B

Router1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#router rip
Router1(config-router)#version 2
Router1(config-router)#network 192.168.10.8
Router1(config-router)#network 192.168.10.16
Router1(config-router)#network 192.168.10.24
Router1(config-router)#network 192.168.10.40
Router1(config-router)#

Router2(config)#router rip
Router2(config-router)#version 2
Router2(config-router)#network 192.168.10.40
Router2(config-router)#network 192.168.10.44
Router2(config-router)#exit

Router3(config)#
Router3(config)#router rip
Router3(config-router)#version 2
Router3(config-router)#network 192.168.10.0
Router3(config-router)#network 192.168.10.32
Router3(config-router)#network 192.168.10.44
Router3(config-router)#exit

interface Serial0/0/0
ip address 192.168.10.41 255.255.255.252
!
interface Serial0/0/1
no ip address
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 192.168.10.0
!
ip classless
!
ip flow-export version 9
!
!

Appendix C

Switch0(config)#int fa0/1
Switch0(config-if)#switchport mode trunk

Router1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#int g0/0.99
Router1(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.99, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.99, changed state to up

Router1(config-subif)#encapsulation dot1Q 99
Router1(config-subif)#ip add 192.168.10.9 255.255.255.248
Router1(config-subif)#no shut
Router1(config-subif)#exit
Router1(config)#int g0/0.20
Router1(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.20, changed state to up

Router1(config-subif)#encapsulation dot1Q 20
Router1(config-subif)#ip add 192.168.10.25 255.255.255.248
Router1(config-subif)#no shut
Router1(config-subif)#exit
Router1(config)#int g0/0.30
Router1(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.30, changed state to up

Router1(config-subif)#encapsulation dot1Q 30
Router1(config-subif)#ip add 192.168.10.17 255.255.255.248
Router1(config-subif)#no shut
Router1(config-subif)#exit
Router1(config)#int g0/0
Router1(config-if)#no shut
Router1(config-if)#exit
Router1(config)#do copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
Router1(config)#

Appendix D

Switch0(config)#int vlan 99
Switch0(config-if)#
%LINK-5-CHANGED: Interface Vlan99, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up

Switch0(config-if)#ip add 192.168.10.34 255.255.255.252


Switch0(config-if)#no shut
Switch0(config-if)#exit
Switch0(config)#int fa0/2
Switch0(config-if)#switchport access vlan 99
Switch0(config-if)#exit
Switch0(config)#ip domain-name ervis
Switch0(config)#crypto key generate rsa
The name for the keys will be: Switch0.ervis
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 2048


% Generating 2048 bit RSA keys, keys will be non-exportable...[OK]

*Mar 1 0:15:34.145: %SSH-5-ENABLED: SSH 1.99 has been enabled


Switch0(config)#ip ssh version 2
Switch0(config)#
Switch0(config)#do copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
Switch0(config)#

Switch0(config)#int f0/2
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport port-security
Switch0(config-if)#switchport port-security maximum 1
Switch0(config-if)#switchport port-security violation shutdown
Switch0(config-if)#switchport port-security mac-address 00E0.F9ED.03CB
Switch0(config-if)#switchport port-security mac-address sticky
Switch0(config-if)#ex
Switch0(config)#do copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
Switch0(config)#

You might also like