Download as pdf or txt
Download as pdf or txt
You are on page 1of 28

Huawei openEuler Training Courses

HCIA-openEuler

openEuler System Engineer

Lab Environment Setup Guide

(Server Edition)
Issue: 1.0

Huawei Technologies Co., Ltd.

1
Copyright © Huawei Technologies Co., Ltd. 2022. All rights reserved.
No part of this document may be reproduced or transferred in any form or by any
means without prior written consent of Huawei Technologies Co., Ltd.

Trademarks and Permissions

and other Huawei trademarks are trademarks of Huawei Technologies Co., Ltd.
All other trademarks and trade names mentioned in this document are the property of
their respective holders.

Notice
The purchased products, services, and features are stipulated by the commercial
contract made between Huawei and the customer. All or partial products, services, and
features described in this document may not be within the purchased scope or the
usage scope. Unless otherwise specified in the contract, all statements, information,
and recommendations in this document are provided "AS IS" without warranties,
guarantees or representations of any kind, either express or implied.
The information in this document is subject to change without notice. Every effort has
been made in the preparation of this document to ensure accuracy of the contents, but
all statements, information, and recommendations in this document do not constitute
a warranty of any kind, express or implied.

Huawei Technologies Co., Ltd.

Huawei Industrial Base


Bantian, Longgang
Address:
Shenzhen 518129
People's Republic of China

Website: https://e.huawei.com/en/

Huawei Proprietary and Confidential


Copyright © Huawei Technologies Co., Ltd
HCIA-openEuler Lab Environment Setup Guide Page 1

Huawei Certification System


The Huawei certification system is a platform for shared growth, part of a thriving
partner ecosystem. There are two types of certification: one for ICT architectures and
applications, and one for cloud services and platforms. There are three levels of
certification available:
Huawei Certified ICT Associate (HCIA)
Huawei Certified ICT Professional (HCIP)
Huawei Certified ICT Expert (HCIE)
Huawei certification courses cover the entire ICT domain, with a focus on how today's
architecture generates cloud-pipe-device synergy. The courses present the latest
developments of all essential ICT aspects to foster a thriving ICT talent ecosystem for
the digital age.
HCIA-openEuler is intended for frontline engineers at Huawei regional or representative
offices, as well as other personnel who want to expand their knowledge of Linux
technologies. The HCIA-openEuler certification includes the introduction to the
openEuler OS, software installation, and basic operations, file processing and text
editing, user and permission management, logical volume management, and other
techniques and best practices aimed at getting the most out of openEuler.
Those who pass this certification will be able to install and use openEuler, as well as
apply cutting-edge Linux knowledge.
HCIA-openEuler Lab Environment Setup Guide Page 2
HCIA-openEuler Lab Environment Setup Guide Page 3

About This Document

Overview
This document relates to the HCIA-openEuler certification. It is intended for those
preparing for that certification or as well as those who wish to expand their knowledge
of openEuler.

About the Exercises


This document consists of ten exercises:
⚫ Exercise 1: openEuler OS installation
⚫ Exercise 2: basic openEuler CLI operations
⚫ Exercise 3: openEuler text processing
⚫ Exercise 4: openEuler text editor
⚫ Exercise 5: openEuler user and permission management
⚫ Exercise 6: openEuler software management
⚫ Exercise 7: openEuler storage and file system management
⚫ Exercise 8: openEuler system and process management
⚫ Exercise 9: shell script language basics
⚫ Exercise 10: openEuler comprehensive practices

Required Knowledge
To better understand this certification course, you should be familiar with:
⚫ Computer operation and hardware

Lab Environment Overview


Networking Description
This lab environment is intended for Linux system engineers who are preparing for the
HCIA-openEuler certification. Each lab environment includes one TaiShan server and can
accommodate 10 to 20 trainees doing hands-on practice as the same time.

Device Introduction
To meet the HCIA-openEuler lab requirements, it is recommended to use the following
configurations in each lab environment.
HCIA-openEuler Lab Environment Setup Guide Page 4

The table below describes the mapping between devices, models, and versions.

Device Model Configuration

Switch CE5880 /

2 x 48 Kunpeng 920 | 16 x 32 GB RAM | 2


Server TaiShan 200 (model 2280)
x 960 GB SSD + 6 x 2 TB SAS

Software Required for the Exercises


Software Download URL

FusionCompute_CNA-8.0-
ARM_64.iso https://support.huawei.com/enterprise/en/cloud-
computing/fusioncompute-pid-
FusionCompute_VRM-8.0.0-
8576912/software/250482697?idAbsPath=fixnode01%7
ARM_64.zip
C22658044%7C7919788%7C9856606%7C21462752%7
FusionCompute_Installer- C8576912
8.0.0.zip

openEuler-20.03-LTS- https://repo.openeuler.org/openEuler-20.03-
aarch64-dvd.iso LTS/ISO/aarch64/openEuler-20.03-LTS-aarch64-dvd.iso

https://repo.openeuler.org/openEuler-20.03-
openEuler-20.03-LTS-
LTS/ISO/aarch64/openEuler-20.03-LTS-everything-
everything-aarch64-dvd.iso
aarch64-dvd.iso

https://hcia-openeuler.obs.cn-north-
libzip-1.2.0.tar.gz
4.myhuaweicloud.com/v1.0/libzip-1.2.0.tar.gz

https://hcia-openeuler.obs.cn-north-
zip-1.19.0.tgz
4.myhuaweicloud.com/v1.0/zip-1.19.0.tgz

https://hcia-openeuler.obs.cn-north-
nextcloud-18.0.4.tar.bz2
4.myhuaweicloud.com/v1.0/nextcloud-18.0.4.tar.bz2
HCIA-openEuler Lab Environment Setup Guide Page 5

Contents

About This Document ............................................................................................................ 3


Overview ...........................................................................................................................................................................................................3
About the Exercises .....................................................................................................................................................................................3
Required Knowledge ...................................................................................................................................................................................3
Lab Environment Overview .....................................................................................................................................................................3
1 Setting Up the Lab Environment ...................................................................................... 6
1.1 Lab Environment ...................................................................................................................................................................................6
1.1.1 Environment Overview ...................................................................................................................................................................6
1.1.2 Networking Diagram ......................................................................................................................................................................6
1.2 Configuring Switches ..........................................................................................................................................................................7
1.2.1 Configuration Description.............................................................................................................................................................7
1.3 Configuring the Server BMC ...........................................................................................................................................................7
1.4 Installing CNAs.......................................................................................................................................................................................8
1.5 Installing FusionCompute .............................................................................................................................................................. 12
2 Configuring Switches ........................................................................................................ 19
2.1 Configuration Description ............................................................................................................................................................. 19
3 Cleaning Up the Environment ......................................................................................... 26
3.1 Cleanup Description ......................................................................................................................................................................... 26
HCIA-openEuler Lab Environment Setup Guide Page 6

1 Setting Up the Lab Environment

1.1 Lab Environment


1.1.1 Environment Overview
In the lab environment, FusionCompute is used to provide the VMs for practice, and
FusionStorage 8.0, which must be configured with a license, is used to provide shared
storage resources. Both FusionCompute and FusionStorage are deployed in hybrid mode.
Five TaiShan 200 servers (model 2280E) are deployed as basic resource servers to meet
the requirements of more than 50 trainees practicing at the same time.

1.1.2 Networking Diagram

Figure 1-1 HCIA-openEuler lab networking diagram


HCIA-openEuler Lab Environment Setup Guide Page 7

1.2 Configuring Switches


1.2.1 Configuration Description
⚫ VLAN 2 is the VLAN of the server BMC, and its gateway address is 192.168.2.254.
⚫ VLAN 100 is the VLAN of the platform management plane, and its gateway address
is 192.168.100.254.
⚫ VLAN 110 is the DHCP configuration VLAN and can be used for automatic network
configuration of VMs. Its gateway address is 192.168.110.254.
⚫ VLAN 101 is the VLAN of the storage network plane and does not require a gateway.
⚫ Configure other VLANs according to your specific requirements.
⚫ Configure the DHCP service on the switch for VLAN 110.

1.3 Configuring the Server BMC


Step 1 Unpack and install the server, power it on, and use a network cable to connect the
PC to its Mgmt port. The default IP address of the Mgmt port on the server is
192.168.2.100/24. You need to configure the IP address of the PC so that the PC
can communicate with the server.

Step 2 Open a browser, enter 192.168.2.100 in the address box, and press Enter. The
BMC login page is displayed. Enter the default username Administrator and
password Admin@9000 to log in to the system.

Step 3 After logging in to the system, choose iBMC Settings > Network Protocols. The
Network Protocols page is displayed.
HCIA-openEuler Lab Environment Setup Guide Page 8

Step 4 On the Network Protocols page, configure the iBMC network, configure the iBMC
IP address of the server as planned, and click Save.

Step 5 Choose User & Security > Local Users. The Local Users page is displayed.

Step 6 On the Local Users page, click Edit next to Administrator. The user information
configuration page is displayed. Change the password of the Administrator user
as planned and save the change.

Step 7 Repeat Steps 1 through 6 to configure iBMC for the other servers.

1.4 Installing CNAs


Step 1 Open the iBMC management page of a server using a browser. On the home
page, choose Virtual Console > Start > HTML5 Integrated Remote Console
(Exclusive). A new tab page should be displayed. If it is not, check whether the
browser has blocked the pop-up windows.
HCIA-openEuler Lab Environment Setup Guide Page 9

Step 2 On the remote console, click and set Boot Device to CD/DVD.

Step 3 Click , select the downloaded FusionCompute_CNA-8.0.0-ARM_64.iso image


file, and click Connect to mount the DVD-ROM drive file to the virtual DVD-ROM
drive on the server.

Step 4 Click and choose Forced Restart to restart the server.

Step 5 After the server is restarted, the Computing Node Agent (CNA) installation and
configuration page is displayed.

Step 6 To configure the CNA network, m ove the cursor to Network and press Enter.
HCIA-openEuler Lab Environment Setup Guide Page 10

Step 7 Select IPv4 and press Enter.

Step 8 Select the planned network interface card (NIC) and press Enter. On the NIC IP
address configuration page, configure CNA01's IP address as shown in the
following figure. Move the cursor to OK and press Enter.

Step 9 Set the default gateway address, move the cursor to OK, and press Enter.
HCIA-openEuler Lab Environment Setup Guide Page 11

Step 10 Move the cursor to OK and press Enter to complete the network configuration.

Step 11 Move the cursor to Hostname, press Enter, enter the host name CNA01, move
the cursor to OK, and then press Enter.

Step 12 Move the cursor to Password and press Enter. Enter the password for the root
user to log in to the CNA. Move the cursor to OK and press Enter.
HCIA-openEuler Lab Environment Setup Guide Page 12

Step 13 Move the cursor to OK and press Enter. Select yes twice to go to the CNA
installation page.

Step 14 After the installation progress reaches 100%, wait for the system to automatically
restart.

Step 15 Repeat Steps 6 through 14 to install the CNA for the other servers.

1.5 Installing FusionCompute


Step 1 Start the FusionComputeInstaller.exe installation tool, set Language to English,
select VRM under Components, and set IP Protocol to IPV4. Confirm the
information and click Next.
HCIA-openEuler Lab Environment Setup Guide Page 13

Step 2 Select Custom Mode and click Next.

Step 3 Click Browse and select the installation package.


HCIA-openEuler Lab Environment Setup Guide Page 14

Step 4 In the displayed dialog box, select the directory where FusionCompute
6.5.0_VRM.zip is located, and click OK.

Note: The path cannot contain Chinese characters.

Step 5 Click Verify to check VRM integrity. After the check is complete, click Next.
HCIA-openEuler Lab Environment Setup Guide Page 15

Step 6 Click Next to go to the VRM parameter configuration page. Set the VRM parameters
as shown in the following figure. Click Next after the configuration is complete.

Step 7 Enter CNA01 host information, and click Configure Host.

(This step takes about 5 to 10 minutes.)


HCIA-openEuler Lab Environment Setup Guide Page 16

Step 8 After host configuration is complete, click Next to go to the datastore configuration
page. Click Refresh StorageUnit. After datastore information is refreshed, click
Next.

(CNA host drive space cannot be less than 140 GB, or the datastores cannot be
discovered.)

Step 9 Select Common mode (recommended) and click Next.

Step 10 Click Install VRM.


HCIA-openEuler Lab Environment Setup Guide Page 17

Step 11 After installation completes, click Next to view the FusionCompute login information.
Click Finish. After the data is cleared, click OK to exit the FusionCompute
installation tool.
HCIA-openEuler Lab Environment Setup Guide Page 18

Step 12 Open your browser, enter the FusionCompute login address in the address box, and
press Enter. In the displayed dialog box, click OK to accept the license agreement.
Enter the username admin and the default password IaaS@PORTAL-CLOUD8!
Then, click Log In. When the system prompts you to change the password, change
the admin user's password to Huawei@1234. After the password is changed, the
FusionCompute page is displayed.

(At this point, no license is yet loaded into the system. The free trial will expire in 90
days.)
HCIA-openEuler Lab Environment Setup Guide Page 19

2 Configuring Switches

2.1 Configuration Description


To connect to the switch, two network ports need to be configured on the server.

Step 1 Connect the first network port of the server to the switch and configure VLAN
100. The other network port does not need a VLAN to be configured.

sysname B5-02-BMC
#
device board 1 board-type CE5880-48T6Q-EI
#
drop-profile default
#
vlan batch 2 to 4094
#
telnet ipv6 server disable
#
diffserv domain default
#
aaa
local-user huawei password irreversible-cipher Admin123!
local-user huawei service-type telnet
local-user huawei level 3
#
authentication-scheme default
#
authorization-scheme default
#
accounting-scheme default
#
domain default
#
domain default_admin
#
stack
#
license
#
interface Vlanif2
ip address 192.168.2.254 255.255.255.0
#
interface Vlanif100
ip address 192.168.100.254 255.255.255.0
#
HCIA-openEuler Lab Environment Setup Guide Page 20

interface Vlanif101
ip address 192.168.101.254 255.255.255.0
#
interface Vlanif102
ip address 192.168.102.254 255.255.255.0
#
interface Vlanif103
ip address 192.168.103.254 255.255.255.0
#
interface Vlanif104
ip address 192.168.104.254 255.255.255.0
#
interface Vlanif105
ip address 192.168.105.254 255.255.255.0
#
interface Vlanif106
ip address 192.168.106.254 255.255.255.0
#
interface Vlanif107
ip address 192.168.107.254 255.255.255.0
#
interface Vlanif108
ip address 192.168.108.254 255.255.255.0
#
interface Vlanif109
ip address 192.168.109.254 255.255.255.0
#
interface Vlanif110
ip address 192.168.110.254 255.255.255.0
#
interface Vlanif111
ip address 192.168.111.254 255.255.255.0
#
interface Vlanif112
ip address 192.168.112.254 255.255.255.0
#
interface Vlanif113
ip address 192.168.113.254 255.255.255.0
#
interface Vlanif114
ip address 192.168.114.254 255.255.255.0
#
interface Vlanif115
ip address 192.168.115.254 255.255.255.0
#
interface Vlanif116
ip address 192.168.116.254 255.255.255.0
#
interface Vlanif117
ip address 192.168.117.254 255.255.255.0
#
interface Vlanif118
ip address 192.168.118.254 255.255.255.0
#
interface Vlanif119
HCIA-openEuler Lab Environment Setup Guide Page 21

ip address 192.168.119.254 255.255.255.0


#
interface Vlanif120
ip address 192.168.120.254 255.255.255.0
#
interface Vlanif171
ip address 192.168.171.254 255.255.255.0
#
interface MEth0/0/0
#
interface Eth-Trunk1
port default vlan 171
#
interface GE1/0/1
port default vlan 2
#
interface GE1/0/2
port default vlan 2
#
interface GE1/0/3
port default vlan 2
#
interface GE1/0/4
port default vlan 2
#
interface GE1/0/5
port default vlan 2
#
interface GE1/0/6
port default vlan 2
#
interface GE1/0/7
port default vlan 2
#
interface GE1/0/8
port default vlan 2
#
interface GE1/0/9
port default vlan 2
#
interface GE1/0/10
port default vlan 2
#
interface GE1/0/11
#
interface GE1/0/12
#
interface GE1/0/13
#
interface GE1/0/14
#
interface GE1/0/15
#
interface GE1/0/16
#
HCIA-openEuler Lab Environment Setup Guide Page 22

interface GE1/0/17
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/18
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/19
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/20
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/21
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/22
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/23
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/24
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/25
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/26
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/27
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
HCIA-openEuler Lab Environment Setup Guide Page 23

interface GE1/0/28
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/29
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/30
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/31
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/32
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/33
port link-type trunk
port trunk pvid vlan 110
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/34
port link-type trunk
port trunk pvid vlan 110
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/35
port link-type trunk
port trunk pvid vlan 110
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/36
port link-type trunk
port trunk pvid vlan 110
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/37
port link-type trunk
port trunk pvid vlan 110
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/38
port link-type trunk
port trunk pvid vlan 110
port trunk allow-pass vlan 2 to 4094
#
HCIA-openEuler Lab Environment Setup Guide Page 24

interface GE1/0/39
port link-type trunk
port trunk pvid vlan 110
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/40
port link-type trunk
port trunk pvid vlan 110
port trunk allow-pass vlan 2 to 4094
#
interface GE1/0/41
#
interface GE1/0/42
#
interface GE1/0/43
#
interface GE1/0/44
eth-trunk 1
#
interface 10GE1/0/1
#
interface 10GE1/0/2
#
interface 10GE1/0/3
#
interface 10GE1/0/4
#
interface 40GE1/0/1
#
interface 40GE1/0/2
#
interface 40GE1/0/3
#
interface 40GE1/0/4
#
interface 40GE1/0/5
#
interface 40GE1/0/6
#
interface NULL0
#
lldp enable
#
ssh authorization-type default aaa
#
ssh server cipher aes256_ctr aes128_ctr
ssh server hmac sha2_256_96 sha2_256 sha1_96
ssh server key-exchange dh_group_exchange_sha256 dh_group_exchange_sha1 ecdh_sha2_nistp256
ecdh_sha2_nistp384 ecdh_sha2_nistp521 sm2_kep
#
ssh server dh-exchange min-len 2048
#
ssh client cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc
3des_cbc
#
HCIA-openEuler Lab Environment Setup Guide Page 25

user-interface maximum-vty 15
#
user-interface con 0
#
user-interface vty 0 14
authentication-mode aaa
protocol inbound telnet
#
Return
HCIA-openEuler Lab Environment Setup Guide Page 26

3 Cleaning Up the Environment

3.1 Cleanup Description


Step 1 Delete all VMs except exam VMs.

You might also like