Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 2

Step 1: Configure Access And VTY(Telnet) Passwords

Config t

enable secret Cisco123

line vty 0 4
password Cisco123
login

Step 2: Configure A Router Hostname

hostname Router1

Step 3: Configure IP Addresses For Router Interfaces

interface GigabitEthernet 0/0


ip address 100.100.100.1 255.255.255.252
no shutdown
exit

interface GigabitEthernet 0/1


ip address 192.168.10.1 255.255.255.0
no shutdown
exit

Step 4: Confiugre Static Or Dynamic Routing

(Destination) (Subnet) (Gateway)


ip route 200.200.200.0 255.255.255.0 100.100.100.2

Step 5: Save The Config

exit
copy running-config startup-config

how running-config

*OPTIONAL*

Configure NAT
(Only If Your Router Acts As Internet Border Gateway)

config t
interface GigabitEthernet 0/0
ip nat outside
exit

interface GigabitEthernet 0/1


ip nat inside
exit

access-list 1 permit 192.168.10.0 0.0.0.255


ip nat inside source list 1 interface GigabitEthernet 0/0 overload

CONFIGURE DHCP
(A Cisco Router Can Be Configured As A DCHP Server To Dynamically Assign IP
Adresses To Internal Hosts)

ip dhcp pool lan-pool


network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8

(Use This To Exlude ertain Ip Addresses That You Dont Want The Router To Assign)
ip dhcp excluded-address 192.168.10.1 192.168.10.50

You might also like