+RIP Config - v3

You might also like

Download as pdf or txt
Download as pdf or txt
You are on page 1of 4

CONFIGURE DYNAMIC ROUTES (!!!

(!!! Before configuration make sure all necessary interfaces are “up” and “up” with: R1#show ip interface brief )
R2(config)#router ? (Shows routing protocols)

R2(config)#router rip (RIP Message format: Dest. add: FF-FF-FF-FF-FF-FF, //Dest. IP: 255.255.255.255, protocol field 17 for UDP; 01-ICMP,
06-TCP; // UDP segment source and dest. Ports: 520 // RIP Message: 512 bytes, up to 25 entries, Maximum path: 4 equal-
cost load balancing, AD: 120, Metric: max Hop Count 15 (Bellman-Ford or Ford-Fulkerson algorithm), each 30sec.,
advertising classful address without sbn.mask, timers… = version 1, 2)

Stub, Edge R2

R2#show ip interface brief


R2#debug ip rip (or no debug ip rip, or undebug all) Boundary router (R2) – sits on the edge of two discontiguous
R2(config)#ip classless (or no ..., router behavior type - forwarding packets classful networks or routing protocol networks
also to the best supernet route or default route)
R2(config)#router rip (no router rip – to disable RIP) RIP:
R2(config-router)# ? UDP (17) port 520, Broadcasting 255.255.255.255,
R2(config-router)#network 172.30.0.0 (all nets on R1, classful address only!) AD-120 or change it by command distance, metric-HopCount,
R2(config-router)#network x.x.x.x (or no network x.x.x.x) 30sec.-updates, 25-entries, 16-ivalid route, 4-equal-cost routes,
R2(config-router)#distance (by default AD = 120) updade = classful networks only
R2(config-router)#timers (adjust routing timers) Does not support discontiguous subnets, VLSM, or CIDR
R2(config-router)#neighbor 172.30.2.1 (next hop - a specific neighbor with supernet routes
which to exchange info)
R2(config-router)#passive-interface fa 0/0 (int. receives RIP upds only) Automatic network summarization = classful network boundary
R2(config-router)#default-information originate (propagating a default static route in Automatic ip classless is on from IOS 11.3 by default
RIP upds) Aut. ip split horizon rule is on – for forwarding RIP updates
R2(config-router)#redistribute static (static route configured & redistributed
by RIP upds, or others routing protocols) RIPv2:
R2(config-router)#maximum paths 6 (Equal-Cost-Load-Balancing up to 6 routes, Multicasting 224.0.0.9 - Group of RIPv2 routers,
by default 4-equal-cost routes) Update = classless networks + subnet masks
R2(config-router)#end No auto-summary command should be issued
R2#copy running-config startup-config (Save changes into config file into NVRAM)

--------------------------------------------------------------------------------------------------------------------

SUMMARY RIP v2:

R1(config)#ip classless (Classless routing behavior is by default from IOS 11.3 = type of lookup process in routing table)
R1(config)#router rip
R1(config-router)#?
R1(config-router)#version 2 (supports VLSM + CIDR; RIP updates are with IP+SnM)
R1(config-router)#no auto-summary (RIPv2 summarizes networks at the classful boundary by default)
R1(config-router)#network 192.168.1.0 (all nets on R1, classful address only!)
R1(config-router)#network 192.168.2.0
R1(config-router)#neighbor 192.168.2.2 (a specific neighbor with which to exchange routing info)

R1(config-router)#passive-interface default (turn-down all interfaces on R1 into passive state = receive RIP upds only)
R1(config-router)#no passive-interface s0/0/0 (turn-on sending RIP upds through s0/0/0)
R1(config-router)#passive-interface gi0/0 (interface only receives RIP upds)

R1(config-router)#default-information originate (propagate default static 0.0.0.0 route in RIP upds) = Gateway of last resort is 0.0.0.0 to network 0.0.0.0 in RT)
R1(config-router)#redistribute static (Redistribute information from another routing protocol, or static route configured and redistributed by RIP upds)
R1(config-router)#ip summary-address rip <supernet> <supernet mask> (allowing RIPv2 supernet summarization of networks – CIDR)
R1(config-router)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 s0/0/1 209.165.200.226 (Fully specified default static route)
R2#show ip route

1
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
R1(config)#key chain RIP_KEY (názov krúžku pre kľúče)
R1(config-keychain)#key 1 (poradie kľúčov)
R1(config-keychain-key)#key-string cisco (reťazec – zúbkovanie na kľúči)

R1(config)#interface s0/0/0
R1(config-if)#ip rip authentication mode md5
R1(config-if)#ip rip authentication key-chain RIP_KEY
R1(config-if)#end

R1#write memory (Save changes into config file into NVRAM)


R1#copy running-config startup-config (Save changes into config file into NVRAM)

R1#show ip route (displays Routing table – AD, Metrics, ID networks...)


R1#clear ip route* (to force the routers to rebuild their routing tables)
R1#show ip route rip
R1#show ip rip database (displays Topology table – ...)
R1#show ip protocols (displays complet info about RIP… all RIP neighbours, timers of updates of Routing Protocols)

R1#show ip traffic [….] (info about number and type of packets sent and received)
R1#debug ip rip

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

ISP - 2001:DB8:FEED:1::1/64

Stub R1
R1 - S0/0/1

2
SUMMARY RIPng for IPv6:

R1(config)#ip unicast-routing (To enable an IPv6 router to forward IPv6 packets)


R1(config)# ipv6 route 0::/0 s0/0/1 2001:DB8:FEED:1::1 (A fully specified default static route)

R1(config)# ipv6 router rip RIP-AS (RIP-AS = process-name or domain-name)


R1(config-rtr)#? Where is a passive interface???

R1(config)#interface g0/0
R1(config-if)#ipv6 rip RIP-AS enable (RIP-AS = process-name or domain-name; there is no network commands in RIPng)
R1(config-if)#no shutdown

R1(config)#interface s0/0/0
R1(config-if)#ipv6 rip RIP-AS enable
R1(config-if)#ipv6 rip RIP-AS default-information originate (to propagate the default static route in RIPng updates sent out of the configured interface)
R1(config-if)#no shutdown

R1#show ipv6 route (displays Routing table – AD, Metrics, ID networks...)


R1#clear ipv6 route* (to force the routers to rebuild their routing tables)
R1#show ipv6 route rip (to see only RIP updates in RTable)

R1#show ipv6 rip RIP-AS


R1#show ipv6 protocols (displays complet info about RIP… all RIP neighbours, timers of updates of Routing Protocols)

3
4

You might also like