Download as pdf or txt
Download as pdf or txt
You are on page 1of 11

2018

Advanced OSPF
lab2 for
CCNP Students
By
Eng. Abeer Hosni
OSPF Lab2:

The Frame Relay Configuration:

R1(config)#int s1/0
R1(config-if)#ip address 172.12.123.1 255.255.255.0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
R1(config-if)#frame-relay map ip 172.12.123.2 102 broadcast
R1(config-if)#frame-relay map ip 172.12.123.3 103 broadcast
R1(config-if)#no shutdown
R1(config-if)#int loop 1
R1(config-if)#ip address 1.1.1.1 255.255.255.255

R2(config)#int s1/0
R2(config-if)#ip address 172.12.123.2 255.255.255.0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no frame-relay inverse-arp
R2(config-if)#frame-relay map ip 172.12.123.1 201
R2(config-if)#frame-relay map ip 172.12.123.3 201
R2(config-if)#no shutdown
R2(config-if)#int loop 2
R2(config-if)#ip address 2.2.2.2 255.255.255.255

R3(config)#int s1/0
R3(config-if)#ip address 172.12.123.3 255.255.255.0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no frame-relay inverse-arp
R3(config-if)#frame-relay map ip 172.12.123.1 301
R3(config-if)#frame-relay map ip 172.12.123.2 301
R3(config-if)#no shutdown
R3(config-if)#int loop 3
R3(config-if)#ip address 3.3.3.3 255.255.255.255

The frame cloud should be pingable now.

To run OSPF:

R1(config)#router ospf 1
R1(config-router)#network 172.12.123.1 0.0.0.0 area 0
R1(config-router)#network 1.1.1.1 0.0.0.0 area 1

R2(config)#router ospf 1
R2(config-router)#network 172.12.123.2 0.0.0.0 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 2

R3(config)#router ospf 1
R3(config-router)#network 172.12.123.3 0.0.0.0 area 0
R3(config-router)#network 3.3.3.3 0.0.0.0 area 3

But the adjacency doesn't come up, so we will have to build the neighbor relationship manually:

R1(config)#router ospf 1
R1(config-router)#neighbor 172.12.123.2
R1(config-router)#neighbor 172.12.123.3
*Mar 1 00:26:19.895: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/0 from
LOADING to FULL, Loading Done
*Mar 1 00:26:20.283: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/0 from
LOADING to FULL, Loading Done

R1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface


2.2.2.2 1 FULL/DROTHER 00:01:48 172.12.123.2 Serial1/0
3.3.3.3 1 FULL/DR 00:01:58 172.12.123.3 Serial1/0
Notice that R3 has become the DR router as it has the highest RID, so we will have to
change that to be sure that the hub router R1 is the DR and there is no BDR in the network.

R2(config)#int s1/0
R2(config-if)#ip ospf priority 0
R3(config)#int s1/0
R3(config-if)#ip ospf priority 0

R1#show ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/DROTHER 00:01:55 172.12.123.2 Serial1/0
3.3.3.3 0 FULL/DROTHER 00:01:35 172.12.123.3 Serial1/0

R1#show ip ospf int s1/0


Serial1/0 is up, line protocol is up
Internet Address 172.12.123.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost:
64 Transmit Delay is 1 sec, State DR, Priority 255
Designated Router (ID) 1.1.1.1, Interface address 172.12.123.1
No backup designated router on this network
Old designated Router (ID) 3.3.3.3, Interface address 172.12.123.3
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:03
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 2.2.2.2
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)

R2#show ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 255 FULL/DR 00:01:31 172.12.123.1 Serial1/0

R3#show ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 255 FULL/DR 00:01:49 172.12.123.1 Serial1/0

R1#show ip route ospf


<Output omitted>
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 172.12.123.2, 00:05:22, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/65] via 172.12.123.3, 00:10:07, Serial1/0

R2#show ip route ospf


<Output omitted>
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/65] via 172.12.123.1, 00:05:48, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/65] via 172.12.123.3, 00:05:48, Serial1/0

R3#show ip route ospf


<Output omitted>
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/65] via 172.12.123.1, 00:11:02, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 172.12.123.2, 00:06:18, Serial1/0

And the network is pingable now:

R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/88/244 ms

Point-to-point configurations:
R1(config)#in s1/1
R1(config-if)#ip address 172.12.13.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#router ospf 1
R1(config-router)#network 172.12.13.1 0.0.0.0 area 13

R3(config)#int s0/1
R3(config-if)#ip address 172.12.13.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#router ospf 1
R3(config-router)#network 172.12.13.2 0.0.0.0 area 13

R1#show ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/DROTHER 00:01:47 172.12.123.2 Serial1/0
3.3.3.3 0 FULL/DROTHER 00:01:47 172.12.123.3 Serial1/0
3.3.3.3 0 FULL/ - 00:00:31 172.12.13.2 Serial1/1

Notice that R1 can see his neighbor R3 two times, one using the frame relay cloud and the other
using the point to point interface. And there is no mention for the DR or BDR routers.

R1#show ip ospf int s1/1


Serial1/1 is up, line protocol is up
Internet Address 172.12.13.1/24, Area 13

Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost:


64 Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)

The Ethernet segment between R3 and R4 configurations (The virtual link


configurations):

R3(config)#int f0/0
R3(config-if)#ip address 172.12.34.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#router ospf 1
R3(config-router)#network 172.12.34.3 0.0.0.0 area 34

R4(config)#int f0/0
R4(config-if)#ip address 172.12.34.4 255.255.255.0
R4(config-if)#no shutdown
R4(config)#int loop 4
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#router ospf 1
R4(config-router)#network 172.12.34.4 0.0.0.0 area 34
R4(config-router)#network 4.4.4.4 0.0.0.0 area 4

R3#show ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 255 FULL/DR 00:01:35 172.12.123.1 Serial1/0
1.1.1.1 0 FULL/ - 00:00:35 172.12.13.1 Serial1/1
4.4.4.4 1 FULL/BDR 00:00:36 172.12.34.4 FastEthernet0/0
But R3 cannot see the network 4.4.4.4 in the routing table:

R3#show ip route ospf


<Output omitted>
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/65] via 172.12.123.1, 00:23:20, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 172.12.123.2, 00:23:20, Serial1/0

So we will convert area 34 to a transit area:

R3(config-router)#area 34 virtual-link 4.4.4.4


R4(config-router)#area 34 virtual-link 3.3.3.3
Notice that the configuration is done using the RID not the router IP.

R3#show ip route ospf


<Output omitted>
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/65] via 172.12.123.1, 00:26:55, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 172.12.123.2, 00:26:55, Serial1/0
4.0.0.0/32 is subnetted, 1 subnets
O IA 4.4.4.4 [110/11] via 172.12.34.4, 00:00:39, FastEthernet0/0

R1#show ip route ospf


<Output omitted>
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 172.12.123.2, 00:27:35, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/65] via 172.12.123.3, 00:27:35, Serial1/0
4.0.0.0/32 is subnetted, 1 subnets
O IA 4.4.4.4 [110/75] via 172.12.123.3, 00:01:13, Serial1/0
172.12.0.0/24 is subnetted, 3 subnets
O IA 172.12.34.0 [110/74] via 172.12.123.3, 00:12:18, Serial1/0

R1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/88/164 ms

R3#show ip ospf virtual-links


Virtual Link OSPF_VL0 to router 4.4.4.4 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 34, via interface FastEthernet0/0, Cost of using
10 Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:05
Adjacency State FULL (Hello suppressed)
Index 2/4, retransmission queue length 0, number of retransmission
0 First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec

R4#show ip ospf virtual-links


Virtual Link OSPF_VL0 to router 3.3.3.3 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 34, via interface FastEthernet0/0, Cost of using
10 Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:03
Adjacency State FULL (Hello suppressed)
Index 1/2, retransmission queue length 0, number of retransmission 0
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec

The Ethernet segment configurations between r1 and R5:

R1(config)#int f0/0
R1(config-if)#ip address 15.0.0.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 15.0.0.0

R5(config)#int f0/0
R5(config-if)#ip address 15.0.0.5 255.255.255.0
R5(config-if)#no shutdown
R5(config)#int loop 5
R5(config-if)#ip address 5.1.1.1 255.255.255.0
R5(config-if)#int loop 6
R5(config-if)#ip address 6.1.1.1 255.255.255.0
R5(config-if)#int loop 7
R5(config-if)#ip address 7.1.1.1 255.255.255.0
R5(config-if)#router rip
R5(config-router)#version 2
R5(config-router)#no auto-summary
R5(config-router)#network 15.0.0.0
R5(config-router)#network 5.0.0.0
R5(config-router)#network 6.0.0.0
R5(config-router)#network 7.0.0.0

We will run redistribution so that the RIP network can see the OSPF network and vice versa.

R1(config)#router ospf 1
R1(config-router)#redistribute rip subnets
R1(config)#router rip.
R1(config-router)#redistribute ospf 1 metric 2

R5#show ip route
<Output omitted>
1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/2] via 15.0.0.1, 00:00:00, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/2] via 15.0.0.1, 00:00:00, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/2] via 15.0.0.1, 00:00:00, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
R 4.4.4.4 [120/2] via 15.0.0.1, 00:00:00, FastEthernet0/0
5.0.0.0/24 is subnetted, 1 subnets
C 5.1.1.0 is directly connected, Loopback5
6.0.0.0/24 is subnetted, 1 subnets
C 6.1.1.0 is directly connected, Loopback6
172.12.0.0/24 is subnetted, 3 subnets
R 172.12.34.0 [120/2] via 15.0.0.1, 00:00:03, FastEthernet0/0
R172.12.13.0 [120/2] via 15.0.0.1, 00:00:03, FastEthernet0/0
R172.12.123.0 [120/2] via 15.0.0.1, 00:00:03, FastEthernet0/0
7.0.0.0/24 is subnetted, 1 subnets
C7.1.1.0 is directly connected, Loopback7
15.0.0.0/24 is subnetted, 1 subnets
C15.0.0.0 is directly connected, FastEthernet0/0

R4#show ip route
<Output omitted>
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/75] via 172.12.34.3, 00:15:17, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/75] via 172.12.34.3, 00:15:17, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/11] via 172.12.34.3, 00:17:14, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback4
5.0.0.0/24 is subnetted, 1 subnets
O E2 5.1.1.0 [110/20] via 172.12.34.3, 00:04:18, FastEthernet0/0
6.0.0.0/24 is subnetted, 1 subnets
O E2 6.1.1.0 [110/20] via 172.12.34.3, 00:04:18, FastEthernet0/0
172.12.0.0/24 is subnetted, 3 subnets
C 172.12.34.0 is directly connected, FastEthernet0/0
O IA 172.12.13.0 [110/74] via 172.12.34.3, 00:17:39, FastEthernet0/0
O 172.12.123.0 [110/74] via 172.12.34.3, 00:15:42, FastEthernet0/0
7.0.0.0/24 is subnetted, 1 subnets
O E2 7.1.1.0 [110/20] via 172.12.34.3, 00:04:43, FastEthernet0/0
15.0.0.0/24 is subnetted, 1 subnets
O E2 15.0.0.0 [110/20] via 172.12.34.3, 00:04:43, FastEthernet0/0

Summarization Configuration:

In some situations, the area cannot be a stubby area or a totally stubby area like the
backbone area and the transit. So we will configure summarization in a different way.

R1(config)#int loop 8
R1(config-if)#ip address 8.0.0.1 255.255.255.0
R1(config-if)#int loop 9
R1(config-if)#ip address 9.0.0.1 255.255.255.0
R1(config-if)#int loop 10
R1(config-if)#ip address 10.0.0.1 255.255.255.0
R1(config-if)#int loop 11
R1(config-if)#ip address 11.0.0.1 255.255.255.0
R1(config-if)#router ospf 1
R1(config-router)#network 8.0.0.1 0.0.0.0 area 1
R1(config-router)#network 9.0.0.1 0.0.0.0 area 1
R1(config-router)#network 10.0.0.1 0.0.0.0 area 1
R1(config-router)#network 11.0.0.1 0.0.0.0 area 1

R3#show ip route ospf


<Output omitted>
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/65] via 172.12.123.1, 00:15:51, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 172.12.123.2, 00:15:51, Serial1/0
5.0.0.0/24 is subnetted, 1 subnets
O E2 5.1.1.0 [110/20] via 172.12.123.1, 00:15:51, Serial1/0
[110/20] via 172.12.13.1, 00:15:51, Serial1/1
6.0.0.0/24 is subnetted, 1 subnets
O E2 6.1.1.0 [110/20] via 172.12.123.1, 00:15:51, Serial1/0
[110/20] via 172.12.13.1, 00:15:51, Serial1/1
7.0.0.0/24 is subnetted, 1 subnets
O E2 7.1.1.0 [110/20] via 172.12.123.1, 00:15:51, Serial1/0
[110/20] via 172.12.13.1, 00:15:51, Serial1/1
8.0.0.0/32 is subnetted, 1 subnets
O IA 8.0.0.1 [110/65] via 172.12.123.1, 00:01:05, Serial1/0
9.0.0.0/32 is subnetted, 1 subnets
O IA 9.0.0.1 [110/65] via 172.12.123.1, 00:00:55, Serial1/0
10.0.0.0/32 is subnetted, 1 subnets
O IA 10.0.0.1 [110/65] via 172.12.123.1, 00:00:55, Serial1/0
11.0.0.0/32 is subnetted, 1 subnets
O IA 11.0.0.1 [110/65] via 172.12.123.1, 00:00:45, Serial1/0
15.0.0.0/24 is subnetted, 1 subnets
O E2 15.0.0.0 [110/20] via 172.12.123.1, 00:15:51, Serial1/0
[110/20] via 172.12.13.1, 00:15:51, Serial1/1

R1(config)#router ospf 1
R1(config-router)#area 1 range 8.0.0.0 252.0.0.0

R3#show ip route ospf


<Output omitted>
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/65] via 172.12.123.1, 00:18:19, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 172.12.123.2, 00:18:19, Serial1/0
5.0.0.0/24 is subnetted, 1 subnets
O E2 5.1.1.0 [110/20] via 172.12.123.1, 00:18:19, Serial1/0
[110/20] via 172.12.13.1, 00:18:19, Serial1/1
6.0.0.0/24 is subnetted, 1 subnets
O E2 6.1.1.0 [110/20] via 172.12.123.1, 00:18:19, Serial1/0
[110/20] via 172.12.13.1, 00:18:19, Serial1/1
7.0.0.0/24 is subnetted, 1 subnets
O E2 7.1.1.0 [110/20] via 172.12.123.1, 00:18:19, Serial1/0
[110/20] via 172.12.13.1, 00:18:19, Serial1/1
15.0.0.0/24 is subnetted, 1 subnets
O E2 15.0.0.0 [110/20] via 172.12.123.1, 00:18:19, Serial1/0
[110/20] via 172.12.13.1, 00:18:19, Serial1/1
O IA 8.0.0.0/6 [110/65] via 172.12.123.1, 00:00:39, Serial1/0

Another way to summarize from an external network to the OSPF network is the
summary-address command:

R1(config)#router ospf 1
R1(config-router)#summary-address 4.0.0.0 252.0.0.0

R3#show ip route ospf


<Output omitted>
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/65] via 172.12.123.1, 00:21:13, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 172.12.123.2, 00:21:13, Serial1/0
15.0.0.0/24 is subnetted, 1 subnets
O E2 15.0.0.0 [110/20] via 172.12.123.1, 00:21:13, Serial1/0
[110/20] via 172.12.13.1, 00:21:13, Serial1/1
O E2 4.0.0.0/6 [110/20] via 172.12.123.1, 00:00:34, Serial1/0
[110/20] via 172.12.13.1, 00:00:34, Serial1/1
O IA 8.0.0.0/6 [110/65] via 172.12.123.1, 00:03:33, Serial1/0

And the network is still pingable. R3#ping 9.0.0.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 9.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/69/148 ms

R3#ping 5.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.1.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 116/145/184 ms

Best Wishes

Abeer 

You might also like