001 HUB1 Configuration

You might also like

Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 2

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

HUB-1
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

enable
!
conf t
!
hostname HUB-01
!
no ip domain lookup
username maymus privilege 15 secret farhan@321
enable secret farhan@321
service password-encryption
banner motd #Unauthorized Access Strictly Prohibited#
!
line con 0
login local
logging synchronous
exec-timeout 0 0
!
line vty 0 15
login local
transport input ssh
logging synchronous
exec-timeout 0 0
exit
!
ip domain name Farhan.com
crypto key generate rsa general-keys modulus 1024
ip ssh authentication-retries 4
ip ssh time-out 60
ip ssh version 2
!
!
!
interface Tunnel1
ip address 192.168.1.1 255.255.255.0
ip nhrp map 192.168.1.2 13.0.0.1
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source 12.0.0.1
tunnel mode gre multipoint
ip nhrp authentication Ihman321
ip nhrp redirect timeout 5
ip nhrp holdtime 600
delay 1000
tunnel key 20
bandwidth 1000
tunnel protection ipsec profile protect-gre
!
interface GigabitEthernet0/0
ip address 12.0.0.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface GigabitEthernet0/1
ip address 2.0.0.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface GigabitEthernet0/2
ip address 8.0.0.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
!
router ospf 1
redistribute bgp 1
network 2.0.0.0 0.0.0.255 area 0
network 8.0.0.0 0.0.0.255 area 0
network 9.0.0.0 0.0.0.255 area 0
!
router bgp 1
network 192.168.1.0
redistribute ospf 1
neighbor 192.168.1.2 remote-as 2
neighbor 192.168.1.3 remote-as 3
neighbor 192.168.1.4 remote-as 4
neighbor 192.168.1.5 remote-as 5
neighbor 192.168.1.6 remote-as 6
!
exit
!
ip route 0.0.0.0 0.0.0.0 12.0.0.2
!
do write
!
end
!

You might also like