Download as pdf or txt
Download as pdf or txt
You are on page 1of 7

4/29/2019 MPLS LDP Label Filtering Example | NetworkLessons.

com

Search...

Table of Contents
MPLS

 Unit 1: Introduction

 Unit 2: LDP (Label Distribution Protocol)

MPLS LDP (Label Distribution Protocol)

MPLS LDP Label Filtering

 Unit 3: MPLS VPN

 Unit 4: MPLS L2 Encapsulation

 Unit 5: IPv6 MPLS

You are here: Home » MPLS

MPLS LDP Label Filtering Example


a d k y v
Once you enable MPLS on the interfaces between the routers and LDP neighbor adjacencies have been formed, a label will be advertised for
each network. With LDP however we can con gure lters to decide what networks should get a label and which ones shouldn’t be tagged. I’ll
use the following topology to demonstrate this:

Above we have 3 routers and each router has 2 loopback interfaces so that we have plenty of networks to play with. Before we enable MPLS
we’ll con gure OSPF so that all networks are advertised:

R1,R2,R3:
(config)#router ospf 1
(config-router)#network 0.0.0.0 255.255.255.255 area 0

We’ll do this the easy way and activate OSPF on all interfaces. Now let’s enable MPLS on the FastEthernet interfaces:

https://networklessons.com/mpls/mpls-ldp-label-filtering-example 1/7
4/29/2019 MPLS LDP Label Filtering Example | NetworkLessons.com

R1(config)#interface fastEthernet 0/0


R1(config-if)#mpls ip

R2(config)#interface fastEthernet 0/0


R2(config-if)#mpls ip
R2(config-if)#exit
R2(config)#interface fastEthernet 0/1
R2(config-if)#mpls ip

R3(config)#interface fastEthernet 0/0


R3(config-if)#mpls ip

Let’s check if we have LDP neighbors:

R2#show mpls ldp neighbor | include Peer


Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 22.22.22.22:0
Peer LDP Ident: 33.33.33.33:0; Local LDP Ident 22.22.22.22:0

So far so good, now let’s take a look at the LDP labels that have been generated:

R1#show mpls forwarding-table


Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 2.2.2.2/32 0 Fa0/0 192.168.12.2
17 17 33.33.33.33/32 0 Fa0/0 192.168.12.2
18 18 3.3.3.3/32 0 Fa0/0 192.168.12.2
19 Pop tag 22.22.22.22/32 0 Fa0/0 192.168.12.2
20 Pop tag 192.168.23.0/24 0 Fa0/0 192.168.12.2

R2#show mpls forwarding-table


Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 1.1.1.1/32 0 Fa0/0 192.168.12.1
17 Pop tag 33.33.33.33/32 0 Fa0/1 192.168.23.3
18 Pop tag 3.3.3.3/32 0 Fa0/1 192.168.23.3
19 Pop tag 11.11.11.11/32 0 Fa0/0 192.168.12.1

R3#show mpls forwarding-table


Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 192.168.12.0/24 0 Fa0/0 192.168.23.2
17 16 1.1.1.1/32 0 Fa0/0 192.168.23.2
18 Pop tag 2.2.2.2/32 0 Fa0/0 192.168.23.2
19 Pop tag 22.22.22.22/32 0 Fa0/0 192.168.23.2
20 19 11.11.11.11/32 0 Fa0/0 192.168.23.2

For all networks a label has been generated by LDP. Now let’s con gure ltering so that we only generate labels for the loopback 0 interfaces.
This is how you do it:

R1(config)#access-list 1 permit 1.1.1.1 0.0.0.0


R1(config)#no mpls ldp advertise-labels
R1(config)#mpls ldp advertise-labels for 1

https://networklessons.com/mpls/mpls-ldp-label-filtering-example 2/7
4/29/2019 MPLS LDP Label Filtering Example | NetworkLessons.com

R2(config)#access-list 1 permit 2.2.2.2 0.0.0.0


R2(config)#no mpls ldp advertise-labels
R2(config)#mpls ldp advertise-labels for 1

R3(config)#access-list 1 permit 3.3.3.3 0.0.0.0


R3(config)#no mpls ldp advertise-labels
R3(config)#mpls ldp advertise-labels for 1

First use no mpls ldp advertise-labels to disable the advertisement of all labels. Secondly use the mpls ldp advertise-labels for command
and refer to an access-list or pre x-list to choose what networks should have a label.

Be careful, if you forget to use the no mpls ldp advertise-labels command you will discover that LDP is STILL advertising a label for
each network…

Let’s verify our work:

R1#show mpls forwarding-table


Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 2.2.2.2/32 0 Fa0/0 192.168.12.2
17 Untagged 33.33.33.33/32 0 Fa0/0 192.168.12.2
18 Untagged 3.3.3.3/32 0 Fa0/0 192.168.12.2
19 Untagged 22.22.22.22/32 0 Fa0/0 192.168.12.2
20 Untagged 192.168.23.0/24 0 Fa0/0 192.168.12.2

R2#show mpls forwarding-table


Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 1.1.1.1/32 0 Fa0/0 192.168.12.1
17 Untagged 33.33.33.33/32 0 Fa0/1 192.168.23.3
18 Pop tag 3.3.3.3/32 0 Fa0/1 192.168.23.3
19 Untagged 11.11.11.11/32 0 Fa0/0 192.168.12.1

R3#show mpls forwarding-table


Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 192.168.12.0/24 0 Fa0/0 192.168.23.2
17 Untagged 1.1.1.1/32 0 Fa0/0 192.168.23.2
18 Pop tag 2.2.2.2/32 0 Fa0/0 192.168.23.2
19 Untagged 22.22.22.22/32 0 Fa0/0 192.168.23.2
20 Untagged 11.11.11.11/32 0 Fa0/0 192.168.23.2

Above you can see that only network 1.1.1.1/32, 2.2.2.2/32 and 3.3.3.3/32 now have a label when advertised to a LDP neighbor.

Configurations
Want to take a look for yourself? Here you will nd the con guration of each device.

R1

https://networklessons.com/mpls/mpls-ldp-label-filtering-example 3/7
4/29/2019 MPLS LDP Label Filtering Example | NetworkLessons.com

hostname R1
!
ip cef
!
no mpls ldp advertise-labels
mpls ldp advertise-labels for 1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
mpls ip
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
access-list 1 permit 1.1.1.1
!
end

R2
hostname R2
!
ip cef
!
no mpls ldp advertise-labels
mpls ldp advertise-labels for 1
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
mpls ip
!
interface FastEthernet0/1
ip address 192.168.23.2 255.255.255.0
mpls ip
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
access-list 1 permit 2.2.2.2
!
end

R3

https://networklessons.com/mpls/mpls-ldp-label-filtering-example 4/7
4/29/2019 MPLS LDP Label Filtering Example | NetworkLessons.com

hostname R3
!
ip cef
!
no mpls ldp advertise-labels
mpls ldp advertise-labels for 1
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.23.3 255.255.255.0
mpls ip
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
access-list 1 permit 3.3.3.3
!
end

That’s all I wanted to show you, if you have any questions feel free to leave a comment!

« Previous Lesson
MPLS LDP (Label Distribution
Protocol)
Next Lesson
VRFs (Virtual Routing and
Forwarding)
»
 Tags: LDP

Forum Replies

system

For r1 why is 3.3.3.3 untagged?


Similar for r3 why is 1.1.1.1 untagged?

ReneMolenaar

That’s what this tutorial is about… ltering tags so not all pre xes get a tag. R2 only sends a tag for 2.2.2.2 /32 to R1 and R3, not for 1.1.1.1/32 or 3.3.3.3/32.

ReneMolenaar

TDP is the old Cisco equivalent protocol for LDP. LDP is an IETF standard. On older IOS versions, TDP is the default. Nowadays LDP is the default. There is a
command to change the protocol:

https://networklessons.com/mpls/mpls-ldp-label-filtering-example 5/7
4/29/2019 MPLS LDP Label Filtering Example | NetworkLessons.com

R1(config)#mpls label protocol ?


ldp Use LDP (default)
tdp Use TDP

Zaman.rubd

Hi Rene,

I am little bit confused that where we can use the label ltering in Production network .I am looking for scenario where we deploy it . Thx

br//zaman

ReneMolenaar

Hi Zaman,

Think of an MPLS VPN network where we have PE and CE routers. The PE routers only require an LSP (Label Switched Path) between their loopback interfaces
and the /32 IP address that is con gured on these loopback interfaces. These are the IP addresses that are used for the next hops in BGP.

By default, LDP creates and advertises a label for each and every pre x that is learned. This increases memory usage but also the number of advertisements
between peers. If you only advertise labels for the LSPs that you need, you reduce convergence time and memory usage.

 8 more replies! Ask a question or join the discussion by visiting our Community Forum

Hello There!
I am René Molenaar (CCIE
#41726), Your main Instructor.
My goal is to teach you
everything about Cisco,
Wireless and Security. I am
here to Help You Master Networking!

Read my story

Social Fans

 
14,319 9,788
FANS FOLLOWERS

 
658 14,352
FOLLOWERS SUBSCRIBERS

New Lessons
Device Programmability
Data Models and Structures
Network Automation and Orchestration
Cloud Connectivity
Virtualization Functions (NFVI, VNF)

https://networklessons.com/mpls/mpls-ldp-label-filtering-example 6/7
4/29/2019 MPLS LDP Label Filtering Example | NetworkLessons.com

Tag Cloud
802.1Q 802.1X ACL ARP Authentication
Certi cate Cloud Design DMVPN DHCP
Filtering GRE IGMP IKE IOS
IP Routing IPSec LDP Linux
Load Balancing LSA NAT Network Management

Network Services Network Type OER

OSPFv3 PAT PFR PIM PPP Redistribution


Security Shaping SSH Stub
Summarization Trunk Tuning Tunnel VLAN
VMWare VPN VRF Wireless

Disclaimer
Privacy Policy
Support
© 2013 - 2019 NetworkLessons.com 21871

https://networklessons.com/mpls/mpls-ldp-label-filtering-example 7/7

You might also like