Download as pdf or txt
Download as pdf or txt
You are on page 1of 6

6/9/23, 1:21 PM Cisco IOS Command List: Router/Switch configuration commands

Commands/Keystroke Description

Press the key  Tab Completes a partial command name entry.

Press the key  Backspace Erases the character to the left of the cursor.

Press the key  Ctrl + D Erases the character at the cursor.

Press the key  Ctrl + K Erases all characters from the cursor to the end of the command line.

Press the key  Esc + D Erases all characters from the cursor to the end of the word.

Erases all characters from the cursor back to the beginning of the command
Press the key  Ctrl + U  or  Ctrl + X
line.

Press the key  Ctrl + W Erases the word to the left of the cursor.

Press the key  Ctrl + A Moves the cursor to the beginning of the line.

Press the key  Left Arrow  or  Ctrl + B Moves the cursor one character to the left.

Press the key  Esc + B Moves the cursor back one word to the left.

Press the key  Esc + F Moves the cursor forward one word to the right.

Press the key  Right Arrow  or  Ctrl + F Moves the cursor one character to the right.

Press the key  Ctrl + E Moves the cursor to the end of command line.

Recalls the previous command in the history buffer, beginning with the most
Press the key  Up Arrow  or  Ctrl + P
recent command.

Press the key  Down Arrow  or  Ctrl + N Goes to the next line in the the history buffer.

Redisplays the system prompt and command line after a console message is
Press the key  Ctrl + R  or  Ctrl + I  or  Ctrl + L
received.

Press the key  Enter Displays the next line.

Press the key  Space  Bar Displays the next screen.

Ends the display string, returning to previous prompt. * Except "y", which
Any other key *
answers "yes" and acts like the  Space  bar

When in any configuration mode, ends the configuration mode and returns to
Press the key  Ctrl + C privileged EXEC mode. When in setup mode, aborts back to the command
prompt.

When in any configuration mode, ends the configuration mode and returns to
Press the key  Ctrl + Z
privileged EXEC mode.

Press the key  Ctrl + Shift + 6 All-purpose break sequence used to abort DNS lookups, traceroutes, pings, etc.

« ‹ 1 2 3 › »

https://itexamanswers.net/cisco-ios-command-list-router-switch-configuration-commands.html 1/6
6/9/23, 1:21 PM Cisco IOS Command List: Router/Switch configuration commands

Commands/Keystroke Description

On Switch:
Switch# delete flash:vlan.dat
Switch# erase startup-config
Switch# reload
Delete/erase the startup configuration for the Router/Switch.

On Router:
Router# erase startup-config
Router# reload

Switch/Router> show clock Display the current clock settings

Switch/Router# clock set 15:08:00 Oct 26 2022 Configure the clock

C:UsersWindows10> ipconfig /all Verify PC settings and connectivity

C:UsersWindows10> ping 192.168.1.5 Test the connectivity to PC with IP address 192.168.1.5.

Switch/Router(config)# hostname Brand Change the switch name/router name to Brand.

Router/Switch(config)# no ip domain-lookup Prevent/disable unwanted DNS lookups.

Assign class as the privileged EXEC password Note: The enable secret


Switch/Router(config)# enable secret class password overrides the enable password. If both are configured on the switch,
you must enter the enable secret password to enter privileged EXEC mode.

« ‹ 1 2 3 › »

boot system

Unprivileged Commands

enable lock ping

telnet traceroute resume

disconnect ssh exit

Privileged Commands

configure terminal debug setup

copy running-config startup-config erase startup-config write

clock set clear reload

write terminal undebug all copy tftp startup-config

copy running-config tftp copy tftp running-config copy startup-config running-config

https://itexamanswers.net/cisco-ios-command-list-router-switch-configuration-commands.html 2/6
6/9/23, 1:21 PM Cisco IOS Command List: Router/Switch configuration commands

terminal monitor copy startup-config tftp

Configure Commands

ip domain-lookup no hostname

config-register clock timezone alias exec

logging console do default interface

interface router username

ip classless ip subnet-zero ip default-gateway

ip dhcp pool enable secret ip domain-name

ip host ip http server ip name-server

ip route access-list (standard) access-list (extended)

ip access-list service password-encryption interface loopback

end logging buffered banner motd

router rip router eigrp <As> router ospf <process id>

ip nat pool ip nat inside source list ip nat inside source static

ip dhcp excluded-address enable password

Interface Commands

ip address clock rate encapsulation

bandwidth description duplex

no shutdown / shutdown encapsulation dot1q keepalive

ip access-group ip bandwidth-percent (EIGRP) ip directed-broadcast

ip helper-address (DHCP) ip mtu ip ospf #

ip ospf cost ip ospf priority ip ospf network broadcast

ip ospf network nonbroadcast ip ospf network point-to-point ip ospf network point-to-multipoint

ip ospf hello-interval ip ospf dead-interval cdp enable

ip rip send ip rip receive speed

mac-address ip split-horizon (RIP) ip split-horizon eigrp <As>

encapsulation ppp ppp authentication chap ppp chap hostname

ppp chap password ppp pap sent-username encapsulation frame-relay

frame-relay interface-dlci frame-relay map ip frame-relay inverse-arp

ip nat inside ip nat outside ip nat enable

ip address dhcp ppp authentication pap delay

Line console Commands

logging synchronous login history size

exec-timeout length lockable

https://itexamanswers.net/cisco-ios-command-list-router-switch-configuration-commands.html 3/6
6/9/23, 1:21 PM Cisco IOS Command List: Router/Switch configuration commands

password privilege

Line VTY Commands 

logging synchronous login history size

exec-timeout length lockable

password privilege access-class

Show Commands

show access-lists show Running-config show startup-config

show running-config Interface show Clock show controllers

show debug show frame-relay map show frame-relay pvc

show frame-relay lmi show hosts show interfaces

show ip interfaces show ip interface brief show sessions

show tech-support show ip access-lists show ip dhcp binding

show ip dhcp conflicts show ip dhcp pool show dhcp server

show ip eigrp interface show ip eigrp neighbors show ip eigrp topology

show ip ospf interface show ip ospf interface brief show ip ospf neighbor

show ip ospf database show ip route show ip route rip

show ip route eigrp show ip route ospf show ip route connected

show ip nat translations show ip nat statistics show ip protocols

show cdp neighbors show cdp neighbors detail show dhcp lease

Filtering Output *

Router RIP Commands

version 2 no auto-summary network

passive-interface validate-update-source passive-interface default

maximum-paths distribute-list offset-list

distance timers neighbor

Router EIGRP Commands

no auto-summary network distance

distribute-list eigrp router-id passive-interface

passive-interface default variance (EIGRP) offset-list

distance eigrp maximum-paths neighbor

https://itexamanswers.net/cisco-ios-command-list-router-switch-configuration-commands.html 4/6
6/9/23, 1:21 PM Cisco IOS Command List: Router/Switch configuration commands
Router OSPF Commands

network

passive-interface router-id passive-interface default

maximum-paths distribute-list auto-cost reference-bandwidth

distance distance ospf neighbor

Debug Commands

debug ip packet debug ip packet detail debug ip routing

debug ip eigrp debug ip ospf adj debug ip ospf events

debug ip ospf packet debug ip rip

Clear Commands

clear ip route * clear ip ospf process clear ip eigrp neighbors

Switch Commands

Privilege Commands

vlan database configure

Vlan Database Commands

vlan exit show

vtp domain vtp pruning vtp server

vtp client vtp transparent vtp password

apply

Configure Commands

vlan interface vlan interface range

vtp mode server vtp mode client vtp mode transparent

vtp domain vtp password spanning-tree backbonefast

vtp pruning spanning-tree portfast ip default-gateway

spanning-tree vlan root primary spanning-tree vlan root secondary spanning-tree vlan priority

spanning-tree uplinkfast

Interface Commands

switchport mode access switchport mode trunk switchport nonegotiate

spanning vlan cost switchport trunk encapsulation dot1q switchport trunk encapsulation isl

https://itexamanswers.net/cisco-ios-command-list-router-switch-configuration-commands.html 5/6
6/9/23, 1:21 PM Cisco IOS Command List: Router/Switch configuration commands

switchport trunk native vlan spanning-tree port-priority switchport trunk allowed vlan

switchport access vlan switchport port-security switchport port-security mac-address

spanning-tree vlan port-priority switchport port-security maximum switchport port-security violation

spanning-tree cost spanning-tree guard root

spanning-tree portfast

Show Commands

show vlan show vlan brief show interface trunk

show spanning-tree show spanning-tree vlan show vtp status

show port-sec show mac-address-table show interface

Special Keys Commands

Tab Return (at the –More– prompt) space Bar (at the –More– prompt)

Ctrl-F Esc-B Esc-F

Ctrl-A Ctrl-E Ctrl-D

Esc-D Ctrl-W Ctrl-K

Ctrl-U or Ctrl-X Up Arrow or Ctrl-P Down Arrow or Ctrl-N

Ctrl-Y Ctrl-Z Ctrl-shift-6, x

← Previous Article
Connection Multiplexing Explained with Examples
Next Article →
show version Command on CISCO Router/Switch

https://itexamanswers.net/cisco-ios-command-list-router-switch-configuration-commands.html 6/6

You might also like