Download as pdf or txt
Download as pdf or txt
You are on page 1of 34

Command Manual – Port Basic Configuration

H3C S3100-52P Ethernet Switch Table of Contents

Table of Contents

Chapter 1 Port Basic Configuration Commands........................................................................ 1-1


1.1 Port Basic Configuration Commands................................................................................. 1-1
1.1.1 broadcast-suppression............................................................................................ 1-1
1.1.2 copy configuration ................................................................................................... 1-2
1.1.3 description ............................................................................................................... 1-4
1.1.4 display brief interface .............................................................................................. 1-5
1.1.5 display interface ...................................................................................................... 1-6
1.1.6 display loopback-detection...................................................................................... 1-9
1.1.7 display transceiver-information interface .............................................................. 1-10
1.1.8 display port ............................................................................................................ 1-11
1.1.9 display unit ............................................................................................................ 1-12
1.1.10 duplex.................................................................................................................. 1-13
1.1.11 flow-control .......................................................................................................... 1-14
1.1.12 flow interval ......................................................................................................... 1-15
1.1.13 giant-frame statistics enable ............................................................................... 1-16
1.1.14 interface............................................................................................................... 1-16
1.1.15 jumboframe enable ............................................................................................. 1-17
1.1.16 loopback .............................................................................................................. 1-18
1.1.17 loopback-detection control enable ...................................................................... 1-19
1.1.18 loopback-detection enable .................................................................................. 1-20
1.1.19 loopback-detection interval-time ......................................................................... 1-20
1.1.20 loopback-detection per-vlan enable .................................................................... 1-21
1.1.21 mdi....................................................................................................................... 1-22
1.1.22 multicast-suppression ......................................................................................... 1-22
1.1.23 port access vlan .................................................................................................. 1-23
1.1.24 port hybrid pvid vlan ............................................................................................ 1-24
1.1.25 port hybrid vlan.................................................................................................... 1-25
1.1.26 port link-type........................................................................................................ 1-26
1.1.27 port trunk permit vlan .......................................................................................... 1-27
1.1.28 port trunk pvid vlan.............................................................................................. 1-28
1.1.29 reset counters interface....................................................................................... 1-29
1.1.30 shutdown ............................................................................................................. 1-29
1.1.31 speed................................................................................................................... 1-30
1.1.32 unicast-suppression ............................................................................................ 1-31
1.1.33 virtual-cable-test.................................................................................................. 1-32

i
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Chapter 1 Port Basic Configuration Commands

1.1 Port Basic Configuration Commands


1.1.1 broadcast-suppression

Syntax

broadcast-suppression { ratio | pps max-pps }


undo broadcast-suppression

View

System view , Ethernet port view

Parameter

ratio: Maximum ratio of the received broadcast traffic to the total bandwidth on an
Ethernet port. The value ranges from 1 to 100 (in step of 1) and defaults to 100. The
smaller the ratio is, the less broadcast traffic is allowed.
max-pps: Maximum number of broadcast packets allowed to be received per second
on an Ethernet port (in pps).
In system view, the max-pps argument is in the range of 1 to 262,143.
In Ethernet port view, the max-pps argument is in the range of 1 to 148,810.

Description

Use the broadcast-suppression command to limit broadcast traffic allowed to be


received on each port (in system view) or on a specified port (in Ethernet port view).
Use the undo broadcast-suppression command to restore the default broadcast
suppression setting.
The broadcast-suppression command is used to enable broadcast suppression. By
default, broadcast suppression is disabled.
When incoming broadcast traffic exceeds the broadcast traffic threshold you set, the
system drops the packets exceeding the threshold to reduce the broadcast traffic ratio
to the reasonable range, so as to keep normal network service.
You can use the undo broadcast-suppression command in system view to cancel the
broadcast suppression settings on all ports, or use the broadcast-suppression
command in system view to make a global setting.
Executing the commands in Ethernet port view only takes effect on the current port.

1-1
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Note:
The global broadcast suppression setting configured by the broadcast-suppression
command in system view takes effect on all Ethernet ports in the system except for the
reflection ports, stack ports and ports having their own broadcast suppression settings.
If you configure broadcast-suppression command in both system view and Ethernet
port view, the configuration in Ethernet port view will take effect.

Example

# Allow incoming broadcast traffic on the Ethernet1/0/1 port to occupy at most 20% of
the bandwidth on the port.
<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] broadcast-suppression 20

# Set the maximum number of broadcast packets that can be received per second by
the Ethernet1/0/1 port to 1000.
[H3C-Ethernet1/0/1] broadcast-suppression pps 1000

1.1.2 copy configuration

Syntax

copy configuration source { interface-type interface-number | aggregation-group


source-agg-id } destination { interface-list [ aggregation-group destination-agg-id ] |
aggregation-group destination-agg-id }

View

System view

Parameter

interface-type: Port type.


interface-number: Port number.
source-agg-id: Source aggregation group number, in the range of 1 to 416. The port
with the smallest port number in the aggregation group is used as the source port.
destination-agg-id: Destination aggregation group number, in the range of 1 to 416.
interface-list: Destination port list, interface-list =interface-type interface-number [ to
interface-type interface-number ] &<1-10. &<1-10> means that you can input up to 10
ports/port ranges.

1-2
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Description

Use the copy configuration command to copy the configuration on a port to some
other ports to keep consistent configuration on them.

Note:
z If you specify a source aggregation group ID, the system uses the port with the
smallest port number in the aggregation group as the source.
z If you specify a destination aggregation group ID, the configuration of the source
port will be copied to all ports in the aggregation group and all ports in the group will
have the same configuration as that of the source port.

The configuration that can be copied includes: VLAN configuration, protocol-based


VLAN configuration, LACP configuration, QoS configuration, GARP configuration, STP
configuration and initial port configuration.
VALN configuration: includes IDs of the VLANs allowed on the port and the default
VLAN ID of the port;
Protocol-based VLAN configuration: includes IDs and indexes of the protocol-based
VLANs allowed on the port;
Link aggregation control protocol (LACP) configuration: includes LACP enable/disable
status;

Note:
The copy command can only be used to copy the configuration of LACP’s enable state,
but not to copy the configuration of aggregation group, i.e., you can not add a port to the
aggregation group bye the command.

QoS configuration: includes rate limit, port priority, and default 802.1p priority on the
port;
STP configuration: includes STP enable/disable status on the port, link attribute on the
port (point-to-point or non-point-to-point), STP priority, path cost, packet transmission
rate limit, whether loop protection is enabled, whether root protection is enabled, and
whether the port is an edge port;
Generic attribute registration protocol (GARP) configuration: includes GVRP
enable/disable status, timer settings, and registration mode;
Port configuration: includes link type of the port, port rate and duplex mode.

1-3
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Example

# Copy the configuration of Ethernet1/0/1 to Ethernet1/0/2 and Ethernet1/0/3.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] copy configuration source ethernet 1/0/1 destination ethernet 1/0/2
ethernet 1/0/3
Note: The following will be removed from destination port list:
Aggregation port(s),Voice vlan port(s).
Copying VLAN configuration...
Copying Protocol based VLAN configuration...
Copying LACP configuration...
Copying QOS configuration...
Copying GARP configuration...
Copying STP configuration...
Copying speed/duplex configuration...

Note:
z Any aggregation group port you input in the destination port list will be removed from
the list and the copy command will not take effect on the port. If you want an
aggregation group port to have the same configuration with the source port, you can
specify the aggregation group of the port as the destination (with the
destination-agg-id argument).
z Any voice-VLAN-enabled port you input in the destination port list will be removed
from the list.

1.1.3 description

Syntax

description text
undo description

View

Ethernet port view

Parameter

text: Port description, a string of 1 to 80 characters.

Description

Use the description command to set a port description string.

1-4
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Use the undo description command to remove the port description string.
By default, no description is defined for a port.

Example

# Set description string "lanswitch-interface" for the Ethernet1/0/1 port.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet1/0/1
[H3C-Ethernet1/0/1] description lanswitch-interface

1.1.4 display brief interface

Syntax

display brief interface [ interface-type interface-number ] [ | { begin | include |


exclude } string ]

View

Any view

Parameter

interface-type: Port type.


interface-number: Port number.
|: Specifies to use a regular expression to describe the configuration information entries
to be displayed.
begin: Each entry must begin with a specified character string.
include: Each entry must include a specified character string.
exclude: Each entry must not include a specified character string.
string: Regular expression, a character string of 1 to 256 characters.

Note:
For details about regular expression, refer to the “Configuration File Management”
module in this manual.

Description

Use the display brief interface command to display the brief configuration information
about one or all interfaces, including: interface type, link state, link rate, duplex attribute,
link type, default VLAN ID and description string.

1-5
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

This command is similar to the display interface command, but the information it
displays is briefer.

Note:
Currently, for the port types other than Ethernet port, this command only displays the
link state, and shows "--" in all other configuration information fields.

Related command: display interface.

Example

# Display the brief configuration information about the Ethernet1/0/1 port.


<H3C> display brief interface Ethernet1/0/1
Interface:
Eth - Ethernet GE - GigabitEthernet TENGE - tenGigabitEthernet
Loop - LoopBack Vlan - Vlan-interface Cas - Cascade
Speed/Duplex:
A - auto-negotiation

Interface Link Speed Duplex Type PVID Description


------------------------------------------------------------------------
Eth1/0/1 DOWN A A hybrid 1 home

Table 1-1 Description on the fields of the display brief interface command

Field Description
Interface Port type
Link Link state: UP or DOWN
Speed Link rate
Duplex Duplex attribute
Type Link type: access, hybrid or trunk
PVID Default VLAN ID
Description Port description string

1.1.5 display interface

Syntax

display interface [ interface-type | interface-type interface-number ]

1-6
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

View

Any view

Parameter

interface-type: Port type.


interface-number: Port number.
For details about the arguments, refer to the parameter description of the interface
command.

Description

Use the display interface command to display port configuration.


When using this command:
If you specify neither port type nor port number, the command displays information
about all ports.
If you specify only port type, the command displays information about all ports of the
specified type.
If you specify both port type and port number, the command displays information about
the specified port.

Example

# Display the configuration information of the Ethernet1/0/1 port.


<H3C> display interface ethernet1/0/1
Ethernet1/0/1 current state : DOWN
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is
0012-a990-2240
Media type is twisted pair, loopback not set
Port hardware type is 100_BASE_TX
100Mbps-speed mode, full-duplex mode
Link speed type is force link, link duplex type is force link
Flow-control is enabled
The Maximum Frame Length is 9216
Broadcast MAX-pps: 500
Unicast MAX-ratio: 100%
Multicast MAX-ratio: 100%
Allow jumbo frame to pass
PVID: 1
Mdi type: auto
Port link-type: access
Tagged VLAN ID : none
Untagged VLAN ID : 1

1-7
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Last 300 seconds input: 0 packets/sec 0 bytes/sec


Last 300 seconds output: 0 packets/sec 0 bytes/sec
Input(total): 0 packets, 0 bytes
0 broadcasts, 0 multicasts, - pauses
Input(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Input: 0 input errors, 0 runts, 0 giants, - throttles, 0 CRC
0 frame, - overruns, 0 aborts, 0 ignored, - parity errors
Output(total): 0 packets, 0 bytes
0 broadcasts, 0 multicasts, 0 pauses
Output(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Output: 0 output errors, - underruns, - buffer failures
0 aborts, 0 deferred, 0 collisions, 0 late collisions
0 lost carrier, - no carrier

Table 1-2 Description on the fields of the display interface command

Field Description
Current Ethernet port status: up or
Ethernet1/0/1 current state
down
IP Sending Frames' Format Ethernet frame format

Hardware address Port hardware address


Media type Media type
Port hardware type Port hardware type

100Mbps-speed mode, full-duplex mode Current speed mode and duplex mode
Link speed type is force link, link duplex Link speed and duplex status ( force or
type is force link auto-negotiation)
Flow-control is enabled Status of flow-control on the port
Maximum frame length allowed on the
The Maximum Frame Length
port
Broadcast suppression ratio on the
Broadcast MAX-ratio
port
Unknown unicast suppression ratio on
Unicast MAX-ratio
the port
Multicast MAX-ratio Multicast suppression ratio on the port

Whether Jumbo frame is allowed on


Allow jumbo frame to pass
the port.
PVID Default VLAN ID of the port
Mdi type Network cable type

1-8
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Field Description
Port link-type Port link type
Identify the VLANs whose packets will
Tagged VLAN ID
be forwarded with tags on the port.
Identify the VLANs whose packets will
Untagged VLAN ID
be forwarded without tags on the port.
Last 300 seconds input: 0 packets/sec 0
bytes/sec Rate and number of incoming and
outgoing packets in the last 300
Last 300 seconds output: 0 packets/sec 0 seconds
bytes/sec
Input(total): 0 packets, 0 bytes
0 broadcasts, 0 multicasts, - pauses
Input(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Input: 0 input errors, 0 runts, 0 giants, -
throttles, 0 CRC
0 frame, - overruns, 0 aborts, 0 Statistics on the incoming and
ignored, - parity errors outgoing packets and errors on the
Output(total): 0 packets, 0 bytes port
0 broadcasts, 0 multicasts, 0 pauses The “-” indicates that the statistical
item is not supported.
Output(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Output: 0 output errors, - underruns, -
buffer failures
0 aborts, 0 deferred, 0 collisions, 0
late collisions
0 lost carrier, - no carrier

1.1.6 display loopback-detection

Syntax

display loopback-detection

View

Any view

Parameter

None

1-9
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Description

Use the display loopback-detection command to display the loopback detection


status on the port. If loopback detection is enabled, this information will also be
displayed: time interval for loopback detection and the loopback ports.

Example

# Display the loopback detection status on the port.


<H3C> display loopback-detection
Port Ethernet1/0/1 loopback-detection is running
system Loopback-detection is running
Detection interval time is 30 seconds
There is no port existing loopback link

Table 1-3 Description on the fields of the display loopback-detection command

Field Description
Port Ethernet1/0/1 Loopback detection is enabled on the
loopback-detection is running Ethernet1/0/1.
system Loopback-detection is
Loopback detection is enabled globally.
running
Time interval for loopback detection is 30
Detection interval time is 30 seconds
seconds.
There is no port existing loopback link No loopback port exists.

1.1.7 display transceiver-information interface

Syntax

display transceiver-information interface interface-type interface-number

View

Any view

Parameter

interface-type: Port type


interface-number: Port number

Description

Use the display port display transceiver-information interface command to display


information about a specified optical port.
This command will display the following information about an optical port:

1-10
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

z Hardware type
z Interface type
z Wavelength
z Vendor name
z Serial number
z Transfer distance
z Current receive state: no signal or signal detected, “-“ means not supported by the
current device

Example

# Display the information about the optical interface GigabitEthernet1/1/1.


<H3C> display transceiver-information interface GigabitEthernet 1/1/1
Hardware Type : -
Interface Type : SFP
Wave Length(nm) : -
Vendor Name : 3Com
Serial Number : L1RP3N0067090
3C Number :
Transfer Distance(m)
9um Fiber : 0
50um Fiber : 550
62.5um Fiber : 270
Copper Line : 0

1.1.8 display port

Syntax

display port { hybrid | trunk }

View

Any view

Parameter

hybrid: Displays hybrid ports.


trunk: Displays trunk ports.

Description

Use the display port command to check whether there are hybrid or trunk ports in the
current system and display such ports (if available).

Example

# Display the hybrid ports in the current system.

1-11
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

<H3C> display port hybrid


The following hybrid ports exist:
Ethernet1/0/1 Ethernet1/0/2

The above information shows the current system has two hybrid ports: Ethernet1/0/1
and Ethernet1/0/2.

1.1.9 display unit

Syntax

display unit unit-id interface

View

Any view

Parameter

unit-id: Unit ID, in the range of 1 to 8.

Description

Use the display unit command to display information about the ports on a specified
unit.

Example

# Display information about the ports on unit 1.


<H3C> display unit 1 interface
Aux1/0/0
Description : Aux Interface

Ethernet1/0/1 current state : DOWN


IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is
0012-a990-2240
Media type is twisted pair, loopback not set
Port hardware type is 100_BASE_TX
100Mbps-speed mode, full-duplex mode
Link speed type is force link, link duplex type is force link
Flow-control is enabled
The Maximum Frame Length is 9216
Broadcast MAX-pps: 500
Unicast MAX-ratio: 100%
Multicast MAX-ratio: 100%
Allow jumbo frame to pass
PVID: 1
Mdi type: auto

1-12
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Port link-type: access


Tagged VLAN ID : none
Untagged VLAN ID : 1
Last 300 seconds input: 0 packets/sec 0 bytes/sec
Last 300 seconds output: 0 packets/sec 0 bytes/sec
Input(total): 0 packets, 0 bytes
0 broadcasts, 0 multicasts, - pauses
Input(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Input: 0 input errors, 0 runts, 0 giants, - throttles, 0 CRC
0 frame, - overruns, 0 aborts, 0 ignored, - parity errors
Output(total): 0 packets, 0 bytes
0 broadcasts, 0 multicasts, 0 pauses
Output(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Output: 0 output errors, - underruns, - buffer failures
0 aborts, 0 deferred, 0 collisions, 0 late collisions
0 lost carrier, - no carrier

(The following displayed information is omitted)

Table 1-4 Description on the fields of the display unit command

Field Description
Aux1/0/0 The description string of the AUX port is
Description : Aux Interface "Aux Interface".

For the description of other fields, refer to Table 1-2.

1.1.10 duplex

Syntax

duplex { auto | full | half }


undo duplex

View

Ethernet port view

Parameter

auto: Sets the port to auto-negotiation mode.


full: Sets the port to full duplex mode.
half: Sets the port to half duplex mode.

1-13
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Description

Use the duplex command to set the duplex mode of the current port.
Use the undo duplex command to restore the default duplex mode, that is,
auto-negotiation.
By default, the port is in auto-negotiation mode.
Related command: speed.

Example

# Set the Ethernet1/0/1 port to auto-negotiation mode.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] duplex auto

1.1.11 flow-control

Syntax

flow-control
undo flow-control

View

Ethernet port view

Parameter

None

Description

Use the flow-control command to enable flow control on the current Ethernet port.
Use the undo flow-control command to disable flow control on the port.
Suppose flow control is enabled on both the local and peer switches. When congestion
occurs on the local switch,
the local switch sends a message to notify the peer switch of stopping sending packets
to itself or reducing the sending rate temporarily,
the peer switch will stop sending packets to the local switch or reduce the sending rate
temporarily when it receives the message; and vice versa. By this way, packet loss is
avoided and the network service operates normally.
By default, flow control is disabled on a port.

1-14
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Example

# Enable flow control on the Ethernet1/0/1 port.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] flow-control
[H3C-Ethernet1/0/1]

1.1.12 flow interval

Syntax

flow-interval interval
undo flow-interval

View

Ethernet port view

Parameter

Interval: Interval (in seconds) to perform statistics on port information. This argument
ranges from 5 to 300 (in step of 5) and is 300 by default.

Description

Use the flow-interval command to set the interval to perform statistics on port
information.
Use the undo flow-interval command to restore the default interval.
By default, this interval is 300 seconds.
When you use the display interface interface-type interface-number command to
display the information of a port, the system performs statistical analysis on the traffic
flow passing through the port during the specified interval and displays the average
rates in the interval. For example, if you set the interval to 100 seconds, the displayed
information is as follows:
Last 100 seconds input: 0 packets/sec 0 bytes/sec
Last 100 seconds output: 0 packets/sec 0 bytes/sec

Related command: display interface.

Example

# Set the interval to perform statistics on the Ethernet1/0/1 port to 100 seconds.
<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1

1-15
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

[H3C-Ethernet1/0/1] flow-interval 100

1.1.13 giant-frame statistics enable

Syntax

giant-frame statistics enable


undo giant-frame statistics enable

View

System view

Parameter

None

Description

Use the giant-frame statistics enable command to enable the giant-frame statistics
function.
Use the undo giant-frame statistics enable command to disable the giant-frame
statistics function.
By default, the giant-frame statistics function is not enabled.

Example

# Enable the giant-frame statistics function.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] giant-frame statistics enable

1.1.14 interface

Syntax

interface interface-type interface-number

View

System view

Parameter

interface-type: Port type, which can be Aux, Ethernet, GigabitEthernet, LoopBack,


NULL or Vlan-interface.
interface-number: Port number, in the format of Unit ID/slot number/port number,
where:
Unit ID is in the range of 1 to 8;

1-16
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

The slot number is 0 if the port is an Ethernet port;


The slot number is 1 if the port is a GigabitEthernet port.
For details about the types and port number ranges of the ports on S3100-52P Ethernet
switch, refer to Table 1-5.

Table 1-5 Description on port types and port number ranges

Range of port number


Switch model
Ethernet port GigabitEthernet port
S3100-52P 1 to 48 1 to 4

Description

Use the interface command to enter Ethernet port view. To configure parameters for a
port, you must enter the port view first.

Example

# Enter Ethernet1/0/1 port view.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1]

1.1.15 jumboframe enable

Syntax

jumboframe enable
undo jumboframe enable

View

Ethernet port view

Parameter

None

Description

Use the jumboframe enable command to allow jumbo frames that are not larger than
9216 bytes to pass through the current Ethernet port.
Use the undo jumboframe enable command to allow frames that are not larger than
1536 bytes to pass through the current Ethernet port.

1-17
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

By default, frames that are not larger than 9216 bytes are allowed to pass through the
Ethernet port.

Example

# Allow frames that are not larger than 9216 bytes to pass through
GigabitEthernet1/0/1.
<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] jumboframe enable

1.1.16 loopback

Syntax

loopback { external | internal }

View

Ethernet port view

Parameter

external: Performs external loop test. In the external loop test, self-loop headers
(which are made from four cores of the 8-core cables, then the packets forwarded by
the port will be received by itself.) must be used on the port of the switch. The external
loop test can locate the hardware failures on the port.
internal: Performs internal loop test. In the internal loop test, self loop is established in
the switching chip to locate the chip failure which is related to the port.

Description

Use the loopback command to perform a loopback test on the current Ethernet port to
check whether the Ethernet port works normally. The loopback test terminates
automatically after running for a specific period.
By default, no loopback test is performed on the Ethernet port.

Example

# Perform an internal loop test on Ethernet1/0/1.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] loopback internal
Loopback internal succeeded.
[H3C-Ethernet1/0/1]

1-18
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

1.1.17 loopback-detection control enable

Syntax

loopback-detection control enable


undo loopback-detection control enable

View

Ethernet port view

Parameter

None

Description

Use the loopback-detection control enable command to enable the loopback


detection control feature on the current trunk or hybrid port.
Use the undo loopback-detection control enable command to disable the loopback
detection control feature on the trunk or hybrid port.
After loopback detection is enabled by using the loopback-detection enable
command, the loopback-detection control enable command can be used to control
the working status of the trunk port or hybrid port where loopback is found in a VLAN.
If this feature is enabled on a trunk or hybrid port, when loopback is found on the port,
the system sets the port to a controlled working state and removes the MAC address
entries corresponding to the port.
If this feature is disabled on a trunk or hybrid port, when loopback is found on the port,
the system just reports a Trap message, and the port still works normally.
By default, the loopback detection control feature is disabled on the trunk or hybrid port.
Note that this command is invalid for an access port.
Related command: loopback-detection enable.

Example

# Enable the loopback detection control feature on Ethernet1/0/1.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] port link-type trunk
[H3C-Ethernet1/0/1] loopback-detection control enable
[H3C-Ethernet1/0/1]

1-19
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

1.1.18 loopback-detection enable

Syntax

loopback-detection enable
undo loopback-detection enable

View

System view or Ethernet port view

Parameter

None

Description

Use the loopback-detection enable command to enable the loopback detection


feature on ports to detect whether external loopback occurs on a port.
Use the undo loopback-detection enable command to disable the loopback
detection feature on port.
If loopback is found on an access port, the switch will set the port to a controlled
working state.
For a trunk or hybrid port, the loopback detection control feature can be implemented
by using this command and the loopback-detection control enable command together.
The loopback detection feature takes effect on a specified port only when the loopback
detection feature is enabled in both system view and the specified port view.
By default, the loopback detection feature is disabled on any port.
Related command: loopback-detection control enable.

Example

# Enable the loopback detection feature on Ethernet1/0/1.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] loopback-detection enable
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] loopback-detection enable
[H3C-Ethernet1/0/1]

1.1.19 loopback-detection interval-time

Syntax

loopback-detection interval-time time


undo loopback-detection interval-time

1-20
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

View

System view

Parameter

time: Time interval for loopback detection, in the range of 5 to 300 (in seconds). It is 30
seconds by default.

Description

Use the loopback-detection interval-time command to set time interval for loopback
detection.
Use the undo loopback-detection interval-time command to restore the default time
interval.

Example

# Set time interval for loopback detection to 10 seconds.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] loopback-detection interval-time 10
[H3C]

1.1.20 loopback-detection per-vlan enable

Syntax

loopback-detection per-vlan enable


undo loopback-detection per-vlan enable

View

Ethernet port view

Parameter

None

Description

Use the loopback-detection per-vlan enable command to configure the system to


run loopback detection on all VLANs of the current trunk or hybrid port.
Use the undo loopback-detection per-vlan enable command to restore the default
setting.
By default, the system runs loopback detection only on the default VLAN of the trunk or
hybrid port.
Note that the command is invalid for any access port.

1-21
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Example

# Configure the system to run loopback detection on all VLANs of the trunk port
Ethernet1/0/1.
<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] port link-type trunk
[H3C-Ethernet1/0/1] loopback-detection per-vlan enable

1.1.21 mdi

Syntax

mdi { across | auto | normal }


undo mdi

View

Ethernet port view

Parameter

across: Sets the port to support MDIX.


auto: Sets the port to support auto-MDI/MDIX.
normal: Sets the port to support MDI.

Description

Use the mdi command to set port MDI attribute.


Use the undo mdi command to restore the default setting.
By default, the port MDI attribute is auto.

Example

# Set the MDI attribute of Ethernet1/0/1 to across.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface Ethernet1/0/1
[H3C-Ethernet1/0/1] mdi auto

1.1.22 multicast-suppression

Syntax

multicast-suppression { ratio | pps max-pps }


undo multicast-suppression

1-22
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

View

Ethernet port view

Parameter

ratio: Maximum ratio of received multicast traffic to the total bandwidth on the Ethernet
port. The value ranges from 1 to 100 (in step of 1) and defaults to 100. The smaller the
ratio is, the less multicast traffic is allowed to be received.
max-pps: Maximum number of multicast packets allowed to be received per second on
the Ethernet port (in pps). The value ranges from 1 to 148,810.

Description

Use the multicast-suppression command to limit multicast traffic allowed to be


received on the current port.
Use the undo multicast-suppression command to restore the default multicast
suppression setting on the current port.
When incoming multicast traffic on the port exceeds the multicast traffic threshold you
set, the system drops the packets exceeding the threshold to reduce the multicast
traffic ratio to the reasonable range, so as to keep normal network service.
By default, the switch does not suppress multicast traffic.

Example

# Allow the incoming multicast traffic on the Ethernet1/0/1 port to occupy at most 20%
of the bandwidth on the port.
<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] multicast-suppression 20

# Set the maximum number of multicast packets that can be received per second by the
Ethernet1/0/1 port to 1000 pps.
[H3C-Ethernet1/0/1] multicast-suppression pps 1000

1.1.23 port access vlan

Syntax

port access vlan vlan-id


undo port access vlan

View

Ethernet port view

1-23
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Parameter

vlan-id: VLAN ID defined in IEEE802.1Q, in the range of 1 to 4094.

Caution:

All access ports belong to VLAN 1, which is the default VLAN of the system, so you are
not allowed to add an access port to VLAN 1 or remove an access port from VLAN 1.
Otherwise, the system will prompt: “Can't delete ports from or add ports to the default
VLAN!”.

Description

Use the port access vlan command to add the access port into the specified VLAN.
Use the undo port access vlan command to remove the access port from the
specified VLAN.
You must specify the ID of an existing VLAN in the command.

Example

# Add Ethernet1/0/1 into VLAN 3.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] vlan 3
[H3C-vlan3] quit
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] port access vlan 3
[H3C-Ethernet1/0/1]

1.1.24 port hybrid pvid vlan

Syntax

port hybrid pvid vlan vlan-id


undo port hybrid pvid

View

Ethernet port view

Parameter

vlan-id: VLAN ID defined in IEEE802.1Q, in the range of 1 to 4094. It is 1 by default.

1-24
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Description

Use the port hybrid pvid vlan command to set the default VLAN ID for the hybrid port.
Use the undo port hybrid pvid command to restore the default VLAN ID of the port.
Related command: port link-type.

Caution:

You are recommended to set the default VLAN ID of the local hybrid or trunk ports to
the same value as that of the hybrid or trunk ports on the peer switch. Otherwise,
packet forwarding may fail on the ports.

Example

# Set the default VLAN ID of the hybrid port Ethernet1/0/1 to 100.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet1/0/1
[H3C-Ethernet1/0/1] port link-type hybrid
[H3C-Ethernet1/0/1] port hybrid pvid vlan 100

1.1.25 port hybrid vlan

Syntax

port hybrid vlan vlan-id-list { tagged | untagged }


undo port hybrid vlan vlan-id-list

View

Ethernet port view

Parameter

vlan-id-list: VLAN range to which the hybrid port will be added. vlan-id-list = [ vlan-id1
[ to vlan-id2 ] ]&<1-10>, where, vlan-id is in the range of 1 to 4094 and can be discrete,
and &<1-10> means you can input up to ten VLAN IDs/ID ranges.
tagged: Keeps VLAN tags when the packets of the specified VLANs are forwarded on
this port.
untagged: Keeps no VLAN tags when the packets of the specified VLANs are
forwarded on this port.

1-25
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Description

Use the port hybrid vlan command to add the hybrid port into specified VLANs.
Use the undo port hybrid vlan command to remove the hybrid port from specified
VLANs.
A hybrid port can belong to multiple VLANs. When you use the command several times,
all VLAN specified in the commands will be allowed to pass the port.
The VLAN specified by the vlan-id argument must be existing. Otherwise, this
command is invalid. Related command: port link-type.

Example

# Add the hybrid port Ethernet1/0/1 to VLAN 2, VLAN 4 and VLAN 50 through VLAN
100, with tags assigned to their packets.
<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] vlan 2
[H3C-vlan2] quit
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] port link-type hybrid
[H3C-Ethernet1/0/1] port hybrid vlan 2 4 50 to 100 tagged
Operation complete, except these VLAN(s):
Non-existent VLAN(s)

1.1.26 port link-type

Syntax

port link-type { access | hybrid | trunk }


undo port link-type

View

Ethernet port view

Parameter

access: Sets the port as an access port.


hybrid: Sets the port as a hybrid port.
trunk: Sets the port as a trunk port.

Description

Use the port link-type command to set the link type of the current Ethernet port.
Use the undo port link-type command to restore the default link type.

1-26
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

By default, the link type of any port is access.


Pay attention to the following:
The four types of ports can co-exist on the same Ethernet switch. However, the trunk,
hybrid ports cannot be directly switched between the three types (trunk, hybrid). To set
a trunk/hybrid port to another type (different from access), you must first set the port to
an access port and then set the access port to the required type. For example, a trunk
port cannot be set to a hybrid port directly. You must set the trunk port to an access port
and then set it to a hybrid port.

Example

# Set Ethernet1/0/1 as a trunk port.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] port link-type trunk

1.1.27 port trunk permit vlan

Syntax

port trunk permit vlan { vlan-id-list | all }


undo port trunk permit vlan { vlan-id-list | all }

View

Ethernet port view

Parameter

vlan-id-list: VLAN range to which the trunk port will be added. vlan-id-list = [ vlan-id1 [ to
vlan-id2 ] ]&<1-10>, where, vlan-id is in the range of 1 to 4094 and can be discrete, and
&<1-10> means you can input up to ten VLAN IDs/ID ranges.
all: Adds the trunk port into all VLANs.

Description

Use the port trunk permit vlan command to add the trunk port into the specified
VLAN.
Use the undo port trunk permit vlan command to remove the hybrid port from the
specified VLAN.
A trunk port can belong to multiple VLANs. When you use the command several times,
all VLAN specified in the commands will be allowed to pass the port.
Related command: port link-type.

1-27
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Example

# Add the trunk port Ethernet1/0/1 to VLAN 2, VLAN 4 and VLAN 50 through VLAN
100.
<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet1/0/1
[H3C-Ethernet1/0/1] port link-type trunk
[H3C-Ethernet1/0/1] port trunk permit vlan 2 4 50 to 100
Please wait... Done.

1.1.28 port trunk pvid vlan

Syntax

port trunk pvid vlan vlan-id


undo port trunk pvid

View

Ethernet port view

Parameter

vlan-id: VLAN ID defined in IEEE802.1Q, in the range of 1 to 4094. It is 1 by default.

Description

Use the port trunk pvid vlan command to set the default VLAN ID for the trunk port.
Use the undo port trunk pvid command to restore the default setting.
To guarantee the proper packet transmission, the default VLAN ID of the local trunk port
must be identical with that of the trunk port on the peer switch connected with the local
trunk port.
Related command: port link-type.

Example

# Set the default VLAN ID of the trunk port Ethernet1/0/1 to 100.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] port link-type trunk
[H3C-Ethernet1/0/1] port trunk pvid vlan 100

1-28
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

1.1.29 reset counters interface

Syntax

reset counters interface [ interface-type | interface-type interface-number ]

View

User view

Parameter

interface-type: Port type.


interface-number: Port number.
For details about the parameters, see the parameter description of the interface
command.

Description

Use the reset counters interface command to clear the statistics of the port, preparing
for a new statistics collection.
If you specify neither port type nor port number, the command clears statistics of all
ports.
If specify only port type, the command clears statistics of all ports of this type.
If specify both port type and port number, the command clears statistics of the specified
port.
The statistics of the 802.1x-enabled ports cannot be cleared.

Example

# Clear the statistics of Ethernet1/0/1.


<H3C> reset counters interface ethernet1/0/1

1.1.30 shutdown

Syntax

shutdown
undo shutdown

View

Ethernet port view

Parameter

None

1-29
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Description

Use the shutdown command to disable an Ethernet port.


Use the undo shutdown command to enable an Ethernet port.
By default, an Ethernet port is enabled.

Example

# Enable Ethernet1/0/1.
<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] shutdown
[H3C-Ethernet1/0/1] undo shutdown

1.1.31 speed

Syntax

speed { 10 | 100 | 1000 | auto }


undo speed

View

Ethernet port view

Parameter

10: Specifies the port speed to 10 Mbps.


100: Specifies the port speed to 100 Mbps.
1000: Specifies the port speed to 1000 Mbps (this argument is valid for Gigabit ports
only).
auto: Specifies the port speed to the auto-negotiation mode.

Description

Use the speed command to set the port speed.


Use the undo speed command to restore the port speed to the default setting.
By default, the port speed is in the auto-negotiation mode.
Note that the speed of a Gigabit port can be set to 1000 Mbps or auto-negotiation mode
only.
Related command: duplex.

Example

# Set the speed of Ethernet1/0/1 to 10 Mbps.

1-30
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] speed 10

1.1.32 unicast-suppression

Syntax

unicast-suppression { ratio | pps max-pps }


undo unicast-suppression

View

Ethernet port view

Parameter

ratio: Maximum ratio of received unknown unicast traffic to the total bandwidth on the
Ethernet port. The value ranges from 1 to 100 (in step of 1) and defaults to 100. The
smaller the ratio is, the lesser unknown unicast traffic is allowed to be received.
max-pps: Maximum number of unknown unicast packets allowed to be received per
second on the Ethernet port (in pps). The value ranges from 1 to 148,810.

Description

Use the unicast-suppression command to limit the unknown unicast traffic allowed to
be received on the current port.
Use the undo broadcast-suppression command to restore the default unknown
unicast suppression setting on the port.
When incoming unknown unicast traffic exceeds the unknown unicast traffic threshold
you set, the system drops the packets exceeding the threshold to reduce the unknown
unicast traffic ratio to the reasonable range, so as to keep normal network service.
By default, the switch does not suppress unknown unicast traffic.

Example

# Allow unknown incoming unicast traffic on the Ethernet1/0/1 port to occupy at most
20% of the bandwidth on the port.
<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface ethernet 1/0/1
[H3C-Ethernet1/0/1] unicast-suppression 20

# Set the maximum number of unknown unicast packets that can be received per
second by the Ethernet1/0/1 port to 1000 pps.

1-31
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

[H3C-Ethernet1/0/1] unicast-suppression pps 1000

1.1.33 virtual-cable-test

Syntax

virtual-cable-test

View

Ethernet port view

Parameter

None

Description

Use the virtual-cable-test command to enable the system to test the cable connected
to a specific port and to display the results. The system can test these attributes of the
cable:
Cable status, including normal, abnormal, abnormal-open, abnormal-short and failure
Cable length

Note:
z If the cable is in normal state, the displayed length value is the total length of the
cable.
z If the cable is in any other state, the displayed length value is the length from the
port to the faulty point.
z Currently, the following testing functions are available on an S3100-52P switch:
cable status testing and Cable length testing.

Pair impedance mismatch


Pair skew
Pair swap
Pair polarity
Insertion loss
Return loss
Near-end crosstalk
By default, the system does not test the cable connected to the Ethernet port.

1-32
Command Manual – Port Basic Configuration Chapter 1 Port Basic Configuration
H3C S3100-52P Ethernet Switch Commands

Note:
The combo port does not support the virtual-cable-test command.

Example

# Enable the system to test the cable connected to Ethernet1/0/1.


<H3C> system-view
System View: return to User View with Ctrl+Z.
[H3C] interface Ethernet1/0/1
[H3C-Ethernet0/1] virtual-cable-test
Cable status: abnormal(open), 7 metres
Pair Impedance mismatch: yes
Pair skew: 4294967294 ns
Pair swap: swap
Pair polarity: normal
Insertion loss: 7 db
Return loss: 7 db
Near-end crosstalk: 7 db

1-33

You might also like