Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 5

BGP(BORDER GATEWAY PROTOCOL)

Router0 Configuration
Router>
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int gi0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
Router(config-if)#^Z
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int gi0/1
Router(config-if)#ip address 172.16.1.1 255.255.0.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int loopback ?
<0-2147483647> Loopback interface number
Router(config)#int loopback0
Router(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
Router(config-if)#ip address 10.10.10.10 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router#sh run
interface Loopback0
ip address 10.10.10.10 255.0.0.0
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 172.16.16.1 255.255.0.0
duplex auto
speed auto
!
Router(config)#router ?
Bgp- Border Gateway Protocol (BGP)
Eigrp- Enhanced Interior Gateway Routing Protocol (EIGRP)
Ospf- Open Shortest Path First (OSPF)
Rip- Routing Information Protocol (RIP)
Router(config)#router bgp ?
<1-65535>- Autonomous system number
Router(config)#router bgp 65001
Router(config-router)#?
Bgp- BGP specific commands
Distance- Define an administrative distance
Exit- Exit from routing protocol configuration mode
Neighbor- Specify a neighbor router
Network- Specify a network to announce via BGP
No- Negate a command or set its defaults
Redistribute- Redistribute information from another routing protocol
Synchronization- Perform IGP synchronization
Timers- Adjust routing timers
Router(config-router)#neighbor ?
A.B.C.D Neighbor address
Router(config-router)#neighbor 172.16.1.2 ?
next-hop-self Disable the next hop calculation for this neighbor
remote-as- Specify a BGP neighbor
Router(config-router)#neighbor 172.16.1.2 remote-as 65002(where 65002 is the ASN of 2 nd
router)
Router(config-router)#?
Bgp- BGP specific commands
Distance- Define an administrative distance
Exit- Exit from routing protocol configuration mode
Neighbor- Specify a neighbor router
Network- Specify a network to announce via BGP
No- Negate a command or set its defaults
Redistribute- Redistribute information from another routing protocol
Synchronization- Perform IGP synchronization
Timers- Adjust routing timers
Router(config-router)#network ?
A.B.C.D Network number
Router(config-router)#network 10.10.10.10 ?
mask Network mask
Router(config-router)#network 10.10.10.10 mask 255.0.0.0
Router(config-router)#network 192.168.1.0 mask 255.255.255.0
Router(config-router)#?
Bgp- BGP specific commands
Distance- Define an administrative distance
Exit- Exit from routing protocol configuration mode
Neighbor- Specify a neighbor router
Network- Specify a network to announce via BGP
Router(config-router)#no ?
Bgp- BGP specific commands
distance- Define an administrative distance
neighbor- Specify a neighbor router
network- Specify a network to announce via BGP
redistribute- Redistribute information from another routing protocol
synchronization- Perform IGP synchronization
timers- Adjust routing timers
Router(config-router)#no synchronization
Router(config-router)#exit
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#sh run
Router#sh ip ro
Router#sh ip bgp

Router1 Configuration
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int gi0/1
Router(config-if)#ip address 172.16.1.2 255.255.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
Router(config-if)#^Z
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int gi0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
Router(config-if)#^Z
Router#
outer#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int loopback0

Router(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up

Router(config-if)#ip address 20.20.20.20 255.0.0.0


Router(config-if)#no shut
Router(config-if)#exit
Router#sh run
!
interface Loopback0
ip address 20.20.20.20 255.0.0.0
!
interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 172.16.1.2 255.255.0.0
duplex auto
speed auto
!
Router(config)#router ?
Router(config)#router bgp 65002
Router(config-router)#neighbor ?
A.B.C.D Neighbor address
Router(config-router)#neighbor 172.16.1.1 remote-as 65001(where 65001 is the ASN of 1 st
router)
Router(config-router)#network ?
Router(config-router)#network 20.20.20.20 mask 255.0.0.0
Router(config-router)#network 192.168.2.0 mask 255.255.255.0
Router(config-router)#no synchronization
Router(config-router)#exit
Router(config)#^Z
Router#sh run
Router#sh ip ro
Router#sh ip bgp

You might also like