Download as pdf or txt
Download as pdf or txt
You are on page 1of 5

Download PNETLab Platform

PNETLAB Store
PNETLab.com

IPv6 Tunneling over IPv4

Lab Topology:
Please use the following topology to complete this lab exercise:

Lab Objective:
The objective of this lab exercise is for you to learn and understand how can you configure IPv6
tunneling over IPv4

Task list:
Task 1: Configure the hostname and IP address, EIGRP routing for Routers as topo. Check the
reachability between Routers.
Task 2: Create tunnel encapsulate IPv6 traffic between R1 and R3. Tunnel running mode GRE.
Task 3: Config RIPNG between R1 and R3 via tunnel created in Task 2.
Task 4: Check IPv6 Reachability between R1 and R3 via tunnel.

SOLUTION:
Task 1: Configure the hostname and IP address, EIGRP routing for Routers as topo. Check the
reachability between Routers.
On R1
!
1
Download PNETLab Platform
PNETLAB Store
PNETLab.com

interface Ethernet0/0
ip address 10.1.12.1 255.255.255.0
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255On R1
!
router eigrp 10
network 1.1.1.1 0.0.0.0
network 10.1.12.0 0.0.0.255
!
On R2
!
interface Ethernet0/0
ip address 10.1.12.2 255.255.255.0
!
interface Ethernet0/1
ip address 10.1.23.2 255.255.255.0
!
On R3
!
interface Ethernet0/1
ip address 10.1.23.3 255.255.255.0
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
router eigrp 10
network 3.3.3.3 0.0.0.0
network 10.1.23.0 0.0.0.255
!
Verification:
R1#show ip route eigrp
Gateway of last resort is not set

3.0.0.0/32 is subnetted, 1 subnets


D 3.3.3.3 [90/435200] via 10.1.12.2, 00:40:42, Ethernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.23.0/24 [90/307200] via 10.1.12.2, 00:40:47, Ethernet0/0

R3#show ip route eigrp


Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets


D 1.1.1.1 [90/435200] via 10.1.23.2, 00:41:22, Ethernet0/1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

2
Download PNETLab Platform
PNETLAB Store
PNETLab.com

D 10.1.12.0/24 [90/307200] via 10.1.23.2, 00:41:22, Ethernet0/1

R3#ping 1.1.1.1 source l0


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 3.3.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Task 2: Create tunnel encapsulate IPv6 traffic between R1 and R3. Tunnel running mode GRE.
On R1
!
interface Tunnel0
no ip address
tunnel source Loopback0
tunnel destination 3.3.3.3
!
On R3
!
interface Tunnel0
no ip address
tunnel source Loopback0
tunnel destination 1.1.1.1
!
Verification:
R1#show interfaces tunnel0
Tunnel0 is up, line protocol is up
Hardware is Tunnel
MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel linestate evaluation up
Tunnel source 1.1.1.1 (Loopback0), destination 3.3.3.3
Tunnel Subblocks:
src-track:
Tunnel0 source tracking subblock associated with Loopback0
Set of tunnels with source Loopback0, 1 member (includes
iterators), on interface <OK>
Tunnel protocol/transport GRE/IP

R3#show interfaces tunnel0


Tunnel0 is up, line protocol is up
Hardware is Tunnel
MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,
reliability 255/255, txload 1/255, rxload 1/255
3
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Encapsulation TUNNEL, loopback not set


Keepalive not set
Tunnel linestate evaluation up
Tunnel source 3.3.3.3 (Loopback0), destination 1.1.1.1
Tunnel Subblocks:
src-track:
Tunnel0 source tracking subblock associated with Loopback0
Set of tunnels with source Loopback0, 1 member (includes
iterators), on interface <OK>
Tunnel protocol/transport GRE/IP
Task 3: Config RIPNG between R1 and R3 via tunnel created in Task 2.
On R1
!
ipv6 unicast-routing
!
ipv6 router rip RIP13
!
interface Tunnel0
no ip address
ipv6 enable
ipv6 rip RIP13 enable
!
!
interface Loopback0
ipv6 address 2001::1/64
ipv6 enable
ipv6 rip RIP13 enable
!
On R3
!
ipv6 unicast-routing
!
ipv6 router rip RIP13
!
interface Tunnel0
no ip address
ipv6 enable
ipv6 rip RIP13 enable
!
interface Loopback0
ipv6 address 2003::3/64
ipv6 enable
ipv6 rip RIP13 enable
!

4
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Task 4: Check IPv6 Reachability between R1 and R3 via tunnel.


On R1
R1#show ipv6 interface brief | exclude as
Ethernet0/0 [up/up]
Ethernet0/1 [up/up]
Ethernet0/2 [up/up]
Ethernet0/3 [up/up]
Loopback0 [up/up]
FE80::A8BB:CCFF:FE00:F00
2001::1
Tunnel0 [up/up]
FE80::A8BB:CCFF:FE00:F00

R1#show ipv6 route rip


R 2003::/64 [120/2]
via FE80::A8BB:CCFF:FE00:D00, Tunnel0

R3#show ipv6 interface brief | exclude as


Ethernet0/0 [up/up]
Ethernet0/1 [up/up]
Ethernet0/2 [up/up]
Ethernet0/3 [up/up]
Loopback0 [up/up]
FE80::A8BB:CCFF:FE00:D00
2003::3
Tunnel0 [up/up]
FE80::A8BB:CCFF:FE00:D00

R3#show ipv6 route rip


R 2001::/64 [120/2]
via FE80::A8BB:CCFF:FE00:F00, Tunnel0

R1#ping 2003::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2003::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

R3#ping 2001::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

You might also like