Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 3

Basic Router Configuration

==========================
1. Configuring Router Hostname
-------------------------------
Router(config)#hostname AIUB

2. Securing Privileged EXEC Mode


--------------------------------
AIUB(config)#enable password cricket
Saves the password in plain-text format in the configuration file. Hence, not
secured!

AIUB(config)#enable secret cricket


Saves the password in encrypted format using MD5 encryption technology. So,
secured!

3. Securing all the ways to access the Router


---------------------------------------------
AIUB(config)#line console 0
AIUB(config-line)#password football
AIUB(config-line)#login
AIUB(config-line)#exit

AIUB(config)#line vty 0 4
AIUB(config-line)#password baseball
AIUB(config-line)#login
AIUB(config-line)#exit

4. Enabling Password Encryption Service


---------------------------------------
AIUB(config)#service password-encryption

5. Enabling IPv6 Unicast Routing


--------------------------------
AIUB(config)#ipv6 unicast-routing

6. Configuring IP Addressing
----------------------------
AIUB(config)#interface fastEthernet 0/0
AIUB(config-if)#description Connection to User LAN
AIUB(config-if)#ip address 172.16.1.1 255.255.255.0
AIUB(config-if)#ipv6 address 2001:211:A:1::1/64
AIUB(config-if)#no shutdown
AIUB(config-if)#exit

AIUB(config)#interface fastEthernet 0/1


AIUB(config-if)#description Connection to Server LAN
AIUB(config-if)#ip address 172.16.2.1 255.255.255.240
AIUB(config-if)#ipv6 address 2001:211:A:2::1/64
AIUB(config-if)#no shutdown
AIUB(config-if)#exit

7. Configuring User Database and enable in-band login


-----------------------------------------------------
AIUB(config)#username admin secret admin123
AIUB(config)#username jradmin secret jradmin123

AIUB(config)#line console 0
AIUB(config-line)#login local
AIUB(config-line)#exit

AIUB(config)#line vty 0 4
AIUB(config-line)#login local
AIUB(config-line)#exit

8. Configuring IP Domain Name


-----------------------------
AIUB(config)#ip domain-name aiub.edu

9. Configuring SSH
------------------
AIUB(config)#crypto key generate rsa

AIUB(config)#line vty 0 4
AIUB(config-line)#transport input ssh
AIUB(config-line)#exit

To SSH from PC: C:\>ssh -l admin 172.16.1.1

Configuring additional SSH Parameters:


AIUB(config)#ip ssh version 2
AIUB(config)#ip ssh time-out 60
AIUB(config)#ip ssh authentication-retries 5

To copy running-config to startup-config: AIUB#copy running-config startup-config


To copy running-config to TFTP Server: AIUB#copy running-config tftp:

10. Configuring Basic Switch Configuration


-------------------------------------------
Switch(config)#hostname ULSw
ULSw(config)#enable secret cricket
ULSw(config)#line console 0
ULSw(config-line)#password football
ULSw(config-line)#login
ULSw(config-line)#exit
ULSw(config)#line vty 0 4
ULSw(config-line)#password baseball
ULSw(config-line)#login
ULSw(config-line)#exit
ULSw(config)#service password-encryption
ULSw(config)#username admin secret admin123
ULSw(config)#username jradmin secret jradmin123
ULSw(config)#line console 0
ULSw(config-line)#login local
ULSw(config-line)#exit
ULSw(config)#line vty 0 4
ULSw(config-line)#login local
ULSw(config-line)#exit
ULSw(config)#interface vlan 1
ULSw(config-if)#ip address 172.16.1.254 255.255.255.0
ULSw(config-if)#no shutdown
ULSw(config-if)#exit
ULSw(config)#ip default-gateway 172.16.1.1

11. Configuring Banner Message of the Day


-----------------------------------------
AIUB(config)#banner motd #Unauthorized Access Prohibited!#
12. Configure minimum password length
-------------------------------------
AIUB(config)#security passwords min-length 8

You might also like