Router Connectivity

You might also like

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 3

Connecting three routers on different networks via the command line involves setting up routing

tables and using routing protocols. Below is a step-by-step guide on how to achieve this. The
example assumes the use of Cisco IOS commands, but similar principles apply to other routers.

Example Network Layout:

 Router A (RA):
o Network 192.168.6.1/24
 Router B (RB):
o Network 192.168.6.2/24
 Router C (RC):
o Network 192.168.7.2/24

Steps:

1. Configure Interfaces

Assign IP addresses to the interfaces that connect the routers.

Router A (RA):

bash
RA> enable

RA# configure terminal

RA(config)# interface GigabitEthernet0/0/0

RA(config-if)# ip address 192.168.6.1 255.255.255.0

RA(config-if)# no shutdown

RA(config-if)# exit

RA(config)# interface GigabitEthernet0/0/2

RA(config-if)# ip address 192.168.6.1 255.255.255.252

RA(config-if)# no shutdown

RA(config-if)# exit
Router B (RB):

RB> enable

RB# configure terminal

RB(config)# interface GigabitEthernet0/0/0

RB(config-if)# ip address 192.168.6.2 255.255.255.0

RB(config-if)# no shutdown

RB(config-if)# exit

RB(config)# interface GigabitEthernet0/0/1

RB(config-if)# ip address 10.0.0.2 255.255.255.252

RB(config-if)# no shutdown

RB(config-if)# exit

Router C (RC):

RC> enable

RC# configure terminal

RC(config)# interface GigabitEthernet0/0/0

RC(config-if)# ip address 192.168.7.2 255.255.255.0

RC(config-if)# no shutdown

RC(config-if)# exit

RC(config)# interface GigabitEthernet0/0/1

RC(config-if)# ip address 10.0.0.6 255.255.255.252

RC(config-if)# no shutdown

RC(config-if)# exit

Router A (RA):

RA(config)# ip route 192.168.6.1 255.255.255.0 10.0.0.2


RA(config)# ip route 192.168.6.1 255.255.255.0 10.0.0.2

Router B (RB):

RB(config)# ip route 192.168.6.2 255.255.255.0 10.0.0.1

RB(config)# ip route 192.168.6.2 255.255.255.0 10.0.0.1

Router C (RC):

RC(config)# ip route 192.168.7.2 255.255.255.0 10.0.0.5

RC(config)# ip route 192.168.7.2 255.255.255.0 10.0.0.5

Verify Connectivity

Use the ping command to verify that the routers can communicate with each other.

RA# ping 192.168.6.1

RA# ping 192.168.6.1

RB# ping 192.168.6.2

RB# ping 192.168.6.1

RC# ping 192.168.7.2

RC# ping 192.168.7.1

You might also like