Download as pdf or txt
Download as pdf or txt
You are on page 1of 7

Configuración Inicial del Router

Router> enable

Router# configure terminal

Router(config)# hostname R1

R1(config)# enable secret class

R1(config)# service password-encryption

R1(config)# banner motd #

R1(config)# ipv6 unicast-routing

Configuración de las Líneas de Consola y VTY


R1(config)# line console 0

R1(config-line)# logging synchronous

R1(config-line)# password cisco

R1(config-line)# login

R1(config-line)# exit

R1(config)# line vty 0 4

R1(config-line)# password cisco

R1(config-line)# login

R1(config-line)# transport input ssh telnet

R1(config-line)# exit

Configuración de Interfaces
R1(config)# interface gigabitethernet 0/0/0

R1(config-if)# description Link to LAN 1

R1(config-if)# ip address 10.0.1.1 255.255.255.0

R1(config-if)# ipv6 address 2001:db8:acad:1::1/64

R1(config-if)# ipv6 address fe80::1:a link-local


R1(config-if)# no shutdown

R1(config-if)# exit

R1(config)# interface gigabitethernet 0/0/1

R1(config-if)# description Link to LAN 2

R1(config-if)# ip address 10.0.2.1 255.255.255.0

R1(config-if)# ipv6 address 2001:db8:acad:2::1/64

R1(config-if)# ipv6 address fe80::1:b link-local

R1(config-if)# no shutdown

R1(config-if)# exit

R1(config)# interface serial 0/1/1

R1(config-if)# description Link to R2

R1(config-if)# ip address 10.0.3.1 255.255.255.0

R1(config-if)# ipv6 address 2001:db8:acad:3::1/64

R1(config-if)# ipv6 address fe80::1:c link-local

R1(config-if)# no shutdown

R1(config-if)# exit

Configuración de DHCP
R1(config)# ip dhcp excluded-address 10.0.1.1 10.0.1.10

R1(config)# ip dhcp pool LAN1

R1(dhcp-config)# network 10.0.1.0 255.255.255.0

R1(dhcp-config)# default-router 10.0.1.1

R1(dhcp-config)# dns-server 8.8.8.8

R1(dhcp-config)# exit

R1(config)# ip dhcp excluded-address 10.0.2.1 10.0.2.10

R1(config)# ip dhcp pool LAN2


R1(dhcp-config)# network 10.0.2.0 255.255.255.0

R1(dhcp-config)# default-router 10.0.2.1

R1(dhcp-config)# dns-server 8.8.8.8

R1(dhcp-config)# exit

Configuración de Rutas Estáticas


Router(config)# ip route 172.16.1.0 255.255.255.0 s0/1/0

Router(config)# ip route 172.16.1.0 255.255.255.0 GigabitEthernet 0/0/1 172.16.2.2

Router(config)# ip route 192.168.2.0 255.255.255.0 192.168.1.1

Router(config)# ip route 172.16.3.0 255.255.255.0 g0/0/1 172.16.2.1

Router(config)# ip route 172.16.3.0 255.255.255.0 s0/1/1

Router(config)# ip route 0.0.0.0 0.0.0.0 {ip-address | exit-intf}

Comandos de Verificación de Rutas


R1# show ip route

R1# show ip route static

R1# show ipv6 route static

R1# show running-config | section ip route

R1# show ip route 192.168.2.1

R1# show ip route static

Configuración de OSPF
Router(config)# router ospf 1

Router(config-router)# network 10.0.1.0 0.0.0.255 area 0

Router(config-router)# network 10.0.2.0 0.0.0.255 area 0

Router(config-router)# network 10.0.3.0 0.0.0.255 area 0

Router(config-router)# exit
Verificación de OSPF
Router# show ip ospf neighbor

Router# show ip ospf database

Router# show ip ospf interface

Router# show ip ospf

Router# show ip route ospf

Router# show ip ospf interface gigabitethernet 0/0/0

Router# show ip ospf interface gigabitethernet 0/0/1

Router# show ip ospf interface serial 0/1/1

Configuración de NAT Estática


R2(config)# ip nat inside source static 192.168.10.254 209.165.201.5

R2(config)# interface serial 0/1/0

R2(config-if)# ip address 192.168.1.2 255.255.255.252

R2(config-if)# ip nat inside

R2(config-if)# exit

R2(config)# interface serial 0/1/1

R2(config-if)# ip address 209.165.200.1 255.255.255.252

R2(config-if)# ip nat outside

Configuración de NAT Dinámica


R2(config)# ip nat pool NAT-POOL1 209.165.200.226 209.165.200.240 netmask 255.255.255.224

R2(config)# access-list 1 permit 192.168.0.0 0.0.255.255

R2(config-if)# ip nat inside source list 1 pool NAT-POOL1

R2(config)# interface serial 0/1/0

R2(config-if)# ip nat inside

R2(config)# interface serial 0/1/1


R2(config-if)# ip nat outside

Configuración de PAT para usar una Única Dirección IPv4


R2(config)# ip nat inside source list 1 interface serial 0/1/1 overload

R2(config)# access-list 1 permit 192.168.0.0 0.0.255.255

R2(config)# interface serial0/1/0

R2(config-if)# ip nat inside

R2(config-if)# exit

R2(config)# interface Serial0/1/1

R2(config-if)# ip nat outside

Configuración de PAT para usar una Address Pool


R2(config)# ip nat pool NAT-POOL2 209.165.200.226 209.165.200.240 netmask 255.255.255.224

R2(config)# access-list 1 permit 192.168.0.0 0.0.255.255

R2(config)# ip nat inside source list 1 pool NAT-POOL2 overload

R2(config)# interface serial0/1/0

R2(config-if)# ip nat inside

R2(config-if)# exit

R2(config)# interface serial0/1/1

R2(config-if)# ip nat outside

R2(config-if)# end

Verificación de PAT y NAT


R2# show ip nat translations

R2# show ip nat translation verbose

R2# show ip nat statistics

R2# show running-config | include NAT


Borrar Entradas Dinámicas de NAT
R2# clear ip nat translation *

R2# show ip nat translation

Guardar la Configuración
R1# copy running-config startup-config

You might also like