Download as pptx, pdf, or txt
Download as pptx, pdf, or txt
You are on page 1of 20

EIGRP LAB Trick

Specify the interface that is running the EIGRP process by specifying


the interface ip address with Wide card mask .
For example :

Router Eigrp 100


network 155.1.0.1 0.0.0.0

In this way only the interface with IP address 155.1.0.1 will run the
EIGRP process
EIGRP in named Mode
To configure the EIGRP in named mode , we should implement the following configuration

# router eigrp MULTI-AF


# address-family ipv4 unicast autonomous-system 100
# network 150.1.0.0
#network 155.1.0.0
#exit

The configuration is applied at the af-interface level .


# router eigrp MULTI-AF
# address-family ipv4 unicast autonomous-system 100
# af-interface tunnel 0
# no split-horizon EIGRP 100
EIGRP MD5 & SHA-256 Authentication

EIGRP support MD5 in the classic mode and SHA-256 in named mode
# key chain MD5_KEYS
key 1
key-string MD5_PASS

router eigrp MULTI-AF


address-family ipv4 unicast autonomous-system 100
# af-interface GigabitEthernet1.146
# authentication mode md5
# authentication key-chain MD5_KEYS

# af-interface Tunnel0
authentication mode hmac-sha-256 SHA_KEY
Authentication in classic mode
# key chain MD5_KEYS
key 1
key-string MD5_PASS
!
# interface GigabitEthernet1.67

# ip authentication mode eigrp 100 md5


# ip authentication key-chain eigrp 100 MD5_KEYS

the lowest active key number will be exchanged in EIGRP packets. Note that the key ID must
match for authentication to occur, because this number is exchanged in the hello packets

in Classic Mode, the authentication is applied at the link level, whereas in Named Mode it is
applied at the af-interface mode under the SAFI. In either case, the authentication can be
EIGRP Key Chain Rotation

- Whenever time-based authentication is configured, ensure that all devices agree on the
same time.
First you have to make sure the NTP server is setup correctly .
In the server you configure the NTP master :
# ntp master 1
And in the client configure the NTP client :
# ntp server 155.1.0.5

R#show ntp status

Clock is synchronized, stratum 1, reference is .LOCL.


Key chain rotation setting

Example of Key Chain rotation :

- R4, and R5 with a key-chain named KEY_ROTATION as follows:


- Create key ID 10 with the password CISCO10.
- Create key ID 20 with the password CISCO20.
- Key ID 10 should be used from 00:00:00 Jan 1 1993 until 00:05:00 Jan 1
2030, and should be accepted for 10 minutes past this time.
- Key ID 20 should be sent starting at 00:00:00 Jan 1 2030, and should be
accepted any time after this time
# key chain KEY_ROTATION
# key 10
# key-string CISCO10
# accept-lifetime 00:00:00 Jan 1 1993 00:15:00 Jan 1 2030
# send-lifetime 00:00:00 Jan 1 1993 00:05:00 Jan 1 2030
# key 20
# key-string CISCO20
#accept-lifetime 00:00:00 Jan 1 2030 infinite
#send-lifetime 00:00:00 Jan 1 2030 infinite

interface Tunnel0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 KEY_ROTATION
EIGRP Unicast Updates
Configure R4 and R5 so that they exchange EIGRP packets only as unicasts with
each other on the DMVPN network.
unlike RIP, the passive-interface command is not needed to suppress the sending of the multicast
hellos.
R4:
router eigrp 100
network 155.1.0.0 0.0.0.255
neighbor 155.1.0.5 Tunnel0
R5:
router eigrp MULTI-AF
address-family ipv4 unicast autonomous-system 100
topology base
exit-af-topology
neighbor 155.1.0.4 Tunnel0
network 155.1.0.0 0.0.0.255
exit-address-family
EIGRP Summarization
Like RIP, EIGRP supports summarization at the interface level anywhere throughout
the topology, but it does not have the limitation of being unable to summarize
beyond the classful boundary

Configure the following interfaces on R4, and redistribute them into EIGRP:
Loopback40 - 4.0.0.4/24
Loopback41 - 4.0.1.4/24
Loopback42 - 4.0.2.4/24
Loopback43 - 4.0.3.4/24

#interface Tunnel0
#ip summary-address eigrp 100 4.0.0.0 255.255.252.0

#af-interface GigabitEthernet1.146
#summary-address 6.0.0.0 255.255.252.0
EIGRP redistributed through Route map
Configure the following interfaces on R4, and redistribute them into EIGRP:
Loopback40 - 4.0.0.4/24
Loopback41 - 4.0.1.4/24
Loopback42 - 4.0.2.4/24
Loopback43 - 4.0.3.4/24

ip prefix-list CONNECTED_TO_EIGRP seq 5 permit 4.0.0.0/24


ip prefix-list CONNECTED_TO_EIGRP seq 10 permit 4.0.1.0/24
ip prefix-list CONNECTED_TO_EIGRP seq 15 permit 4.0.2.0/24
ip prefix-list CONNECTED_TO_EIGRP seq 20 permit 4.0.3.0/24
!
route-map CONNECTED_TO_EIGRP permit 10
match ip address prefix-list CONNECTED_TO_EIGRP
!
router eigrp 100
redistribute connected route-map CONNECTED_TO_EIGRP
EIGRP Summarization with Default Routing
EIGRP Summarization with Leak Map
EIGRP Metric Weights
the metrics weights are bandwidth , delay , load , reliability ,

Metric = 256*[(K1*Scaled Bw) + (K2*Scaled Bw)/(256 - Load) + (K3*Scaled Delay)]*[K5/(Reliability + K4)]


The default values for K are:
K1 = 1 Bandwidth
K2 = 0 load
K3 = 1 Delay
K4 = 0
K5 = 0 Reliability

Configure all EIGRP routers so that only delay is used in the composite metric
calculation.

router eigrp 100

metric weights 0 0 0 1 0 0
EIGRP Wide Metric Weights “ in named mode

The Bandwidth is scaled by 65536


The delay is scaled by 65536
In classic mode
router eigrp 100
metric weights 0 0 0 1 0 0

In named mode :
router eigrp MULTI-AF
address-family ipv4 unicast autonomous-system 200
metric weights 0 0 0 1 0 0 0

You might also like