Download as ppt, pdf, or txt
Download as ppt, pdf, or txt
You are on page 1of 24

Course Objectives

Upon completion of this course, you will have:


•Mastered common device management methods.
•Become familiar with command line interfaces (CLIs) and basic commands.
•Gained an understanding of basic router and switch configuration comman
ds.
Course Contents

1. Network Device Management

2. VRP Basics and Configuration Overview


Introduction

On a network, there may be many different types


of devices, including routers, switches, firewalls, l
oad balancers, servers, and computers. During d
atacom project implementation, you need to desig
n and plan data networks for running various data
com devices as well as configure the devices bas
ed on customer requirements, thereby implementi
ng specific network solutions.
To construct a data network, you must first maste
r the configuration and management methods of n
etwork devices.
Console Port

•To configure a device that has been powered on for t


he first time, you can log in to the device through a co
nsole port.
•The console port is a serial port provided by the main
control board of the device.
•Each main control board provides an EIA/TIA-232 D
CE type console port. The serial port of a user termin
al can be directly connected to the console port to imp
lement local device configuration.
Cable Introduction (1)

USB-RS232 Console Cable

One end of a console cable is an RJ45 connector, and the other end is a serial port connector. The RJ45 co
nnector is connected to the RJ45 console port on the device, and the serial port connector is connected to t
he computer. Currently, most desktop computers provide serial ports, and serial ports support console cabl
e connections. However, most laptop computers do not have serial ports. Therefore, if you use a laptop co
mputer, use a USB-RS232 cable for transfer.
Cable Introduction (2)

USB-RS232

Console Cable

Console Port

When you use a USB-RS232 cable, connect the USB end to the USB interface of the laptop computer, the RS232 conn
ector to the serial port of the console cable, and the RJ45 connector of the console cable to the console port of the man
aged device. After connecting the laptop computer and device in this manner, a configuration environment is successfull
y set up. You can then run the terminal emulation program on the computer to perform device management and configur
ation.
SecureCRT Settings

NEXT(N) > Complete Cancel

<BACK(B) NEXT(N) > Cancel


CLI

If cables are connected correctly, use the SecureCRT to log in to the device. After the
login succeeds, the SecureCRT CLI is displayed for you to interact with the device thr
ough commands.

USB-RS232

Console Cable

Console Port
Course Contents

1. Network Device Management

2. VRP Basics and Configuration Overview


VRP

•The Versatile Routing Platform (VRP) is a universal operating platform for


Huawei datacom products. The VRP focuses on IP services and adopts a

modular design. It implements abundant functions and features in addition


to providing application-based tailorability and scalability.
•Like Windows for PCs and iOS for Apple mobile terminals, the VRP is an
operating system for Huawei datacom products.
CLI Window
Command Views (1)

user-interface vty 0 4
User interface view
[Huawei-ui-vty0-4]

interface gi 0/0/0 Interface view


[Huawei-GigabitEthernet0/0/0]

system-view acl 2000


<Huawei> [Huawei] ACL view
[Huawei-acl-basic-2000]
User view System view

vlan 10 VLAN view


[Huawei-vlan-10]

ospf 1
Routing protocol view
[Huawei-ospf-1]
Command Views (2)

<Huawei>
The user view allows you to view simple running status information and
relevant statistics.

quit
system-view

[Huawei]
The system view allows you to configure global system parameters and
enter other function configuration views.

quit Interface GigabitEthernet 0/0/0

[Huawei-GigabitEthernet 0/0/0]
The interface view allows you to configure interface-specific parameters
and functions.
Basic Command Structure

•Each command has a specific format or syntax structure and


needs to be run in the corresponding view.
•Common command format: keyword + parameter

[Huawei] sysname Router1


[Router1]

View identifier Keyword Parameter


CLI Help (1)

•Command prompt
•Command supplement
•Syntax check
CLI Help (2)

• Command prompt

[Huawei] ip rou?
route <Group> route command group
route-static IPv4 static routes
[Huawei] ip route-static ?
IP_ADDR<X.X.X.X> Destination IP address
default-preference Preference-value for IPv4 static-routes
selection-rule Selection rule
vpn-instance VPN-Instance route information
CLI Help (3)

• Command supplement

<huawei> sys[tab]
<huawei> system-view
CLI Help (4)

• Syntax check

[Huawei] sysname
^
Error:Incomplete command found at '^' position.
# The command content at the "^" position is incomplete.

[Huawei] router if 1.1.1.1


^
Error: Unrecognized command found at '^' position.
# The command content at the "^" position cannot be identified.

[Huawei] a
^
Error:Ambiguous command found at '^' position.
# The command content at the "^" position is ambiguous because there are multi
ple keywords beginning with "a".
Command Shortcut Keys

Key Function
Ctrl_A Moves the cursor to the beginning of the current line.
Ctrl_B Moves the cursor one character back.
Ctrl_C Stops the running function.
Ctrl_E Moves the cursor to the end of the current line.
Ctrl_K Terminates the connection of an outgoing call during connection establishment.
Ctrl_R Redisplays information about the current line.
Ctrl_T Terminates the connection of an outgoing call.
Ctrl_V Pastes the text of the clipboard.
Ctrl_W Deletes the character string (word) on the left side of the cursor.
Ctrl_X Deletes all characters on the left side of the cursor.
Deletes the character at the cursor and all characters on the right side of the cu
Ctrl_Y
rsor.
Ctrl_Z Returns to the user view.
Esc_Shift_< Moves the cursor to the start of text in the clipboard.
Esc_Shift_> Moves the cursor to the end of text in the clipboard.
Basic Configuration Commands (1)

•Configure a device name.


<Router> system-view
[Router] sysname R1
•Configure a device clock.
<Huawei> clock datetime 12:00:00 2013-12-20
Basic Configuration Commands (2)

Configure a device interface.


<Router> system-view
[Router] interface GigabitEthernet0/0/0
[Router-GigabitEthernet0/0/0] ip address 10.1.12.1 255.255.255.0
# The interface can also be configured as follows:
[Router-GigabitEthernet0/0/0] ip address 10.1.12.1 24
[Router-GigabitEthernet0/0/0] undo shutdown
Basic Configuration Commands (3)

Enable the Telnet service so that users can remotely log in using a password.
[Quidway] user-interface vty 0 4
[Quidway-ui-vty0-4] authentication-mode password
[Quidway-ui-vty0-4] protocol inbound telnet
[Quidway-ui-vty0-4] set authentication password cipher huawei
[Quidway-ui-vty0-4] quit
[Quidway] super password level 15 cipher huawei15
Configuration File Management

•Save a configuration file. If you save the configuration file for the first time without specifyin
g the configuration-file parameter, the system displays a message asking you whether to na
me the configuration file vrpcfg.zip. The vrpcfg.zip file is the default configuration file with
empty configuration.
<Router> save
•Clear a saved configuration file and restore the factory settings upon the next device restar
t.
<Router> reset saved-configuration
•Back up a configuration file.
<Router> copy flash:/vrpcfg.zip flash:/cfgbackup.zip
Viewing Current Configurations

<Huawei> display current-configuration


sysname Huawei
vlan batch 10 20
cluster enable
Note: After you complete device configuration, the config
ntdp enable
urations that have taken effect determine the functions a
ndp enable
nd services that the device can provide. New configurati
…… ……
ons are dynamically saved to the memory and will be los
interface GigabitEthernet0/0/1 t after a device restart if they are not saved.
port link-type access To prevent such configuration loss, run the save comma
port default vlan 10 nd to save the configurations to the hard disk of the devi
interface GigabitEthernet0/0/2 ce.
port link-type access
port default vlan 20
interface GigabitEthernet0/0/3
…… ……

You might also like